Weird loose rattle sound over bumps in the front end???? (Moved) - Chrysler 300C Forum: 300C & SRT8 Forums
1st Gen SRT8-Specific Wheels/Tires/Brakes/Suspension This section is for topics related to SRT8 wheels, tires, brakes and suspension. For non SRT8-specific topics, please post in the All Models Forums.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 315 (permalink) Old 02-02-2009, 06:23 PM Thread Starter
Senior Member
Points: 15,887, Level: 1 Points: 15,887, Level: 1 Points: 15,887, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
SRT_3Hundy's Avatar
 
Car: 2006 Chrysler 300C SRT8
Join Date: Dec 2008
Location: Houston, TX
Posts: 337
Thanks: 0
Thanked 1 Time in 1 Post
Weird loose rattle sound over bumps in the front end???? (Moved)

Hey fellas,
Ive had my car for about 2 months now and i feel like there is something loose in the front end so im posting this up. Its an 06 SRT8 300C and only has 16,000 miles on it. Its due for brakes which seems normal for the SRT's around the 15,000 mile mark and im about to order the posi quiet pads for it. I need something quiet with good performance that will cut down on the brake dust so i figure thats my answer.

Anyway, back to the front end.... I had the car in at the dealer to check it out under warranty. They replaced the strut tension bars and said it was fixed. Well, ive had the car back now for 2 weeks and that same feel is still there when i hit abrupt bumps in the road. It feel like something maybe tie rod or ball joint related? Anyone else experience this???

Im not sure if im just crazy and being too picky with the car but its been bothering me and im considering taking it to another dealer to get another opinion. Other than this, the car has been great! I forget how fast she is when im just cruising around but when i let her rip... she flys!!! Im loving it!!!!

Thanks for the help guys!!

2006 Silver 300C SRT-8
1996 CE LT4 Vette
2006 Kawasaki ZX6R 636
SRT_3Hundy is offline  
The Following User Says Thank You to SRT_3Hundy For This Useful Post:
Chillwill06 (03-22-2016)
Sponsored Links
Advertisement
 
post #2 of 315 (permalink) Old 02-03-2009, 01:49 PM
Junior Member
Points: 1,171, Level: 1 Points: 1,171, Level: 1 Points: 1,171, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 chrysler 300c
Join Date: Jan 2009
Location: rockport/ont /can
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
My 05 300C has loose rattle from left front, only audible at low speed especially over speed bumps. You'd think it would be sway bar links/rubbers or brake pad separation, but it isn't. Front end is tight ie tie rod ends/ball joints, car runs straight/ no uneven tire wear. A puzzler, I'm still looking!!
chipper is offline  
post #3 of 315 (permalink) Old 02-03-2009, 02:55 PM
Senior Member
Points: 4,351, Level: 1 Points: 4,351, Level: 1 Points: 4,351, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2006 chrysler 300c and 05 infinity G35
Join Date: Jan 2009
Location: San Bruno,CA
Posts: 289
Thanks: 0
Thanked 0 Times in 0 Posts
I have the same problem in my 06 300c,had had the stab. links replaced and its still there.Still cant find it either, ???????????
kd300c is offline  
 
post #4 of 315 (permalink) Old 02-03-2009, 05:22 PM Thread Starter
Senior Member
Points: 15,887, Level: 1 Points: 15,887, Level: 1 Points: 15,887, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
SRT_3Hundy's Avatar
 
Car: 2006 Chrysler 300C SRT8
Join Date: Dec 2008
Location: Houston, TX
Posts: 337
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by kd300c View Post
I have the same problem in my 06 300c,had had the stab. links replaced and its still there.Still cant find it either, ???????????
I believe thats what they replaced on mine. The strut tensioner/stabilizer bars or whatever.

Mine has yet to wear the tires in any odd way and when i take corners, it seems to handle like it should. Its just over abrupt/sudden bumps that you can feel/hear it. The dealer couldnt find it and neither could I. Im sure there is something we must be missing though....
SRT_3Hundy is offline  
post #5 of 315 (permalink) Old 02-03-2009, 08:43 PM
Banned
Points: 7,891, Level: 1 Points: 7,891, Level: 1 Points: 7,891, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 Chrysler 300C
Join Date: Nov 2006
Location: Sudbury, Ontario, Canada
Posts: 1,411
Thanks: 0
Thanked 2 Times in 2 Posts
Drop the pressure by 5 pounds in your tires and take it for a another run over the same road that causes the bumps and the noise will go away.

I find that overinflating the tires is the main culprit.

Try it.
Northern300c is offline  
The Following User Says Thank You to Northern300c For This Useful Post:
Reenie (02-19-2015)
post #6 of 315 (permalink) Old 02-04-2009, 06:54 AM
Senior Member
Points: 3,953, Level: 1 Points: 3,953, Level: 1 Points: 3,953, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 Chrysler 300C
Join Date: Dec 2008
Posts: 148
Thanks: 0
Thanked 1 Time in 1 Post
Could it be the engine bouncing against its mounts?

2005 300C AWD
ray_m is offline  
post #7 of 315 (permalink) Old 02-04-2009, 08:45 AM
Major Contributing Member
Points: 22,356, Level: 1 Points: 22,356, Level: 1 Points: 22,356, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
frankieo's Avatar
 
Car: 2005 chrysler 300 limted
Join Date: Apr 2007
Location: staten island ny
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
I have a 3.5 with the same noise.Brought the car in last week and my mechnic told me I needed all tire rods replaced and 2 torsion bars also replaced.So i asked him will the noise go away and he said yes.Guess what the noise is back a week later and $500 short in my pocket.Going to bring the car back after the snow ends.Just snowed in NY.I will give a update once I talk to him.I just hope they dont keep telling me to replace parts and the noise is still there.
frankieo is offline  
post #8 of 315 (permalink) Old 02-04-2009, 08:56 AM
Senior Member
Points: 2,832, Level: 1 Points: 2,832, Level: 1 Points: 2,832, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
vinster300c's Avatar
 
Car: 2007 chrysler 300c
Join Date: Jan 2009
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
same here going tommorrow...feels like my suspension fell out of the car...update soon..

tinted windows 20%

taillights crome covers

door pillars crome

air intake system

hid lights low/high/foglights

full crome package 300c

mesh grill. blastin bobs pipes 4 inch tips .double din dvd player head unit..srt rear wing

led bulbs interior
vinster300c is offline  
post #9 of 315 (permalink) Old 02-04-2009, 10:06 AM
Major Contributing Member
Points: 22,356, Level: 1 Points: 22,356, Level: 1 Points: 22,356, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
frankieo's Avatar
 
Car: 2005 chrysler 300 limted
Join Date: Apr 2007
Location: staten island ny
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
vinster please post update when you get the car back. let us know what they tell you it seams like everybodys shop says its something else but it looks like nobody figured it out yet where that noise come s from.
frankieo is offline  
post #10 of 315 (permalink) Old 02-04-2009, 12:39 PM Thread Starter
Senior Member
Points: 15,887, Level: 1 Points: 15,887, Level: 1 Points: 15,887, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
SRT_3Hundy's Avatar
 
Car: 2006 Chrysler 300C SRT8
Join Date: Dec 2008
Location: Houston, TX
Posts: 337
Thanks: 0
Thanked 1 Time in 1 Post
What tire pressure do yall run in your tires? Im running 35 indicated on the cluster but when i check it with a manual guage at the stem, its actually around 38-39 PSI. Im running on the SRT 20's if it makes a difference from the 18's the other C's come with...

Ill try lowering it a bit and see what happens. Im planning to take it to another dealer soon though to have it looked at again by some new eyes...
SRT_3Hundy is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Front end rattle over bumps? dreyesjr 1st Gen SRT8-Specific Wheels/Tires/Brakes/Suspension 13 02-13-2016 08:50 PM
Loose Rattle In Front Suspension??? COPPERSHOT General Discussion on Issues / Trouble Shooting 82 01-17-2015 08:53 AM
Front end rattle (Moved) crowell1133 Problems / Dealer Service 7 05-15-2014 08:12 AM
Weird sound from the front end pemond20 Problems / Dealer Service 14 01-16-2011 11:28 PM
Loose Front - Hollow Thump/Rattle over Small Bumps WildTurkey 1st Gen SRT8-Specific Wheels/Tires/Brakes/Suspension 14 01-05-2008 04:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Replace with
For the best viewing experience please update your browser to Google Chrome