Chrysler 300C Forum: 300C & SRT8 Forums - View Single Post - Hemi misfire
Thread: Hemi misfire
View Single Post
post #4 of (permalink) Old 04-19-2017, 03:49 AM Thread Starter
Boro al
Major Contributing Member
Points: 126,714, Level: 1 Points: 126,714, Level: 1 Points: 126,714, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 22% Activity: 22% Activity: 22%
 
Boro al's Avatar
 
Car: 2007 chrysler 300c SRT8 tourer, (00A)
Join Date: May 2009
Location: North East, England, UK
Posts: 1,131
Thanks: 1
Thanked 83 Times in 67 Posts
Update...I checked the car over and it does have a apparent misfire at tickover and when reved, the Autel didn't pick up any misfire codes.

I also noticed a strong smell of petrol under bonnet when the car was started that faded over the next minute or so each time it was started.

The engine sounded sweet as a nut with no rattles.

took it for a short drive and it seemed to drive really well but when it got up to around 40 a really bad stutter started, I thought it may be the MDS not activating properly.

So any ideas on the fuel smell and could that be causing the rough running? and what could the stutter be at 40.

I really like the car but i want to be sure the issues are not too major before i pull the trigger.

Alan.

2006 56 crd tourer Mineral Grey.SOLD
Dec 2007 SRT8 Black tourer with Tints.SOLD
2006 MERC C320 v6 cdi in Black. SOLD
2006 MERC E280 V6 CDI Estate in Blue. SOLD
defected to BMW with a V8 X5. sold

2008 Jeep Grand Cherokee 3ltr crd Overland

Last edited by Boro al; 04-19-2017 at 03:50 AM.
Boro al is offline  
 
 
Replace with
For the best viewing experience please update your browser to Google Chrome