Engine bay grinding noise + vibration - Page 2 - Chrysler 300C Forum: 300C & SRT8 Forums
Interested in the Dodge Challenger? Be sure to check out the Dodge Challenger Forum for your Dodge Challenger information!
Chrysler 300C SRT-8 Header Left Chrysler 300C SRT-8 Logo Right
Go Back   Chrysler 300C Forum: 300C & SRT8 Forums > SRT8 Forums > 2nd Gen SRT8- Mechanical
Register Home Forum Active Topics (T) Gallery Garage Search Today's Posts Mark Forums Read

Like Tree2Likes
Reply
 
LinkBack Thread Tools
Display Modes
Old 04-01-2016, 07:19 PM   #11 (permalink)
Member
 
Car:
Join Date: Mar 2016
Member Number: 126194
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
I have the exact same thing on my 2012 srt8 and it's annoying. I asked two different dealers to look at it and they say nothing is wrong. I cannot believe that the dealer ignores this issue. I even went on a ride with their head Mechanic and he said. Yeah sounds pretty normal to me and try to blow it off. Of course with warranty running out in may of 2016 they'd say that. Dealers suck and I'm fed up. Taking it now to my non corporate non dealer Mechanic who is pricey but can diagnos any sound on a car. I had over heating problems last summer and they couldn't figure that out. Maybe like the last post it's wafter pump. Anyone with news about there srt8 300 with this noise? Updates greatly appreciated!
12srt8392 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-06-2016, 06:41 PM   #12 (permalink)
Junior Member
Points: 187, Level: 1 Points: 187, Level: 1 Points: 187, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 10% Activity: 10% Activity: 10%
 
John_xlc's Avatar
 
Car: 2012 Chrysler 300 SRT8
Join Date: Feb 2016
Member Number: 124554
Location: Alexandria, VA
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Ditto! I have the same issue and same model year. I thought it might be the torque converter going bad but two separate dealerships say nothing is wrong with the car. Oh yeah they replaced my water pump at 16,500 miles. Didn't Chrysler improve their quality assurance to increase power-train dependability or are they just sweeping the issues under the rug?

Last edited by John_xlc; 04-06-2016 at 06:46 PM.
John_xlc is offline   Reply With Quote Quick reply to this message
Old 04-06-2016, 06:45 PM   #13 (permalink)
Member
 
Car:
Join Date: Mar 2016
Member Number: 126194
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Did the water pump fix the sound? Or no? I'm taking it Friday to my non dealer Mechanic to let him listen and possibly talk about the 4 cylinder mode solenoids maybe malfunctioning as the problem. I'm thinking it's going into MPS mode when at idle. Dealer claims eco light would come on if that happens.
12srt8392 is offline   Reply With Quote Quick reply to this message
Old 04-07-2016, 01:38 PM   #14 (permalink)
Junior Member
Points: 187, Level: 1 Points: 187, Level: 1 Points: 187, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 10% Activity: 10% Activity: 10%
 
John_xlc's Avatar
 
Car: 2012 Chrysler 300 SRT8
Join Date: Feb 2016
Member Number: 124554
Location: Alexandria, VA
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Water pump did not solve the noise problem.
John_xlc is offline   Reply With Quote Quick reply to this message
Old 04-07-2016, 03:10 PM   #15 (permalink)
Member
 
Car:
Join Date: Mar 2016
Member Number: 126194
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
So I suppose you just live with the noise. It's a shame that these cars just have this problem. Maybe that's why they never sold many.
12srt8392 is offline   Reply With Quote Quick reply to this message
Old 04-08-2016, 12:42 PM   #16 (permalink)
Junior Member
Points: 187, Level: 1 Points: 187, Level: 1 Points: 187, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 10% Activity: 10% Activity: 10%
 
John_xlc's Avatar
 
Car: 2012 Chrysler 300 SRT8
Join Date: Feb 2016
Member Number: 124554
Location: Alexandria, VA
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
I was told by the service department that the sound may be originating from the exhaust but otherwise the car is running normally. I still don't understand why they would say it is normal after mentioning the exhaust may have an issue.

The 300 SRT still runs like a bat out of hell.

Last edited by John_xlc; 04-10-2016 at 05:15 PM.
John_xlc is offline   Reply With Quote Quick reply to this message
Old 04-08-2016, 12:50 PM   #17 (permalink)
Member
 
Car:
Join Date: Mar 2016
Member Number: 126194
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Went to my mechanic today. With Mechanic stethoscope and we both listened. Coming from exhaust, lifter on cylinder 1, and tensioner on belt. Is where all noises came from. I'm taking it back Monday. Keep yall posted. He knows the dealer in Austin and will personally call him to let him know what the problem is. Lol. I hope this works. He didn't ignore the sound like the dealer did. He definitely heard it and promises he will figure it out Monday and spend a half a day on it
12srt8392 is offline   Reply With Quote Quick reply to this message
Old 04-13-2016, 06:59 AM   #18 (permalink)
Junior Member
Points: 187, Level: 1 Points: 187, Level: 1 Points: 187, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 10% Activity: 10% Activity: 10%
 
John_xlc's Avatar
 
Car: 2012 Chrysler 300 SRT8
Join Date: Feb 2016
Member Number: 124554
Location: Alexandria, VA
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Another thing to consider is the Stability control. When I turned it off this morning, the sound seemed to diminish. Not sure if it was coincidental but it was an observation.
__________________
John_xlc
John_xlc is offline   Reply With Quote Quick reply to this message
Old 04-13-2016, 07:51 AM   #19 (permalink)
Member
 
Car:
Join Date: Mar 2016
Member Number: 126194
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
After extensive work by my local Mechanic he said that cylinder 1 lifter is malfunctionING at idle and causing the noise. It in turn is causing a puttering that leads out the rent of the engine into the exhaust. That was diagnosis after spending hours under the car with mechanics stethoscope. Called dealer and they haven't answered or called me back. It's unfortunate because I will probably have to call chrysler above these local dealers. The dealers already told me there is nothing wrong with the car. But I'm going to demand they replace lifters.
12srt8392 is offline   Reply With Quote Quick reply to this message
Old 04-13-2016, 08:14 AM   #20 (permalink)
Member
 
Car:
Join Date: Mar 2016
Member Number: 126194
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
How to your turn the stability control off?
12srt8392 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grinding noise after a rev!! HELP! pedrosarraga General Discussion on Issues / Trouble Shooting 3 12-04-2011 01:44 AM
Hissing noise in engine bay gotkarp Problems / Dealer Service 3 07-20-2011 10:54 AM
Grinding Noise on Startup wilkenms General Discussion on Issues / Trouble Shooting 3 06-05-2011 12:46 PM
Grinding Noise in Brakes vcval Australia / NZ Forum General Discussion 9 07-21-2008 05:55 AM
weird noise from engine bay when using A/C Casey General Discussion 2 05-13-2007 08:09 PM

» Premium Vendor Showcase
» Buyers Guide
Auto Loans Get Approved Today
Warranty Extended warranty packages
Vehicle History Get a vehicle history report in seconds!
Tires Find the right tires for your car
Insurance Get a free insurance quote
» Latest Chrysler News
» Recent Discussions
Phone Pairing Issue
02-20-2017 12:48 PM
by tj4esta
Last post by Crunkz1
Today 07:52 AM
4 Replies, 149 Views
FIN Owners ! ?
10-20-2005 02:44 PM
Last post by Elkamiina
Today 07:09 AM
1 Replies, 609,038 Views
Best cell phone holder...
03-21-2017 08:29 AM
by chinman
Last post by chinman
Today 06:36 AM
1 Replies, 84 Views
Another newbie from Oz
Today 02:24 AM
Last post by Moparlife
Today 05:55 AM
1 Replies, 24 Views
what did you do to your...
10-07-2012 06:16 PM
Last post by Crunkz1
Today 05:55 AM
7 Replies, 589,932 Views
Tid-Bits - Unrestricted
07-11-2014 02:28 AM
Last post by Yellow Toy
Today 04:58 AM
2 Replies, 127,169 Views
Melted injector cover
Today 02:15 AM
Last post by aussie56
Today 02:15 AM
0 Replies, 31 Views
Egr trouble
11-19-2016 09:08 AM
by Jimcub
Last post by Jimcub
Today 02:11 AM
41 Replies, 1,277 Views
EGR Valve?
03-30-2010 06:01 PM
Last post by Trenton Johnson
Yesterday 09:31 PM
21 Replies, 12,639 Views
Z Automotive...
06-05-2015 06:42 PM
Last post by Xavier Espinoza
Yesterday 07:06 PM
7 Replies, 2,413 Views
Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 08:00 AM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.