Oil everywhere - Chrysler 300C Forum: 300C & SRT8 Forums
Interested in the Dodge Challenger? Be sure to check out the Dodge Challenger Forum for your Dodge Challenger information!
Chrysler 300C SRT-8 Header Left Chrysler 300C SRT-8 Logo Right
Go Back   Chrysler 300C Forum: 300C & SRT8 Forums > SRT8 Forums > 2nd Gen SRT8- Mechanical
Register Home Forum Active Topics (T) Gallery Garage Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools
Display Modes
Old 09-16-2015, 11:23 PM   #1 (permalink)
Senior Member
Points: 7,195, Level: 1 Points: 7,195, Level: 1 Points: 7,195, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 4% Activity: 4% Activity: 4%
 
Car: 2012 Chrysler 300C SRT8
Join Date: May 2014
Member Number: 82042
Location: United States
Posts: 108
Thanks: 6
Thanked 6 Times in 5 Posts
Oil everywhere

So, I normally get my oil changed at the dealership but wasn't able to this time.

So I took my car to a localish muffler man chain store to have the oil changed. I supplied the Mobil 1 0W40 and a Bosch D3410 oil filter as indicated by the book at Wal-mart. (Only place I can find my oil near me)

They do the oil change and all seems well. I take it home and park it. Leave for work the next morning. Get home, notice HUGE oil spots where I parked. Not good.

I pull the dipstick...bone dry. WORSE. especially since I put about 500 miles on the car since the oil change. No low oil light, no overheating, oil pressure gauge seemed fine...the car didn't seem to mind it as far as the sensors told me.

Thankfully, I have a buddy that lives near that Wal-mart and he grabs more oil and another filter and heads on over. I verified the filter that I bought originally is for my engine, from several online sources, the new filter is the same one. We put the new filter on and it doesn't thread all the way up.....

What in the hell would cause this kinda issue? There was definitely no leak prior to the oil change....
jdbrassell is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-17-2015, 09:16 AM   #2 (permalink)
Lifetime Premium Member
Points: 86,810, Level: 1 Points: 86,810, Level: 1 Points: 86,810, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 29% Activity: 29% Activity: 29%
 
GoofyTimL's Avatar
 
Car: '15 300C Platinum Jazz Blue; '07 MSRT8 Bright Silver MSRT: Edelbrock SC w/ InTune, 402flaps, Stealth HIDs, misc BT stuff, dual pin stripes, 35% tint 300C Pt: 35% tint, SpLx Pedal Set so far
Join Date: Oct 2005
Member Number: 3755
Location: Pingree Grove, IL
Posts: 10,753
Thanks: 3
Thanked 41 Times in 41 Posts
Garage
I have never heard of such a problem. Very strange. Don't have a clue what would stop a filter early from threading up all the way to seal. The ONLY thing I can think of is if the filter can was extremely short and the threaded post hit the bottom of the can before the seal reached the block. But if that were the case, it wouldn't be the correct filter for the car...
__________________
See my photo gallery section. First name is... uh... Tim. I know... it's Goofy! LOL


In love with my first wife & first car ('68 Charger) ... still have the wife
but now there's the 300C Platinum and an Edelbrock SC Magnum SRT8!
GoofyTimL is offline   Reply With Quote Quick reply to this message
Old 09-17-2015, 04:03 PM   #3 (permalink)
Super Moderator
Points: 82,399, Level: 1 Points: 82,399, Level: 1 Points: 82,399, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
MADDOG's Avatar
 
Car: 2006 Chrysler SRT8
Join Date: Apr 2007
Member Number: 11602
Location: Oregon
Posts: 17,656
Thanks: 348
Thanked 2,126 Times in 1,924 Posts
Garage
What ^^^ he ^^^^ said. You'll want to re-confirm the filter number with the mfgr on their site.
__________________
Michael
2006 300C SRT8
MADDOG is offline   Reply With Quote Quick reply to this message
The Following User Says Thank You to MADDOG For This Useful Post:
GoofyTimL (09-17-2015)
Old 09-17-2015, 04:14 PM   #4 (permalink)
Senior Member
Points: 8,532, Level: 1 Points: 8,532, Level: 1 Points: 8,532, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 52% Activity: 52% Activity: 52%
 
Car: 2013 Chrysler 300c SRT
Join Date: Nov 2010
Member Number: 29598
Location: Wollongong
Posts: 303
Thanks: 2
Thanked 5 Times in 5 Posts
maybe the rubber seal was missing of the filter which CAN NOT make a good seal onto the block
typan is online now   Reply With Quote Quick reply to this message
Old 09-30-2015, 07:17 AM   #5 (permalink)
Junior Member
 
Car: 2012 Chrysler 300
Join Date: Jun 2015
Member Number: 109089
Location: Houston, Tx
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
I'm guessing they didn't put that spring that goes under the oil filter back.
paythepiper340 is offline   Reply With Quote Quick reply to this message
Old 09-30-2015, 07:32 AM   #6 (permalink)
Lifetime Premium Member
Points: 68,978, Level: 1 Points: 68,978, Level: 1 Points: 68,978, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 24% Activity: 24% Activity: 24%
 
Car: 2005 Chrysler 300C
Join Date: Feb 2005
Member Number: 1483
Location: Coatesville, PA, U.S.A.
Posts: 4,175
Thanks: 2
Thanked 208 Times in 192 Posts
Maybe they didn't remove the old gasket which would prevent the filter from seating properly, and allow oil to leak out.
__________________
2005 300C BRILLIANT BLACK, DRL, Mesh Grill/Vents, Chrome Pillars & Fender Trim, MDS Indicator, Quad Brake Lights, Tinted Windows, De-Molded, K&N Aircharger, 180 T-Stat, Flashing Sidemarkers, Predator Cust. Perf. 93 CAI Tune
1997 MUSTANG COBRA 'VERT, TRIPLE BLACK, Vortech S/C'd., ECT Mod., 4.10 Rear, 18" Saleen Wheels
1950 FORD TUDOR FLATHEAD V8 - Sold 6/27/14 after 16 years of fun.
DESIREE is offline   Reply With Quote Quick reply to this message
Old 09-30-2015, 09:40 PM   #7 (permalink)
Senior Member
Points: 1,673, Level: 1 Points: 1,673, Level: 1 Points: 1,673, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 29% Activity: 29% Activity: 29%
 
tomlabelle's Avatar
 
Car: 2008 Chrysler 300 C SRT Design
Join Date: Mar 2015
Member Number: 102817
Location: Clearview, Washington
Posts: 150
Thanks: 1
Thanked 8 Times in 8 Posts
As it happens, MoPar changed the filter mount sometime in 2008. I found this out when I went to the dealer to buy a filter and he asked for the VIN so he could sell me the right one. Mine is the new model and uses (if I remember rightly) a PER2.
tomlabelle is offline   Reply With Quote Quick reply to this message
Old 10-01-2015, 07:41 AM   #8 (permalink)
Lifetime Premium Member
Points: 68,978, Level: 1 Points: 68,978, Level: 1 Points: 68,978, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 24% Activity: 24% Activity: 24%
 
Car: 2005 Chrysler 300C
Join Date: Feb 2005
Member Number: 1483
Location: Coatesville, PA, U.S.A.
Posts: 4,175
Thanks: 2
Thanked 208 Times in 192 Posts
And you had been using the same filter since you have owned the car? And never had an issue? Weird!
DESIREE is offline   Reply With Quote Quick reply to this message
Old 10-01-2015, 08:14 AM   #9 (permalink)
Senior Member
Points: 12,067, Level: 1 Points: 12,067, Level: 1 Points: 12,067, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 11% Activity: 11% Activity: 11%
 
Torian's Avatar
 
Car: 2015 Chrysler 300S V8
Join Date: Jan 2012
Member Number: 36311
Posts: 459
Thanks: 28
Thanked 18 Times in 17 Posts
Yikes. I hope you get this figured out. Too bad we never stuck with the original oil filter designs...it made everything simplier in my book. These damn dirty hippies are trying to save the planet with all their green technology
Torian is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EXPIRED: Broken engine oil dipstick handle avm Australia & Region Parts Buy/Sell Forum 2 09-29-2015 09:44 AM
Oil warning Chime perini UK & Europe Regional Forum 8 09-24-2015 10:57 AM
Low oil pressure issue 5.7 hemi Dhatz General Discussion on Issues / Trouble Shooting 7 09-17-2015 09:18 PM
First Oil Change Gull Ducat 2nd Generation Chrysler 300 Discussion 0 09-11-2015 07:14 PM
F/S: JEGS 6.1 Catback, 6.1 oil pump, 300cSRT Wheels es7129 Parts Buy/Sell Forum 3 12-24-2014 03:08 PM

» Premium Vendor Showcase
» Buyers Guide
Auto Loans Get Approved Today
Warranty Extended warranty packages
Vehicle History Get a vehicle history report in seconds!
Tires Find the right tires for your car
Insurance Get a free insurance quote
» Latest Chrysler News
» Recent Discussions
Tid-Bits - Unrestricted
07-11-2014 03:28 AM
Last post by Piggy.
Today 01:56 PM
1 Replies, 105,696 Views
ESP/BAS will not go away
Today 01:49 PM
by bama1
Last post by bama1
Today 01:49 PM
0 Replies, 3 Views
99 psi oil pressure????
02-14-2017 11:53 AM
by bama1
Last post by bama1
Today 01:48 PM
4 Replies, 103 Views
DRL connections
Today 12:54 PM
by EeWee
Last post by EeWee
Today 12:54 PM
0 Replies, 13 Views
The Dreaded P0700 Error...
02-25-2017 03:04 PM
by razor
Last post by razor
Today 12:45 PM
7 Replies, 149 Views
Problem seeing threads...
Yesterday 09:12 AM
by OostinD
Last post by OostinD
Today 11:38 AM
6 Replies, 75 Views
Minimize Your Shipping...
Today 09:49 AM
Last post by RockAuto
Today 09:49 AM
0 Replies, 19 Views
Chrysler 300C...
12-19-2014 11:14 AM
Last post by Diode Dynamics
Today 09:10 AM
48 Replies, 5,879 Views
Front suspension part...
02-27-2017 11:24 AM
Last post by UK CHRYSLER 300C
Today 08:21 AM
9 Replies, 152 Views
chrysler 300 2.7 engine...
Today 08:06 AM
Last post by Class-Newbie
Today 08:06 AM
0 Replies, 19 Views
Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 01:58 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.