Strange smell when engine heats up. 2013SRT8 - Chrysler 300C Forum: 300C & SRT8 Forums
2nd Generation Chrysler 300 Discussion This is the area for discussion of the new 2nd generation Chrysler 300.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-14-2012, 12:25 PM Thread Starter
Junior Member
Points: 548, Level: 1 Points: 548, Level: 1 Points: 548, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2012
Location: Trenton, MI
Posts: 4
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Red face Strange smell when engine heats up. 2013SRT8

Hi Folks. I just bought a 2013 300SRT8, after owning a 2007 300 SRT Design. Both are great cars, but I'm experiencing something in the new car that didn't happen in the 2007.
When the car warms up, a "funky" smell creeps into the passenger compartment. I think it's origin is in the engine compartment as the smell is present there too, but I can't pinpoint it.
Before the engine warms up the smell is not present, nor is the smell evident when the car is in motion (I figure the smell is simply being blown away).
The car only has 1,100 miles so I was hoping that it would go away (as a new car smell does), but no luck yet.
The smell is similar to that of a dead mouse (If you've ever smelled one, you don't forget), only not quite as over-powering. Still, it's stinky enough to want to figure out and eliminate. I certainly would like to think that there isn't a carcass wedged in my new car somewhere.
Has anyone else experienced this?
Owenspappy is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-14-2012, 06:39 PM
Senior Member
Points: 6,348, Level: 1 Points: 6,348, Level: 1 Points: 6,348, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
black300csrt8's Avatar
 
Join Date: Mar 2012
Location: Leesburg, VA
Posts: 193
Thanks: 0
Thanked 14 Times in 13 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Could it be the new catalytic converters breaking in? I've heard that they smell a little the first couple of month on a new car.


Sent from my iPhone using AutoGuide.com Free App

P1SC 7lbs / Kooks LTs and Catted Mids/ SRT MAX Plus Cam/ 170 T-Stat/ Hotchkis Sways/ BWoody end links/ DC Strut Tower Bar/ Tuned by Brent @ DTP/ 85MM TB/ Tranzformer/ BT Catch Can/Corsa Xtreme Catback/
black300csrt8 is offline  
The Following User Says Thank You to black300csrt8 For This Useful Post:
Owenspappy (01-02-2013)
post #3 of 6 (permalink) Old 12-14-2012, 08:04 PM
Super Moderator
Points: 54,371, Level: 1 Points: 54,371, Level: 1 Points: 54,371, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
MADDOG's Avatar
 
Join Date: Apr 2007
Location: Oregon
Posts: 14,200
Thanks: 331
Thanked 1,787 Times in 1,612 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Garage
That ^^^^ was my first thought as well.

Michael
2006 300C SRT8
MADDOG is offline  
The Following User Says Thank You to MADDOG For This Useful Post:
Owenspappy (01-02-2013)
post #4 of 6 (permalink) Old 12-15-2012, 02:19 PM
Senior Member
Points: 6,348, Level: 1 Points: 6,348, Level: 1 Points: 6,348, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
black300csrt8's Avatar
 
Join Date: Mar 2012
Location: Leesburg, VA
Posts: 193
Thanks: 0
Thanked 14 Times in 13 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by MADDOG View Post
That ^^^^ was my first thought as well.
It's alright ill let you take the next one haha.


Sent from my iPhone using AutoGuide.com Free App
black300csrt8 is offline  
post #5 of 6 (permalink) Old 12-15-2012, 09:21 PM
Banned
Points: 30,292, Level: 1 Points: 30,292, Level: 1 Points: 30,292, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2008
Location: NYC
Posts: 1,625
Thanks: 3
Thanked 10 Times in 8 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Skype™ to Normgarry
When my engine heats up, I smell burning tires.
Normgarry is offline  
post #6 of 6 (permalink) Old 12-17-2012, 07:13 AM Thread Starter
Junior Member
Points: 548, Level: 1 Points: 548, Level: 1 Points: 548, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2012
Location: Trenton, MI
Posts: 4
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Many thanks!

It could very well be the catalytic converters. Thanks for the replies!
Owenspappy is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
strange noise, diesel smell????? HELP AGAIN leonstone UK & Europe Regional Forum 72 01-29-2014 01:49 AM
Burning Rubber Smell (From Engine Compartment) HerpDerp300c General Discussion on Issues / Trouble Shooting 1 05-29-2012 05:49 PM
Strange Smell. Colmax21 UK & Europe Regional Forum 4 07-11-2007 02:43 AM
Strange noise from engine?? 300cnut Problems / Dealer Service 0 09-04-2005 09:22 PM
Finally got my 300C, strange smell? matts Problems / Dealer Service 11 08-06-2004 01:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design