Battery Saver Mode= bad alternator - Chrysler 300C Forum: 300C & SRT8 Forums
2nd Generation Chrysler 300 Discussion This is the area for discussion of the new 2nd generation Chrysler 300.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 03-20-2014, 01:26 PM Thread Starter
Member
Points: 6,128, Level: 1 Points: 6,128, Level: 1 Points: 6,128, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
Car: 2012 Chysler 300
Join Date: Jul 2005
Posts: 69
Thanks: 6
Thanked 1 Time in 1 Post
Battery Saver Mode= bad alternator

F*CKKKKK my 2012 300 just gave me the "battery saver mode" and then it went away in 5 min, but stereo started "skipping" in disk, USB, and radio. 2 hours after its back to normal.
After some research looks like alternators in all pentastars are crapping out and taking the batteries with em.

Took the car to the dealer this morning and after 2 hrs they did not find any history of the battery saver mode and said that alternator and battery passed with flying colours. Chrysler needs to do a TSB on this as more and more people are having this issue.

Last edited by Denis; 03-20-2014 at 01:27 PM.
Denis is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 03-22-2014, 10:58 AM Thread Starter
Member
Points: 6,128, Level: 1 Points: 6,128, Level: 1 Points: 6,128, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
Car: 2012 Chysler 300
Join Date: Jul 2005
Posts: 69
Thanks: 6
Thanked 1 Time in 1 Post
115 views and not a single comment... i can't be the only one with this issue?
Denis is offline  
post #3 of 17 (permalink) Old 03-22-2014, 11:17 AM
Senior Member
Points: 5,656, Level: 1 Points: 5,656, Level: 1 Points: 5,656, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 13% Activity: 13% Activity: 13%
 
Desert_Flyer's Avatar
 
Car: 2013 Chrysler 300C
Join Date: Dec 2013
Location: Phoenix, AZ
Posts: 246
Thanks: 7
Thanked 21 Times in 21 Posts
What is Battery Saver Mode...never heard of it?

We've got a thing that's called radar love
We've got a light in the sky, radar love - Golden Earring

Desert_Flyer is offline  
 
post #4 of 17 (permalink) Old 03-22-2014, 11:38 AM Thread Starter
Member
Points: 6,128, Level: 1 Points: 6,128, Level: 1 Points: 6,128, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
Car: 2012 Chysler 300
Join Date: Jul 2005
Posts: 69
Thanks: 6
Thanked 1 Time in 1 Post
Quote:
Originally Posted by Desert_Flyer View Post
What is Battery Saver Mode...never heard of it?
its a message that shows up on the dash when battery voltage drops, to make sure the car starts it will shut down the stereo and other electronics to conserve power. It happens when ether the battery or alternator are bad, considering that this happened while driving the car on the highway at 2000 rpms its the alternator is not charging. For some reason i can't post a link but there are numerous threads on other chysler/dodge forums with people having the same issue even as bad as car shutting down completely and alternator smoking.
Denis is offline  
post #5 of 17 (permalink) Old 03-23-2014, 11:54 AM
Member
Points: 4,247, Level: 1 Points: 4,247, Level: 1 Points: 4,247, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
JJTAWDC's Avatar
 
Car: 2014 300S 5.7 AWD Phantom Black/Radar Red
Join Date: Jul 2005
Location: Brooklyn, NY
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
My alternator died on my 2011 300C, first symptom was horrible belt noise and loading down of the engine. Brought it to dealer service, they said the fan belt was dry and dressed it. I told them it has to be more then that, of course they said no. A month later same symptoms adding burning odor, this time the car died and of course it was during a blizzard. Waited 4 hours for a tow truck. Final resolution bad alternator was replaced as well as battery.

2014 300S AWD Phantom Black
JJTAWDC is offline  
post #6 of 17 (permalink) Old 03-23-2014, 02:05 PM
Junior Member
Points: 6,561, Level: 1 Points: 6,561, Level: 1 Points: 6,561, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2012 chrysler 300 S
Join Date: Nov 2013
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
I had the same problem with my 2012 300S and the alterenator had to be replaced .
bigstan3 is offline  
post #7 of 17 (permalink) Old 04-10-2014, 02:26 AM
Lifetime Premium Member
Points: 65,390, Level: 1 Points: 65,390, Level: 1 Points: 65,390, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 6% Activity: 6% Activity: 6%
 
OoTLink's Avatar
 
Car: 2013 Chrysler 300
Join Date: Dec 2005
Location: Los Angeles, CA
Posts: 4,455
Thanks: 0
Thanked 18 Times in 15 Posts
Send a message via AIM to OoTLink Send a message via Skype™ to OoTLink
Yeah, seeing this issue myself. Amusingly he posted this on another forum too. Found it on google while looking for more info.

*facepalm* I better get it done before my factory warranty is up lol
OoTLink is offline  
post #8 of 17 (permalink) Old 05-21-2014, 11:19 AM
Junior Member
Points: 270, Level: 1 Points: 270, Level: 1 Points: 270, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 18% Activity: 18% Activity: 18%
 
Car: 2014 Dodge Challenger SRT8 Tor Red
Join Date: May 2014
Location: Porterville, CA
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
2011 chrysler 300 alternator/battery bad

2011 Chrysler 300, 3.6L, 2 years and 11 months old. 53k. Whining noise, slight burning smell, doors and trunk not opening properly, not starting on 1st button push, radio, display problems, and warning chimes. Battery saver mode. Replaced dead battery $150. Then problem returned in a few days. Replaced fried alternator; $175 rebuild at local shop. Leather seats cracking. Crappy warranty. The list will probably grow.
Corvette Man is offline  
post #9 of 17 (permalink) Old 08-18-2014, 04:36 AM
Junior Member
Points: 1, Level: 1 Points: 1, Level: 1 Points: 1, Level: 1
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Car:
Join Date: Aug 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Im having same issue now. Car is absolutely dead, even charged the battery it holds power but nothing comes on not ign, dome lights, headlights, alternator began smoking today im looking at this problem is it clear cut? Replace alternator and thats it problem solved? Of course as long as battery is good.

Traction control light came on after issue also can anyone offer any better guidance, images to show removing alternator step by step i just want to ensure spending the time and money this is the issue that ive been reading so much about.

Anyone know the best way to remove this and also is the alternator amperage posted anywhere in the manual, pretty sure they have 3 diff types factory 150-190-225 amps

Please help out here or email jru12347 at msn dot com
Squashy is offline  
post #10 of 17 (permalink) Old 08-25-2014, 12:27 PM
Member
Points: 5,703, Level: 1 Points: 5,703, Level: 1 Points: 5,703, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 7% Activity: 7% Activity: 7%
 
Car: 2012 chrysler 300c
Join Date: Jun 2012
Location: Kuwait
Posts: 62
Thanks: 11
Thanked 3 Times in 3 Posts
i get this message all the time specially during parking lot maneuver. radio, A/C, and all electronic works fine when i get it.
dealer said nothing is wrong and no messages appears in the car computer.
bo3adsa is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  LinkBacks (?)
LinkBack to this Thread: http://www.300cforums.com/forums/2nd-generation-chrysler-300-discussion/162914-battery-saver-mode-bad-alternator.html
Posted By For Type Date
Battery Saver Mode= bad alternator (MUST READ) This thread Refback 09-23-2014 12:57 PM

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help, battery saver mode killing my car SRTGR8T 2nd Gen SRT8- Mechanical 12 04-04-2014 07:55 PM
Alternator and Battery Pusbum Australia / NZ Forum General Discussion 11 09-02-2013 02:09 AM
300C fulltime fuel saver mode? richclas General Discussion 15 10-01-2009 08:35 PM
'08 Fuel Saver Mode Gauge TenMidgets General Discussion 10 09-20-2007 03:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Replace with
For the best viewing experience please update your browser to Google Chrome