Backup camera blackout! Not working - Chrysler 300C Forum: 300C & SRT8 Forums
2nd Generation Chrysler 300 Discussion This is the area for discussion of the new 2nd generation Chrysler 300.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 05-29-2014, 07:08 AM Thread Starter
Junior Member
Points: 728, Level: 1 Points: 728, Level: 1 Points: 728, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2012 Chrysler 300 limited
Join Date: Aug 2013
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Backup camera blackout! Not working

Has anyone else had backup camera issues? Mine hasn't been working for about 2 weeks now. Screen just goes black and displays check entire surroundings. Every now and then it shows the display briefly then goes black. Any help? 51l miles on a 2012 limited
12LiMtdGrApH is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 05-29-2014, 07:45 AM
Senior Contributing Member
Points: 16,311, Level: 1 Points: 16,311, Level: 1 Points: 16,311, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 43% Activity: 43% Activity: 43%
 
Crunkz1's Avatar
 
Car: 2013 Chrysler 300C
Join Date: May 2014
Location: Michigan
Posts: 716
Thanks: 79
Thanked 88 Times in 81 Posts
Garage
I Dont know a whole lot about these cars yet. Sounds like a short somewhere? If it were me, before I'd take it somewhere that will probably charge a lot, I'd start with the trunk area and see if you can check out the wiring right there behind the light and or in the trunk area as best as you can.

Like my 06 300 I had, I finally had a day to take out the whole center console, which wasnt hard at all, and a learning experience. Which also showed me a lot about some other stuff.. But with a newer car like that, or like my 2013 300C, I would probably be more hesitant to actually take it apart haha.. dont want to mess something up.

Or as im sure someone else may already know, could there possibly be a way to reset the Infotainment system? maybe that might work?
Crunkz1 is offline  
post #3 of 21 (permalink) Old 05-29-2014, 07:47 AM
Super Moderator
Points: 84,170, Level: 1 Points: 84,170, Level: 1 Points: 84,170, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 67% Activity: 67% Activity: 67%
 
MADDOG's Avatar
 
Car: 2006 Chrysler SRT8
Join Date: Apr 2007
Location: Oregon
Posts: 17,735
Thanks: 348
Thanked 2,132 Times in 1,930 Posts
Garage
Sounds like a camera signal fault.

It could be at the connector to the camera or to the head unit (check the harness connections).

Another possibility is the camera itself is faulty.

Lastly, and hopefully this is not the case, the head unit display or internal camera function connections are bad.

I assume the display works normally on other functions?

Michael
2006 300C SRT8
MADDOG is offline  
The Following User Says Thank You to MADDOG For This Useful Post:
Crunkz1 (05-29-2014)
 
post #4 of 21 (permalink) Old 05-29-2014, 08:11 AM
Lifetime Premium Member
Points: 8,890, Level: 1 Points: 8,890, Level: 1 Points: 8,890, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
Jim910's Avatar
 
Car: 2015 Dodge Charger 392 HEMI
Join Date: Jan 2013
Location: Tarrytown, NY
Posts: 438
Thanks: 58
Thanked 82 Times in 70 Posts
You state 51 miles on a 2012 Limited. Where did you purchase the car? Is it still under warrantee? If it is, don't mess around and bring it to the dealer.
Jim910 is offline  
post #5 of 21 (permalink) Old 05-29-2014, 08:39 AM Thread Starter
Junior Member
Points: 728, Level: 1 Points: 728, Level: 1 Points: 728, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2012 Chrysler 300 limited
Join Date: Aug 2013
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Sorry meant 51k miles! I wish it only had 51 miles.
The head unit works perfectly aside from when it's in reverse. I have to assume it's something with the camera because the screen even displays check all surroundings but the rest of the screen is black. Guess I'll have to start ripping her apart.
12LiMtdGrApH is offline  
post #6 of 21 (permalink) Old 05-29-2014, 09:51 AM
Senior Member
Points: 5,796, Level: 1 Points: 5,796, Level: 1 Points: 5,796, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 13% Activity: 13% Activity: 13%
 
JMitch's Avatar
 
Car: 2011 Chrysler 300C
Join Date: Jul 2013
Location: Poulsbo, WA
Posts: 167
Thanks: 34
Thanked 44 Times in 38 Posts
Garage
As MADDOG stated, I would first check the video connection from the camera to your head unit. I installed a front camera, and when I first tested it, my display was the same as you described. It was simply the video connection.

Billet Technology Underhood Kit and Catch Can, Mopar Pedal Kit, Blastin' Bob's Resonator Delete, Magnaflows, 180 Degree Thermostat, Airaid CAI, Petty's Garage Strut Tower Bar, Mopar Stage 1 Springs, Diablosport Trinity 93 Octane Tune, Rear Deck Spoiler
JMitch is offline  
post #7 of 21 (permalink) Old 05-29-2014, 10:46 AM
Senior Member
Points: 18,602, Level: 1 Points: 18,602, Level: 1 Points: 18,602, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 17% Activity: 17% Activity: 17%
 
Car: Mesmerizingly Black 2013 Chrysler 300S
Join Date: Nov 2013
Location: San Leandro, CA
Posts: 451
Thanks: 10
Thanked 41 Times in 34 Posts
One word: Extended Lifetime Warranty. OK, so I was never great in math.

Otherwise, I'd never heard of a problem like yours happening (others w/an intermittent working camera). Certainly post back regarding the particulars of how you had it corrected.
Mike in the Dro is offline  
post #8 of 21 (permalink) Old 12-08-2014, 01:32 PM
Users Awaiting Email Confirmation
 
Car:
Join Date: Dec 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
backup camera failed.

My 300 is at 45k miles. I disconnected the negative battery cable and pulled/reset the fuse before taking to the local garage. It was the camera. $200 for camera and $200 for labor.
porter300 is offline  
post #9 of 21 (permalink) Old 12-08-2014, 07:15 PM
Senior Member
Points: 5,656, Level: 1 Points: 5,656, Level: 1 Points: 5,656, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 13% Activity: 13% Activity: 13%
 
Desert_Flyer's Avatar
 
Car: 2013 Chrysler 300C
Join Date: Dec 2013
Location: Phoenix, AZ
Posts: 246
Thanks: 7
Thanked 21 Times in 21 Posts
First, try removing the black tape someone put on the camera! 😜


Sent from AutoGuide.com Free App

We've got a thing that's called radar love
We've got a light in the sky, radar love - Golden Earring

Desert_Flyer is offline  
post #10 of 21 (permalink) Old 12-08-2014, 10:59 PM
Senior Member
Points: 64,247, Level: 1 Points: 64,247, Level: 1 Points: 64,247, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 2% Activity: 2% Activity: 2%
 
Car: 2014 Dodge Charger
Join Date: Oct 2013
Location: Austin, TX
Posts: 460
Thanks: 16
Thanked 192 Times in 131 Posts
$200 for labor!?!

Replacing the camera is LITERALLY a ten-minute job. I would have exploded if I got that bill!

The camera is $200, though...
tanbam is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  LinkBacks (?)
LinkBack to this Thread: http://www.300cforums.com/forums/2nd-generation-chrysler-300-discussion/173490-backup-camera-blackout-not-working.html
Posted By For Type Date
2nd Generation Chrysler 300 Discussion on Chrysler 300C Forum: 300C and SRT8 Forums | BoardReader This thread Refback 12-15-2014 11:58 PM

Similar Threads
Thread Thread Starter Forum Replies Last Post
Backup camera Ankurinmood Appearance General Discussion 12 08-27-2012 01:12 PM
Where to put the backup camera??????? CitysOnly32 Car Audio/Alarms/UConnect/Navigation 6 04-27-2009 10:42 AM
backup camera??? chrysler300c Car Audio/Alarms/UConnect/Navigation 1 01-31-2008 02:44 PM
Backup Camera... mlaurenza Car Audio/Alarms/UConnect/Navigation 3 01-08-2007 09:33 PM
Adding Backup Camera/Front Camera, Any Suggestions. NautcaSprt6 Car Audio/Alarms/UConnect/Navigation 4 11-08-2006 10:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Replace with
For the best viewing experience please update your browser to Google Chrome