Blank Screen - Chrysler 300C Forum: 300C & SRT8 Forums
Car Audio/Alarms/UConnect/Navigation This section is for topics related to the LX audio/video and navigation systems, alarms, upgrades, modifications, etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 01-06-2010, 06:30 PM Thread Starter
Junior Member
Points: 939, Level: 1 Points: 939, Level: 1 Points: 939, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
steptoe's Avatar
 
Join Date: Nov 2007
Location: Biloxi, Ms
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Blank Screen

I have a 2006 300C. My factory navigation unit screen has gone blank. Everything works as it should but the image is gone-just a gray screen with lines streaking thru it. Doesn't matter if using the GPS or radio. At times the image does come back as though nothing was wrong. I presume that there must be a short or something loose in the main board. I did remove the unit from the dash but did not see anything that would cause this problem. Has anyone had this type problem? Does anyone here repair the nav unit or know where I can get it fixed? Any help would be greatly appreciated.
steptoe is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 01-06-2010, 10:22 PM
Super Moderator
Points: 30,219, Level: 1 Points: 30,219, Level: 1 Points: 30,219, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
CUEBALL's Avatar
 
Join Date: Sep 2005
Location: Mount Enterprise TX
Posts: 6,094
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check out Dom at tvandnav2go . Great vendor with no bad reviews ever. Give them a call! Also, they can modify the unit if you want to add a DVD feed from an external player or backup camera. They've fixed your issue on other members rides

My name is Steve, but you can call me Cueball.
FORUM SUPER MODERATOR from 2007-2012; Car sold Sep 2011

MODS: 22elite Console cover, Formula One 35%, Blastin Bob's 5db resonator delete, KW V2's, Hotchkis sways, 3-Piece Intro 311 22's, Stoptech slotted rotors(Zeckhausen), Fenders rolled, TZ wingless grille, SS Braided brake lines, ATE super blue DOT 4 fluid, SPC camber kit, Headlight Armor 50% tint, Jonstintedtails.
CUEBALL is offline  
post #3 of 17 (permalink) Old 01-06-2010, 11:02 PM
Junior Member
Points: 839, Level: 1 Points: 839, Level: 1 Points: 839, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
toddbarrick's Avatar
 
Join Date: May 2009
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Had the same problem with 06 srt8..Its a loose LED connection..Bad news is, I got a refurbished from the dealership for $716.00,,and $45.00 for installation..The good news is a factory refurbished has a one year 12000 mile warranty..Kinda sucks cause all my stuff worked to except screen..But If you ever trade it in..They are gonna take that off trade in..So might as well pay it now and enjoy it till you trade it in..There is a link on ebay for $325 to refurbish..Have to be carefull sending it though..These things are easily damaged en route..So I feel your pain..
toddbarrick is offline  
post #4 of 17 (permalink) Old 01-07-2010, 07:42 AM Thread Starter
Junior Member
Points: 939, Level: 1 Points: 939, Level: 1 Points: 939, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
steptoe's Avatar
 
Join Date: Nov 2007
Location: Biloxi, Ms
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Toddbarrick. Thanks for the info. Is there some way I can fix that loose LED connection? Do you know where it would be located within the unit? The wife and I just use the radio and we can see the station call letters on the dash cluster. My bluetooth even still works. I really need to find a cheap why out if possible. I love this car - it is an amasing piece of machinery but I am restoring a 1955 Chevy Bel Air 2 door sedan which is my true love (I lost my virginity in the back seat of a '55). Oh, the memories.........lol . It's gonn'a be awesome: LT1, 4L60E, power everything, 4 wheels discs, A/C, Cadillac heated seats, floor shift, digital dash, flaming river column, wire wheels, etc.
steptoe is offline  
post #5 of 17 (permalink) Old 01-07-2010, 08:02 AM Thread Starter
Junior Member
Points: 939, Level: 1 Points: 939, Level: 1 Points: 939, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
steptoe's Avatar
 
Join Date: Nov 2007
Location: Biloxi, Ms
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cueball that's a beautiful ride. That website doesn't mention repair work so I sent them an email about my problem. Thanks for the information.
steptoe is offline  
post #6 of 17 (permalink) Old 01-07-2010, 12:09 PM
Elite Contributing Member
Points: 77,879, Level: 1 Points: 77,879, Level: 1 Points: 77,879, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 9% Activity: 9% Activity: 9%
 
Quiknen's Avatar
 
Join Date: Dec 2008
Location: Sutton, MA
Posts: 3,676
Thanks: 1
Thanked 12 Times in 5 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Send a message via AIM to Quiknen
random thought... have you tried popping out the nav disk and re-inserting it?
(dont know if this would do anything but could be worth a simple try)

Also i bought mycar with 35,000 a year ago and broke the joystick nob i think like 6 months of owning it, brought it back to the dealer and they complete swapped it out so i'd try to hassle them a little more

Real Name: Ian Butler

(Click above picture to see modifications)
Click here to see My Garage


5.7L Hemi Registry #1537 Quiknen
Quiknen is offline  
post #7 of 17 (permalink) Old 01-07-2010, 05:28 PM Thread Starter
Junior Member
Points: 939, Level: 1 Points: 939, Level: 1 Points: 939, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
steptoe's Avatar
 
Join Date: Nov 2007
Location: Biloxi, Ms
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quiknen I don't have any warranty. The 06 model only had a 3/36 warranty but it doesn't matter as I purchased it used with 40,000 on it then. The dealer wants $375.00 to send the Navigation Unit off for repair. I had a call from some place in California who said if it was just a loose connection, they would repair it for only $350.00 plus shipping. That's not bad pay for about 15 - 30 minutes work. I think I'll just live with it cause I'm tired of getting stuffed by corporate America. I can use my Tom Tom if necessary. lol
steptoe is offline  
post #8 of 17 (permalink) Old 01-07-2010, 09:21 PM
Junior Member
Points: 839, Level: 1 Points: 839, Level: 1 Points: 839, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
toddbarrick's Avatar
 
Join Date: May 2009
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Man your dealer was cheaper than mine..Got mine installed today..It was $811.00..Im not sure on where The Led connection was located..It will get old after awhile starring at those lines..They are different everytime you turn it on..it wouldnt be so bad if you could just turn off the screen..
toddbarrick is offline  
post #9 of 17 (permalink) Old 01-08-2010, 07:23 AM Thread Starter
Junior Member
Points: 939, Level: 1 Points: 939, Level: 1 Points: 939, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
steptoe's Avatar
 
Join Date: Nov 2007
Location: Biloxi, Ms
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I can't believe people charge so much for so little. Maybe my mind is stuck back in the '60s but I just can't accept outrageous charges. Ex: AAMCO will charge you about $2500.00 to rebuild your transmission. Of course they give a lifetime warranty. How many wil keep their car longer than 3 additional years from that date? Your're paying for something you will never use. You can buy one direct from a GM Dealer with a 3 year factory warranty which includes towing, labor, etc., for $1500.00. Go figure. Everybody is looking to make a fast buck. I just won't give in. I'll do without, trade, sell, or whatever it takes to find a way around. Yes, I CAN look at those gray lines for a long time before I'll pay the price they demand. Maybe I should have bought a Yugo instead of a luxury car? Thanks for the help and advise everyone.
steptoe is offline  
post #10 of 17 (permalink) Old 01-08-2010, 09:03 AM
Elite Contributing Member
Points: 77,879, Level: 1 Points: 77,879, Level: 1 Points: 77,879, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 9% Activity: 9% Activity: 9%
 
Quiknen's Avatar
 
Join Date: Dec 2008
Location: Sutton, MA
Posts: 3,676
Thanks: 1
Thanked 12 Times in 5 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Send a message via AIM to Quiknen
Mines as well just go with and Aftermarket Deck lol
Quiknen is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen is Blank ScottChar Car Audio/Alarms/UConnect/Navigation 0 03-18-2010 12:20 AM
Blank or Chrysler Center Caps for Charger Wheels? bradtopp Custom Wheels & Tires 5 10-25-2009 02:49 AM
Blank Screen steptoe Car Audio/Alarms/UConnect/Navigation 0 10-18-2009 09:29 AM
VES - Wide Screen vs. Full Screen ROCKET Car Audio/Alarms/UConnect/Navigation 0 10-10-2007 02:37 PM
Navigation screen went blank moddog Problems / Dealer Service 2 12-07-2005 06:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design