Navigation Display Screen Problems - Chrysler 300C Forum: 300C & SRT8 Forums
Car Audio/Alarms/UConnect/Navigation This section is for topics related to the LX audio/video and navigation systems, alarms, upgrades, modifications, etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 33 (permalink) Old 04-07-2011, 10:28 AM Thread Starter
Junior Member
Points: 501, Level: 1 Points: 501, Level: 1 Points: 501, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 Chrysler 300c
Join Date: May 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Navigation Display Screen Problems

Ok, I am hoping someone may be able to help me out here... I have a 2005 300C with the Navigation unit with AM/FM 6 CD changer...

So, yesterday while driving into work everything was fine. When I started the car to go home, the screen of the radio/Navigation unit is grey and has what look like lines running through it. Everything still seems to work on the unit itself (Radio, CD's ets) but there is no display. It looks like the lines change as I adjust the volume or change from Radio to CD, but still a grey screen. Anyone have any ideas? I tried turning the car off and turning it back on... I turned the unit itself off and then back on. Nothing seems to work.

ANY HELP IS APPRECIATED!!!!
GuyfromNY456 is offline  
Sponsored Links
Advertisement
 
post #2 of 33 (permalink) Old 04-07-2011, 01:58 PM
Senior Member
Points: 5,846, Level: 1 Points: 5,846, Level: 1 Points: 5,846, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 8% Activity: 8% Activity: 8%
 
Cudajon's Avatar
 
Car: 2005 chrysler 300C AWD
Join Date: Apr 2010
Location: Wisconsin
Posts: 336
Thanks: 0
Thanked 3 Times in 1 Post
Sounds to me like your LCD display just took a dump. No suggestions for you. Sorry.

Cudajon is offline  
post #3 of 33 (permalink) Old 12-05-2011, 10:55 AM
Junior Member
Points: 1,491, Level: 1 Points: 1,491, Level: 1 Points: 1,491, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 4% Activity: 4% Activity: 4%
 
Car: 2005 Chrysler 300c AWD
Join Date: Mar 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Did you ever fix this? What was the problem and solution? I have the same problem
G9Cap is offline  
 
post #4 of 33 (permalink) Old 12-19-2011, 10:52 AM
Junior Member
Points: 31, Level: 1 Points: 31, Level: 1 Points: 31, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 chrylser 300c
Join Date: Dec 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
I just repaired mine for the same reason took out radio take out 10 little screws that hold faceplate on pull off all knobs first then unsnap faceplate from body remove 4 screws that hold video screen on clean out dust from sockets mine works great now
retro1300s is offline  
post #5 of 33 (permalink) Old 12-19-2011, 12:29 PM
Junior Member
Points: 1,491, Level: 1 Points: 1,491, Level: 1 Points: 1,491, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 4% Activity: 4% Activity: 4%
 
Car: 2005 Chrysler 300c AWD
Join Date: Mar 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks guys.
I took mine out and cleaned it etc. but it won't work.

I did find that you can buy just the screen (attached to the board) for $175 so I'll probably do that.

There is no way I'd get the whole unit (which seems to be what most people do) and pay upwards of $600 - $900 when only the screen is out so just the screen will do it for me.

Thanks again.
G9Cap is offline  
post #6 of 33 (permalink) Old 12-19-2011, 12:31 PM
Junior Member
Points: 1,491, Level: 1 Points: 1,491, Level: 1 Points: 1,491, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 4% Activity: 4% Activity: 4%
 
Car: 2005 Chrysler 300c AWD
Join Date: Mar 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
retro1300s..... when you say "clean out sockets" what do you mean?

I mean, I took the unit out, opened it and got the screen off with the 4 screws but "sockets"? Thx
G9Cap is offline  
post #7 of 33 (permalink) Old 01-14-2012, 11:20 AM
Junior Member
Points: 31, Level: 1 Points: 31, Level: 1 Points: 31, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2006 chrysler 300C
Join Date: Jan 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
When my screen goes dark my stereo or cd player locks on to that channel or cd only. You lose control of the system. On a restart the screen goes on and everything is functional again this lasts for about 10 min. then goes dark. any suggestions or ideas where i can purchase a screen? thanks
darin 1 is offline  
post #8 of 33 (permalink) Old 05-21-2012, 09:36 AM
Junior Member
Points: 32, Level: 1 Points: 32, Level: 1 Points: 32, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2008 Chrysler 300c
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Hi all,

I have the same problem as Darin. The only difference maybe is the fact that I can turn off and on the radio/cd and I can change the cd. so these buttons are working ok. The display went black.

This happened yesterday- a rainy day, after I have left the car into a close parking. When I left the parking, I saw that the display went black. I have turned off the engine, took off the key and opened the door. Then, I put in moto the car.

After 10 minutes, the display went again black. I have done the same thing as above and the display was ok for 30-40 minutes.

Today, another rainy day, the display went black remained black also after I have done the checks I did yesterday.

Could some help me with some information ? Is there another solution of this problem (solution different from the official one- to change it)?
Darrin, what have you done in the end?

I will apprecciate all the answers- I need to understand what went wrong and why happend this.

Strunphy
Strunphy is offline  
post #9 of 33 (permalink) Old 05-21-2012, 09:45 AM
Super Moderator
Points: 83,096, Level: 1 Points: 83,096, Level: 1 Points: 83,096, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
MADDOG's Avatar
 
Car: 2006 Chrysler SRT8
Join Date: Apr 2007
Location: Oregon
Posts: 17,692
Thanks: 348
Thanked 2,130 Times in 1,928 Posts
Garage
The units can get dirty and the contacts (sockets) carbon up. If they get cleaned they sometimes work. Other times, it's too late. Just like any other electrical connection, they can fail. So can the screen itself. You can replace the screen.

What many folks do is upgrade to a new aftermarket head unit for a lot less than a new unit (A new REC/NAV head unit is almost $2200 dealer price!!!), get a harness adapter or two and move on. Some folks shop for used ones on eBay but as with any other used item, you are taking your chances there.

Michael
2006 300C SRT8
MADDOG is online now  
post #10 of 33 (permalink) Old 05-21-2012, 09:56 AM
Junior Member
Points: 32, Level: 1 Points: 32, Level: 1 Points: 32, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2008 Chrysler 300c
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
ok, I will try to see what I can resolve with the sockets.

Thanks, dude for the quick reply.
Strunphy is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! REC Navigation added but no Display wisejeff Car Audio/Alarms/UConnect/Navigation 1 06-27-2011 12:29 PM
Navigation display just blacked out! kg300C Car Audio/Alarms/UConnect/Navigation 8 08-13-2010 11:10 PM
UConnect Battery Indicator in Navigation Display JRMedved Car Audio/Alarms/UConnect/Navigation 4 11-12-2007 03:12 PM
300C navigation Radio display JJ Black 06 300C Car Audio/Alarms/UConnect/Navigation 3 07-28-2006 09:26 PM
Digital Display on the Nav Screen? ATLsrt8 1st Gen SRT8-Specific General Discussion 3 06-05-2006 09:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome