Blank Screen on REC Nav unit after update - Chrysler 300C Forum: 300C & SRT8 Forums
Interested in the Dodge Challenger? Be sure to check out the Dodge Challenger Forum for your Dodge Challenger information!
» Featured Product
» Buyers Guide

Wheel & Tire Center

Go Back   Chrysler 300C Forum: 300C & SRT8 Forums > Chrysler 300 & All LX Models Forums > Car Audio/Alarms/UConnect/Navigation
Register Home Forum Active Topics (T) Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto Loans

Car Audio/Alarms/UConnect/Navigation This section is for topics related to the LX audio/video and navigation systems, alarms, upgrades, modifications, etc.

300cForums.com is the premier Chrysler 300c Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-22-2012, 08:38 PM   #1 (permalink)
Junior Member
Points: 1,243, Level: 1 Points: 1,243, Level: 1 Points: 1,243, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 1% Activity: 1% Activity: 1%
 
Car: 2007 Chrysler 300C
Join Date: Jan 2012
Member Number: 36612
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Blank Screen on REC Nav unit after update

Background:
I purchased my 300 this past summer. It has the REC nav unit, but it never really worked. Since the day I test-drove it, it displayed a message saying something along the lines of the disk installed was older than the version installed.
I tried getting the dealership (non Chrysler) to resolve it before purchasing it, but kept getting a no and “I don’t understand what kind of deal I’m getting”. You know that salesman BS.

Since Then:
My clock is now an hour behind, but from what I read in the owner’s manual (or how I understood it) I’m unable to change the time without the Nav functional. I’ve also purchased Pacifica (growing family) and it too has a nav system. After playing with it, I decided to look more into getting it to work in the 300.

Problem:
So today after looking at few forms, I gathered what could be my solution by accessing the hidden menu and forcing the download of the disk that I have in my unit. I followed the instructions that can be found on several posts. However, when I pressed the force download button my screen went blank. I just assumed it was part of the update process and watched some football. I followed up on the update during commercials but found no change. After the game was over, I decided to turn the car off and back on to see if anything would change but got nothing.

Things to note:
I have never had problems with my display. I appear to have complete functionality of the rest of the components of my radio. The version disk that I have is version AD and the Pacific is version AE. I tried putting in the disk from the Pacific after it went blank, but still have had no change.

Has anyone experienced this or have any suggestions in what I could do to fix it?

Last edited by mihenry; 01-23-2012 at 05:49 PM.
mihenry is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-23-2012, 05:52 PM   #2 (permalink)
Junior Member
Points: 1,243, Level: 1 Points: 1,243, Level: 1 Points: 1,243, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 1% Activity: 1% Activity: 1%
 
Car: 2007 Chrysler 300C
Join Date: Jan 2012
Member Number: 36612
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
I pulled this from a Charger form... Does this sound like it will work or has anyone tried this?

Fix for an REC Nav Unit Bad-Flash [Archive] - Dodge Charger Forums

Fix for an REC Nav Unit Bad-Flash

It happened to me. I put an updated burnt Navigation disc into my REC NAV radio and the update crapped out part of the way through. :sick::knockout: All I got was a black screen and none of the buttons worked when the radio was turned on. :eek3:


Here is what I did to fix it.

1. Re-burnt the Navigation disc minus the +1GB files in the main directory to a single layer DVD.
2. Insert that disc into the REC NAV.
3. Turn the vehicle off.
4. Restart the car and turn the radio on.
5. Hit NAV and Enter (even though the screen is black)
6. Wait about 30 seconds.
7. The REC NAV should recognize the DVD and re-flash the REC NAV automatically. A progress bar should display.

I put the original Navigation DVD back in and force flashed the REC NAV. Here is how to do it.

1. Start the car.
2. Turn on the radio and put it on any AM station.
3. Turn off the car.
4. Restart the car and turn on the radio.
5. Hit the AM/FM twice.
6. Hit "Nav"
7. Hold down the 2 and 6 and hit the Cancel button (while holding the 2 and 6).
8. Go to Unit Check --> Debugging --> Force Download and press Yes

The REC NAV unit will reflash the unit with whatever version Nav disc that's in it. Don't play with any of those other settings. You might really screw up the REC NAV unit. If you do, you're on your own.
mihenry is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 01-24-2012, 03:22 PM   #3 (permalink)
Junior Member
Points: 1,243, Level: 1 Points: 1,243, Level: 1 Points: 1,243, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 1% Activity: 1% Activity: 1%
 
Car: 2007 Chrysler 300C
Join Date: Jan 2012
Member Number: 36612
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Come on, someone on here has to have some insight to this...
mihenry is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 02-21-2012, 10:23 PM   #4 (permalink)
Junior Member
Points: 1,243, Level: 1 Points: 1,243, Level: 1 Points: 1,243, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 1% Activity: 1% Activity: 1%
 
Car: 2007 Chrysler 300C
Join Date: Jan 2012
Member Number: 36612
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Bump...
Im still looking for some advice here...


Sent from my Autoguide iPhone app
mihenry is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 04-25-2012, 02:20 PM   #5 (permalink)
Junior Member
Points: 1,469, Level: 1 Points: 1,469, Level: 1 Points: 1,469, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 1% Activity: 1% Activity: 1%
 
Car: 2005 Chrysler 300C
Join Date: Oct 2004
Member Number: 814
Location: Marina del Rey, CA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Sorry no one has posted a DIY fix that works for your unit. If you search eBay for Chrysler Navigation Repair you will find at least one guy that repairs pretty much any REC problem for $150-250 and buys nonfunctional units. Of course you would have a big hole in the dash for 1-2 weeks.
OPFOR is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 04-25-2012, 02:49 PM   #6 (permalink)
Super Moderator
Points: 52,663, Level: 1 Points: 52,663, Level: 1 Points: 52,663, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
MADDOG's Avatar
 
Car: 2006 Chrysler SRT8
Join Date: Apr 2007
Member Number: 11602
Location: Oregon
Posts: 13,879
Thanks: 327
Thanked 1,749 Times in 1,578 Posts
I've never seen that happen before. Mine has always worked flawlessly when I upgraded it. It does sound like the Force Flash process should work.
__________________
Michael
2006 300C SRT8
MADDOG is online now  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 04-25-2012, 04:37 PM   #7 (permalink)
Junior Member
Points: 1,243, Level: 1 Points: 1,243, Level: 1 Points: 1,243, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 1% Activity: 1% Activity: 1%
 
Car: 2007 Chrysler 300C
Join Date: Jan 2012
Member Number: 36612
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by MADDOG View Post
I've never seen that happen before. Mine has always worked flawlessly when I upgraded it. It does sound like the Force Flash process should work.
Any idea how to do it when the screen is nothing but blank?
mihenry is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 04-25-2012, 04:59 PM   #8 (permalink)
Super Moderator
Points: 52,663, Level: 1 Points: 52,663, Level: 1 Points: 52,663, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
MADDOG's Avatar
 
Car: 2006 Chrysler SRT8
Join Date: Apr 2007
Member Number: 11602
Location: Oregon
Posts: 13,879
Thanks: 327
Thanked 1,749 Times in 1,578 Posts
Sorry, no idea whatsoever.
MADDOG is online now  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 04-25-2012, 05:00 PM   #9 (permalink)
Super Moderator
Points: 52,663, Level: 1 Points: 52,663, Level: 1 Points: 52,663, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
MADDOG's Avatar
 
Car: 2006 Chrysler SRT8
Join Date: Apr 2007
Member Number: 11602
Location: Oregon
Posts: 13,879
Thanks: 327
Thanked 1,749 Times in 1,578 Posts
Here's a thought....don't know if this would work but you could pull the head unit from the dash and disconnect the power wire to it. A hard reboot may do the trick.
MADDOG is online now  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
blank , nav , rec , update

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blank Screen steptoe Car Audio/Alarms/UConnect/Navigation 16 08-06-2014 06:42 PM
Screen is Blank ScottChar Car Audio/Alarms/UConnect/Navigation 0 03-18-2010 12:20 AM
Blank Screen steptoe Car Audio/Alarms/UConnect/Navigation 0 10-18-2009 09:29 AM
Navigation screen went blank moddog Problems / Dealer Service 2 12-07-2005 06:55 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:33 AM.



Inactive Reminders By Icora Web Design

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2