2006 300C Radio Display Has Gone Our, but Radio Still Works? Is it an easy fix?? - Chrysler 300C Forum: 300C & SRT8 Forums
Car Audio/Alarms/UConnect/Navigation This section is for topics related to the LX audio/video and navigation systems, alarms, upgrades, modifications, etc.

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 02-26-2012, 03:22 PM Thread Starter
Member
Points: 14,429, Level: 1 Points: 14,429, Level: 1 Points: 14,429, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2006 Satin Jade 300C AWD
Join Date: Oct 2005
Posts: 58
Thanks: 1
Thanked 1 Time in 1 Post
2006 300C Radio Display Has Gone Our, but Radio Still Works? Is it an easy fix??

Looking for advice: I have a 2006 300C with the premium Bose Radio and Navigation system. Recently the large 3"x4" LCD Radio screen started going on the fritz.

When I start the car the screen and controls work find for the first 10 minutes or so. Then the Radio LCD screen goes blank, but the radio and the preset stations still work fine.

Once the LDC screen goes out, the radio controls ont he stearing wheel will no longer change channels, but the presets on the radio will change stations.

Does anyone know of a Service Bulletin or have an idea as to the intermittant cause of my LCD Screen problems?

Trying to diagnoise this before I bring it to the dealer and have hime tell me to replace the entire radio for big $$

Thanks
Gary
Andover NJ
Gary25 is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 03-07-2012, 02:43 PM
Senior Member
Points: 12,874, Level: 1 Points: 12,874, Level: 1 Points: 12,874, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
moe300's Avatar
 
Car: 2006 Chrysler 300C SRT8
Join Date: Nov 2009
Location: London, ON, Canada
Posts: 319
Thanks: 6
Thanked 10 Times in 8 Posts
Garage
Im starting to have the same issue,,,, i hope someone could help

Moe Razak
moe300 is offline  
post #3 of 23 (permalink) Old 03-08-2012, 12:17 PM
Chrysler Customer Service Agent
Points: 6,527, Level: 1 Points: 6,527, Level: 1 Points: 6,527, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 76% Activity: 76% Activity: 76%
 
ChryslerCares's Avatar
 
Car:
Join Date: Jul 2011
Location: Auburn Hills
Posts: 992
Thanks: 88
Thanked 231 Times in 175 Posts
Bad thing is that most radios / media centers are exchange only parts which means that dealers can't open them up or try to repair them. They must replace it with an entire new unit.

The only TSB resembling anything described is as follows:

TSB 08-018-06

SUBJECT:
No Radio Audio Or Display Following Engine Crank

OVERVIEW:
This bulletin involves selectively erasing and reprogramming the radio with new software.

NOTE: This bulletin applies to vehicles equipped with a RAQ or REF sales code radio built on or before October 30, 2005 (MDH 1030XX)

SYMPTOM/CONDITION:
No radio audio or display following engine crank. All radio functions return when ignition key is turned off and back into accessory.
ChryslerCares is online now  
 
post #4 of 23 (permalink) Old 03-08-2012, 01:25 PM
Senior Member
Points: 12,874, Level: 1 Points: 12,874, Level: 1 Points: 12,874, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
moe300's Avatar
 
Car: 2006 Chrysler 300C SRT8
Join Date: Nov 2009
Location: London, ON, Canada
Posts: 319
Thanks: 6
Thanked 10 Times in 8 Posts
Garage
This might help, I just pulled up Chrysler TSB 08-018-06 and it stats the the labour amount is 0.3 hrs. is that what the dealer will charge me? or they will just go ahead and charge one hour?


Thanks you
moe300 is offline  
post #5 of 23 (permalink) Old 03-08-2012, 01:26 PM
Senior Member
Points: 12,874, Level: 1 Points: 12,874, Level: 1 Points: 12,874, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
moe300's Avatar
 
Car: 2006 Chrysler 300C SRT8
Join Date: Nov 2009
Location: London, ON, Canada
Posts: 319
Thanks: 6
Thanked 10 Times in 8 Posts
Garage
One more question, how come I never had this issue before, It just started showing up?
moe300 is offline  
post #6 of 23 (permalink) Old 03-09-2012, 01:12 PM
Chrysler Customer Service Agent
Points: 6,527, Level: 1 Points: 6,527, Level: 1 Points: 6,527, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 76% Activity: 76% Activity: 76%
 
ChryslerCares's Avatar
 
Car:
Join Date: Jul 2011
Location: Auburn Hills
Posts: 992
Thanks: 88
Thanked 231 Times in 175 Posts
The dealership would also have to first confirm that the TSB applied to the problem your vehicle is experiencing. Dealerships are independently owned and operated businesses so you would have to ask the dealer how much Tech time they would charge for both diagnosis and repair.

Unfortunately due to the many variables its impossible to determine why the vehicle never exhibited this problem before and just started to show up.
ChryslerCares is online now  
post #7 of 23 (permalink) Old 03-11-2012, 07:40 AM
Senior Member
Points: 9,844, Level: 1 Points: 9,844, Level: 1 Points: 9,844, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car:
Join Date: Jan 2005
Posts: 118
Thanks: 1
Thanked 0 Times in 0 Posts
Sounds like something is loose to me. Harness plug or board plug
developerx is offline  
post #8 of 23 (permalink) Old 04-06-2012, 05:23 PM
Junior Member
Points: 4,576, Level: 1 Points: 4,576, Level: 1 Points: 4,576, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 3% Activity: 3% Activity: 3%
 
Car: 2005 Chrysler 300C
Join Date: Jan 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
I've been researching my same problem for quite some time now. From what I'm gathering from my Internet research is that the problem is associated with solder issues on the radios control board. It appears there are components that are temperature sensitive. My understanding is that when we first start our cars these components are cool and as they warm up we start to loose our screens. Some with the appropriate skills have had some luck identifying and re-soldering the problem components but really risky. It looks like mine is off to United Radio at my first opportunity.
Whipper300 likes this.
Wizard of Ahs is offline  
post #9 of 23 (permalink) Old 04-06-2012, 06:42 PM
Senior Member
Points: 9,915, Level: 1 Points: 9,915, Level: 1 Points: 9,915, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
xscash's Avatar
 
Car: 06 chrysler 300c awd
Join Date: Mar 2006
Location: south of boston
Posts: 297
Thanks: 0
Thanked 1 Time in 1 Post
i have a radio that was removed the first week i got the car and is esentially brand new if anyone needs one.

06 AWD 22s'' with the KENSTYLE kit
kenwood nav with headrest tvs
auto sound shop owner

Last edited by xscash; 04-06-2012 at 06:42 PM.
xscash is offline  
post #10 of 23 (permalink) Old 04-06-2012, 09:26 PM
Super Moderator
Points: 84,927, Level: 1 Points: 84,927, Level: 1 Points: 84,927, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
MADDOG's Avatar
 
Car: 2006 Chrysler SRT8
Join Date: Apr 2007
Location: Oregon
Posts: 17,755
Thanks: 348
Thanked 2,135 Times in 1,933 Posts
Garage
Electronic components and connections do wear out. Luckily, mine is doing just fine but I hear about this at least once a week. If you have a test bench and know how to diagnose then fix small soldered connections on circuit boards, you can probably fix this. The dealer can't.

Michael
2006 300C SRT8
MADDOG is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
300C LCD Radio Screen goes out but radio still works? Gary25 General Discussion 8 04-13-2014 06:31 PM
REC radio display TA1124 Car Audio/Alarms/UConnect/Navigation 1 11-16-2008 07:29 PM
Easy RAQ for REF radio swap??? player19 Car Audio/Alarms/UConnect/Navigation 9 08-24-2007 09:13 AM
300C navigation Radio display JJ Black 06 300C Car Audio/Alarms/UConnect/Navigation 3 07-28-2006 09:26 PM
Radio Display? RobertR Appearance General Discussion 1 08-09-2004 07:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Replace with
For the best viewing experience please update your browser to Google Chrome