300C no oil pressure? - Chrysler 300C Forum: 300C & SRT8 Forums
General Discussion on Issues / Trouble Shooting General Discussion on Issues / Trouble Shooting problems and solutions

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-26-2012, 11:36 AM Thread Starter
Junior Member
Points: 925, Level: 1 Points: 925, Level: 1 Points: 925, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2012
Location: wilmington CA
Posts: 13
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exclamation 300C no oil pressure?

hey guys im new here been searching like crazy, just wanted your guys opinion. I got a 05 300C 152k, car seemed fine. I pulled into a gas station when i came back out started the car, it made a ticking noise louder than the usual hemi tick, and the oil light turned on. So i turned off the car checked the oil and it was good, When i tried to restart the car it would not turn on. Had it towed to shop, mechanic is telling me he took off the oil pressure switch and checked, and that it had no oil pressure. Hes telling me that there could be major engine damage because of this. What do you guys think? would this be as simple as changing an oil pump or am i better off just rebuilding or replacing the motor? its throwing codes P0198, p0730, p2172

any input on this would be appreciated, thanx
brutalsack is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-26-2012, 11:45 AM
Super Moderator
Points: 55,392, Level: 1 Points: 55,392, Level: 1 Points: 55,392, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
MADDOG's Avatar
 
Join Date: Apr 2007
Location: Oregon
Posts: 14,329
Thanks: 332
Thanked 1,801 Times in 1,623 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Garage
Sounds like the oil pump gave out. Try replacing it and manually turning it over, listening for any rod knocks or clunks. Then start it.

Michael
2006 300C SRT8
MADDOG is online now  
The Following User Says Thank You to MADDOG For This Useful Post:
brutalsack (11-26-2012)
post #3 of 6 (permalink) Old 11-26-2012, 02:34 PM Thread Starter
Junior Member
Points: 925, Level: 1 Points: 925, Level: 1 Points: 925, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2012
Location: wilmington CA
Posts: 13
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by MADDOG View Post
Sounds like the oil pump gave out. Try replacing it and manually turning it over, listening for any rod knocks or clunks. Then start it.
ok thnx will tell the mechanic to try it. so far he told me hes going to pull out the motor and take it apart to check bearings and other stuff not sure exactly what he said. If nothing else was damaged he was just going to replace oil pump and i forget it what else and throw it back together. If there was a lot of damage he was going to give me a call to see if i wanted it him to fix it or just replace it with another low mile motor. well see how it goes.
brutalsack is offline  
post #4 of 6 (permalink) Old 11-28-2012, 03:05 PM Thread Starter
Junior Member
Points: 925, Level: 1 Points: 925, Level: 1 Points: 925, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2012
Location: wilmington CA
Posts: 13
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
update: so apparantly my motor dropped a valve seat. found a replacement rebuild engine for $1500 so thats what im going to do.
brutalsack is offline  
post #5 of 6 (permalink) Old 12-01-2012, 01:43 PM
Senior Contributing Member
Points: 3,017, Level: 1 Points: 3,017, Level: 1 Points: 3,017, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Montreal300's Avatar
 
Join Date: Sep 2009
Posts: 698
Thanks: 3
Thanked 122 Times in 110 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Another dropped seat. Did you overheat the car recently?
Montreal300 is offline  
post #6 of 6 (permalink) Old 12-03-2012, 01:08 PM Thread Starter
Junior Member
Points: 925, Level: 1 Points: 925, Level: 1 Points: 925, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2012
Location: wilmington CA
Posts: 13
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Montreal300 View Post
Another dropped seat. Did you overheat the car recently?
na I had just got the car like a month ago. Got her for cheap seemed to run good, maybe previous owner did. That $1500 engine never came trough so i just decided to completely rebuild everything $3200 later car will be ready this weekend.
brutalsack is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
300C Hemi Oil Pressure light WFajardo General Discussion on Issues / Trouble Shooting 5 02-12-2014 06:39 PM
air pressure in the 300c OoTLink General Discussion 1 08-22-2010 06:18 PM
Tire pressure monitors on 05 300C? milljbkc Custom Wheels & Tires 1 08-25-2008 01:46 PM
Tire pressure gauge on 05 300C? milljbkc Custom Wheels & Tires 1 08-20-2008 10:06 PM
What is the proper oil pressure for a 300C at idle? Gary25 General Discussion 14 01-21-2007 07:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design