No tachometer or horn or signals or wipers or cruise cont. wiring / fuse help!!!!! - Chrysler 300C Forum: 300C & SRT8 Forums
General Discussion on Issues / Trouble Shooting General Discussion on Issues / Trouble Shooting problems and solutions

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-30-2011, 11:37 AM Thread Starter
Member
Points: 1,596, Level: 1 Points: 1,596, Level: 1 Points: 1,596, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2010
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Question No tachometer or horn or signals or wipers or cruise cont. wiring / fuse help!!!!!


i have a c&hrysler 300 2.7L. I have accidentally disconnected or blown smthng in the process. I have everything working except i have no use of anything attached to the steering column, such as turn signals, TACHOMETER, cruise control, HORN, wipers.... Any idea what wire or fuse i should check!?!. i have toyed around a lot with my car, so i imagine it was done while i had the guage cluster out, because once i plugged my guages back in, the TACHOMETER didn't work along with everything on the steering column. What wire or fduse would control everything running from the steering column (horn, signals, ect..) to ..... the abyss???.......... 8)

Last edited by scfreedl; 03-30-2011 at 11:47 AM.
scfreedl is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-30-2011, 12:37 PM
Elite Contributing Member
Points: 43,588, Level: 1 Points: 43,588, Level: 1 Points: 43,588, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Bronek's Avatar
 
Join Date: Jul 2009
Location: Saskatoon, SK
Posts: 5,045
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Bronek
Did you happen to plug the cluster in when the battery was connected still?

Sabrina - Srebrny Księżna
2005 300 Limited AWD ~ FE210 AWD? Maybe...
Click below for current mods + future plans
I do not believe in fire-breathing dragons, multi-coloured unicorns, good-willed people, omni-present creators, or other mythical creatures.
Bronek is offline  
post #3 of 4 (permalink) Old 03-30-2011, 01:56 PM
Major Contributing Member
Points: 4,358, Level: 1 Points: 4,358, Level: 1 Points: 4,358, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2006
Location: palmdale,ca
Posts: 1,140
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
check the fuses in the rear power distribution box in the trunk next to the spare tire and a point to remember when working on anything electronic on these cars disconnect the battery as there is a lot of fussy computers etc and will save you a lot of grief.
jetech00001 is offline  
post #4 of 4 (permalink) Old 09-16-2011, 02:42 PM Thread Starter
Member
Points: 1,596, Level: 1 Points: 1,596, Level: 1 Points: 1,596, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2010
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Bronek View Post
Did you happen to plug the cluster in when the battery was connected still?
i did not disconnect the battery. but when i plugged the guage cluster back in it went haywire, everything started flashing and doing wierd stuff.....
scfreedl is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control Fuse soulman97 General Discussion 2 02-27-2011 07:40 PM
What Fuse # Will Turn Off Windshield Wipers? DIGITALGRAVEL General Discussion 1 03-11-2009 07:12 PM
cruise fuse raspyvette General Discussion 5 09-10-2008 01:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design