Enigine and Red Lightning Bolt Symbols - Chrysler 300C Forum: 300C & SRT8 Forums
General Discussion General Discussion topics about the Chrysler 300 and other LX models that don't fit within the specific listed categories below.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 03-03-2014, 05:08 PM Thread Starter
Senior Member
Points: 18,456, Level: 1 Points: 18,456, Level: 1 Points: 18,456, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
acesrt's Avatar
 
Car: 2006 Chrysler SRT-8
Join Date: Jul 2007
Posts: 272
Thanks: 0
Thanked 0 Times in 0 Posts
Enigine and Red Lightning Bolt Symbols

The Enigine and Red Lightning Bolt Symbols are lit on the dash

06 SRT just over 100k.

Why might these come on?


acesrt is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 03-03-2014, 05:29 PM
Lifetime Premium Member
Points: 30,781, Level: 1 Points: 30,781, Level: 1 Points: 30,781, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
CNISTER's Avatar
 
Car: 2008 Chrysler 300C SRT Design
Join Date: Apr 2013
Location: Nashport, Ohio
Posts: 1,405
Thanks: 289
Thanked 262 Times in 223 Posts
Does it start? Drive it to Autozone or do the "Key Dance" and tell us the codes. the Red Lightning bolt I believe has something to do with the fly by wire throttle.
CNISTER is offline  
post #3 of 17 (permalink) Old 03-03-2014, 05:31 PM Thread Starter
Senior Member
Points: 18,456, Level: 1 Points: 18,456, Level: 1 Points: 18,456, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
acesrt's Avatar
 
Car: 2006 Chrysler SRT-8
Join Date: Jul 2007
Posts: 272
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Bullnugget View Post
Does it start? Drive it to Autozone or do the "Key Dance" and tell us the codes. the Red Lightning bolt I believe has something to do with the fly by wire throttle.

Yes it starts but sounded kinda rough...... it was 14 degrees f in nj today though
acesrt is offline  
 
post #4 of 17 (permalink) Old 03-03-2014, 06:20 PM
Super Moderator
Points: 84,927, Level: 1 Points: 84,927, Level: 1 Points: 84,927, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
MADDOG's Avatar
 
Car: 2006 Chrysler SRT8
Join Date: Apr 2007
Location: Oregon
Posts: 17,755
Thanks: 348
Thanked 2,135 Times in 1,933 Posts
Garage
Sounds like a throttle body problem but to determine exactly what the problem is, we'll need the Diagnostic Trouble Codes (DTC's) from your car's computer. Here's the instructions on how to read the codes via your EVIC:

Checking For Codes - Doing The "Key Dance"

Michael
2006 300C SRT8
MADDOG is offline  
post #5 of 17 (permalink) Old 03-04-2014, 08:30 AM Thread Starter
Senior Member
Points: 18,456, Level: 1 Points: 18,456, Level: 1 Points: 18,456, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
acesrt's Avatar
 
Car: 2006 Chrysler SRT-8
Join Date: Jul 2007
Posts: 272
Thanks: 0
Thanked 0 Times in 0 Posts
p2181

p2181
acesrt is offline  
post #6 of 17 (permalink) Old 03-04-2014, 09:18 AM
Lifetime Premium Member
Points: 30,781, Level: 1 Points: 30,781, Level: 1 Points: 30,781, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
CNISTER's Avatar
 
Car: 2008 Chrysler 300C SRT Design
Join Date: Apr 2013
Location: Nashport, Ohio
Posts: 1,405
Thanks: 289
Thanked 262 Times in 223 Posts
Possible causes

- Low coolant level
- Faulty Engine Coolant Temperature Sensor
- Stuck or leaking thermostat
- Engine Coolant Temperature Sensor harness is open or shorted
- Engine Coolant Temperature Sensor circuit poor electrical connection

Found this online, Obviously first check the coolant level.
Next I would check your temp when fully warmed up. If you hold down the Compass and Music buttons together for a few seconds it will load up a secret menu screen. There is a screen that will give a digital reading of Water temp. Give us that temp when operating the car normally,

Too Hot, the thermostat may be stuck shut/faulty
Too Cold, the thermostat may be stuck open/faulty
Either of which would require a replacement. BUT the sensor may also be faulty, I would think this would give an OBVIOUS wrong reading, like 100 degrees when driving around.

As far as the last two options, I would not be able to really help there. Normal operating temp on a stock 5.7 is around 200-210 F, I would think the 6.1 is around that as well.
Unless of course you have a Programmer such as a Diablosport and have moved the fan settings without changing the thermostat?
Are there any mods you have on your car?

Last edited by CNISTER; 03-04-2014 at 09:18 AM.
CNISTER is offline  
The Following User Says Thank You to CNISTER For This Useful Post:
MADDOG (03-04-2014)
post #7 of 17 (permalink) Old 03-04-2014, 06:19 PM Thread Starter
Senior Member
Points: 18,456, Level: 1 Points: 18,456, Level: 1 Points: 18,456, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
acesrt's Avatar
 
Car: 2006 Chrysler SRT-8
Join Date: Jul 2007
Posts: 272
Thanks: 0
Thanked 0 Times in 0 Posts
The car is 100% stock.

The other day I turned on the heat after the engine was warmed
and got cold air blown for at least 1 min......

mean anything?
acesrt is offline  
post #8 of 17 (permalink) Old 03-04-2014, 08:10 PM
Lifetime Premium Member
Points: 30,781, Level: 1 Points: 30,781, Level: 1 Points: 30,781, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
CNISTER's Avatar
 
Car: 2008 Chrysler 300C SRT Design
Join Date: Apr 2013
Location: Nashport, Ohio
Posts: 1,405
Thanks: 289
Thanked 262 Times in 223 Posts
Not usually, I am not 100% sure, but I think the heater core would be blocked off from coolant unless the heat is on. I think its a fairly new thing on cars. So it would still have cooler coolant in the heater core untill it was circulated.
CNISTER is offline  
post #9 of 17 (permalink) Old 03-05-2014, 06:07 AM
Elite Contributing Member
Points: 43,612, Level: 1 Points: 43,612, Level: 1 Points: 43,612, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 17% Activity: 17% Activity: 17%
 
onesickhotrod's Avatar
 
Car: 2005 Chrysler 300C
Join Date: Jul 2009
Location: Rochester, New York
Posts: 2,402
Thanks: 53
Thanked 287 Times in 235 Posts
Garage
Send a message via AIM to onesickhotrod
The thermostat is a cheap and easy fix. If you have never done that I recommend it asap. Also time for a coolant flush.

Sent from AutoGuide.com Free App


Rochester, NY

See my garage for upgrades
onesickhotrod is offline  
post #10 of 17 (permalink) Old 03-17-2014, 08:54 AM Thread Starter
Senior Member
Points: 18,456, Level: 1 Points: 18,456, Level: 1 Points: 18,456, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
acesrt's Avatar
 
Car: 2006 Chrysler SRT-8
Join Date: Jul 2007
Posts: 272
Thanks: 0
Thanked 0 Times in 0 Posts
Yesterday the air blew cold for ten min after the engine warmed up. Shut the fan, waited a min, turned it back on and it blew hot air for one min, then back to cold. Also the temp readout on the dash stayed in the cold area for the entire 1 hr drive.

code p2181 is still present
acesrt is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Lightning music realsmooth Problems / Dealer Service 15 02-10-2016 11:28 AM
Red Lightening bolt and no codes blueeyed300 General Discussion on Issues / Trouble Shooting 12 07-30-2012 07:02 AM
Red Lightning Bolt (Moved) mako Problems / Dealer Service 25 12-09-2011 12:09 PM
Lightning Bolt at 80mph - and Stalling - Help! TopTrainer 1st Gen SRT8-Specific Problems/Dealer Service 14 03-06-2011 09:12 AM
Red Lightning spacenase UK & Europe Regional Forum 20 10-11-2010 06:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Replace with
For the best viewing experience please update your browser to Google Chrome