Front Suspension problems??????? - Chrysler 300C Forum: 300C & SRT8 Forums
Interested in the Dodge Challenger? Be sure to check out the Dodge Challenger Forum for your Dodge Challenger information!
» Featured Product
» Buyers Guide

Wheel & Tire Center

Go Back   Chrysler 300C Forum: 300C & SRT8 Forums > Chrysler 300 & All LX Models Forums > General Discussion
Register Home Forum Active Topics (T) Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto Loans

General Discussion General Discussion topics about the Chrysler 300 and other LX models that don't fit within the specific listed categories below.

300cForums.com is the premier Chrysler 300c Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-09-2010, 12:13 AM   #1 (permalink)
Senior Contributing Member
Points: 31,504, Level: 1 Points: 31,504, Level: 1 Points: 31,504, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 1% Activity: 1% Activity: 1%
 
Car: 2012 Chrysler SRT8
Join Date: Jan 2009
Member Number: 20692
Location: New Hampshire
Posts: 524
Thanks: 0
Thanked 3 Times in 2 Posts
Front Suspension problems???????

Have an 06 Chryslerr 300c thats reaching 50,000 miles. Usually at low speeds under 15mph and hit a small hole/pothole you can hear kind of a louder clonk. Anyone have any idea what it may be? Anyone having same problem? is it common?
__________________
2012 Chrysler 300 SRT8-White
LMI Intake
Intune
35 percent tint all around
zim-300srt8 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-09-2010, 12:40 AM   #2 (permalink)
Senior Contributing Member
Points: 8,037, Level: 1 Points: 8,037, Level: 1 Points: 8,037, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 3% Activity: 3% Activity: 3%
 
300fisch's Avatar
 
Car: 2006 & 2008 Chrysler 300C & 300C SRT8
Join Date: Sep 2009
Member Number: 23930
Location: Minnesota
Posts: 978
Thanks: 0
Thanked 1 Time in 1 Post
Outer tie rods on the C are a known issue. Could be that or a ball joint possibly??
__________________
300fisch is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 03-09-2010, 01:08 AM   #3 (permalink)
Junior Member
Points: 204, Level: 1 Points: 204, Level: 1 Points: 204, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2006 Dodge D3500
Join Date: Dec 2009
Member Number: 24735
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Hi friend,
I am facing the same problem & thinking of posting a same thread.

If you got the solution please let me know.

All friends just help us ??????
__________________
Used cars for sale by owner
LisaWilliams is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 03-09-2010, 01:15 AM   #4 (permalink)
Elite Contributing Member
Points: 42,667, Level: 1 Points: 42,667, Level: 1 Points: 42,667, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 1% Activity: 1% Activity: 1%
 
BIG SMOOTH's Avatar
 
Car: 2006 Chrysler 300C
Join Date: Sep 2006
Member Number: 7757
Location: San Diego
Posts: 2,422
Thanks: 10
Thanked 23 Times in 23 Posts
Quote:
Originally Posted by 300fisch View Post
Outer tie rods on the C are a known issue. Could be that or a ball joint possibly??
Done and changed those and much, MUCH more.

This last week I had my Eibach shocks and struts replaced with Koni STR.T shocks and guess what?

My clunk is gone now. The Eibachs were all leaking at the seals.

Check your shocks/struts along with your tie rods, ball joints, sway bar end links and bushings.....
BIG SMOOTH is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 03-09-2010, 11:45 AM   #5 (permalink)
Junior Member
Points: 1,712, Level: 1 Points: 1,712, Level: 1 Points: 1,712, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2006 Chrysler 300c Touring
Join Date: Nov 2007
Member Number: 15222
Location: Cardiff U.K.
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
I took my car in last week to my local stealership as I had a similar clunk/rattle on the near front side. I was told it was the suspension bushes but they couldn't repair it for me as there are apparently no spare parts for this problem anywhere in the UK ! They are currently on back order but have no anticipated delivery date. The car is due for its MOT early next month, and if this doesn't get repaired, will probably fail! What sort of car manufacturer is Chrysler these days? Has anyone had the same problem getting the repair carried out?
__________________
glamorgan is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 03-09-2010, 03:43 PM   #6 (permalink)
Senior Member
Points: 3,151, Level: 1 Points: 3,151, Level: 1 Points: 3,151, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
simtso's Avatar
 
Car: 2005 chrysler 300c cool vanilla
Join Date: Sep 2006
Member Number: 8205
Location: laval, qc, canada
Posts: 127
Thanks: 0
Thanked 0 Times in 0 Posts
Yes it is a common problem with these cars, i have it also. I replaced my outer tie rods recently but the clunking noise is still present, I ordered front sway bar bushings and waiting to get them installed. I will let you know if this solves the klunking noise.
simtso is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 03-09-2010, 07:05 PM   #7 (permalink)
Senior Member
Points: 4,351, Level: 1 Points: 4,351, Level: 1 Points: 4,351, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 18% Activity: 18% Activity: 18%
 
Car: 2006 chrysler 300c and 05 infinity G35
Join Date: Jan 2009
Member Number: 20841
Location: San Bruno,CA
Posts: 289
Thanks: 0
Thanked 0 Times in 0 Posts
I had the same thing,it turned out it was the control arm bushing,but you have to replace the whole control arm.
__________________
K&N CAI
JBA Ceramic coated headers
JBA high flow Cats
JBA stainless steel Exhaust
Diablo Predator
HHP Custom Tune
SRT8 spoiler
22 elite arm rest
50% tint
JBL GTO 14001
diamond audio D3 subs
MB quart amp.
JVC avx720
Mesh grill
180 T-stat
kd300c is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 03-09-2010, 10:12 PM   #8 (permalink)
Senior Contributing Member
Points: 31,504, Level: 1 Points: 31,504, Level: 1 Points: 31,504, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 1% Activity: 1% Activity: 1%
 
Car: 2012 Chrysler SRT8
Join Date: Jan 2009
Member Number: 20692
Location: New Hampshire
Posts: 524
Thanks: 0
Thanked 3 Times in 2 Posts
The drivers side outer tie rod was replaced early on the car and the passenger side was replaced at 47,000 and now the drivers one is going out!!!! But its coming from the passenger side for sure so its not the outer tie rod. Im gonna probably take it to the dealership and see if they can do a quick check. I hope its not the lower control arm lol
zim-300srt8 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 03-23-2010, 03:01 PM   #9 (permalink)
Junior Member
Points: 974, Level: 1 Points: 974, Level: 1 Points: 974, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
bhomes's Avatar
 
Car: 2006 Chrysler 300c SRT8
Join Date: Feb 2010
Member Number: 25747
Location: Nanaimo, BC
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
I just bought 06' SRT 8 with very low mileage...only 27,000kms (approx. 17,000 miles) and noticed a small clunking and some minimal vibration which appears to be coming from the front LH/passenger side. Could it be some of the same things you guys are mentioning? It seems like the mileage is to low for components like sway bar bushing, tie rod ends, and ball joints to be wearing out?
bhomes is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 03-23-2010, 03:50 PM   #10 (permalink)
Member
Points: 461, Level: 1 Points: 461, Level: 1 Points: 461, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Rosco's Avatar
 
Car: 2005 Chrysler 300C
Join Date: Jan 2009
Member Number: 20715
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by BIG SMOOTH View Post
Done and changed those and much, MUCH more.

This last week I had my Eibach shocks and struts replaced with Koni STR.T shocks and guess what?

My clunk is gone now. The Eibachs were all leaking at the seals.

Check your shocks/struts along with your tie rods, ball joints, sway bar end links and bushings.....
What do you think of your STR.Ts??? I installed a set about 6 months ago, not bad but the front shocks are still is a bit soft for my liking.
Rosco is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A bit worried about suspension problems keat CRD Wheels / Tyres / Suspension / Brake 13 09-08-2010 12:42 PM
New guy here with some possible suspension problems Frankie Problems / Dealer Service 3 09-22-2009 11:03 PM
SRT-8 Suspension swap problems Davez 300C Suspension/Handling Modifications 6 11-22-2007 10:43 PM
suspension problems with 22"s xsbc63x Custom Wheels & Tires 1 03-27-2006 08:36 PM
Front Right Strut - Suspension problems anyone? hemiwife General Discussion 9 07-22-2005 03:24 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:57 PM.



Inactive Reminders By Icora Web Design

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2