AC compressor clutch - Chrysler 300C Forum: 300C & SRT8 Forums
General Discussion General Discussion topics about the Chrysler 300 and other LX models that don't fit within the specific listed categories below.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 26 (permalink) Old 08-31-2010, 06:12 PM Thread Starter
Junior Member
Points: 1,841, Level: 1 Points: 1,841, Level: 1 Points: 1,841, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 Chrysler 300
Join Date: Jul 2010
Location: Ontario, Canada
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy AC compressor clutch

Hi all,

I have a 2005 3.5L. My AC is blowing only warm air. I checked my AC pressure and it seems to be high enough that it should engage the clutch, but it is not. When I cycle the AC to ON, the clutch does not engage. I can turn the clutch by hand with no problem. I tried tapping all the lines to see if that would help but no go. Please guide me on any troubleshooting steps I can take in order to find out why the clutch is not engaging.

Any help would be greatly appreciated as it is freakin HOT!

"I'm burning up!!"
amageed is offline  
Sponsored Links
Advertisement
 
post #2 of 26 (permalink) Old 08-31-2010, 07:10 PM Thread Starter
Junior Member
Points: 1,841, Level: 1 Points: 1,841, Level: 1 Points: 1,841, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 Chrysler 300
Join Date: Jul 2010
Location: Ontario, Canada
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Anyone? Is it possible to jump the clutch relay to see if I can force the clutch to engage? If so, how is this done? Please help!!
amageed is offline  
post #3 of 26 (permalink) Old 08-31-2010, 07:37 PM Thread Starter
Junior Member
Points: 1,841, Level: 1 Points: 1,841, Level: 1 Points: 1,841, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 Chrysler 300
Join Date: Jul 2010
Location: Ontario, Canada
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Update: Okay, I found the clutch relay and jumped 30 to 87 and whamo, I got the clutch to engage and cool air seems to be coming from AC again. Now, next question: Does this mean I have a bad relay? Can I leave the jumper on until I get a new relay or could this cause a major problem? Need a quick response as I have to drive 200k tomorrow in the 35 degree weather. Please advise.
amageed is offline  
 
post #4 of 26 (permalink) Old 08-31-2010, 07:44 PM
Member
Points: 2,943, Level: 1 Points: 2,943, Level: 1 Points: 2,943, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
WantOne's Avatar
 
Car: 2012 Chrysler 300 SRT
Join Date: Jun 2007
Location: Hamilton, Ontario
Posts: 98
Thanks: 2
Thanked 1 Time in 1 Post
Check the fuse for the circuit. I don't know which on it is, but probably in the front fuse center.

I GOT IT
WantOne is offline  
post #5 of 26 (permalink) Old 09-09-2010, 03:42 PM
Senior Member
Points: 23,665, Level: 1 Points: 23,665, Level: 1 Points: 23,665, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
5CH_omar's Avatar
 
Car: 2005 Chrysler 300C
Join Date: Jun 2009
Location: Houson, Tx
Posts: 291
Thanks: 15
Thanked 2 Times in 2 Posts
anything new? i am having the same issue
5CH_omar is offline  
post #6 of 26 (permalink) Old 09-11-2010, 09:54 AM Thread Starter
Junior Member
Points: 1,841, Level: 1 Points: 1,841, Level: 1 Points: 1,841, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 Chrysler 300
Join Date: Jul 2010
Location: Ontario, Canada
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
5CH omar, yes. I ended up pulling the relay out from the fuse box under the hood and jumped pin 30 and 87 with a paper clip...the compressor turned on immediately and got COLD air from my AC once again!! If you pull out the relay, it will tell you on the bottom which pins are 30 and 87.

Now I just have to go buy a new relay (under $10). Finally fixed an issue that didn't cost much $$$$!

Let me know how you make out.
amageed is offline  
post #7 of 26 (permalink) Old 09-11-2010, 09:56 AM Thread Starter
Junior Member
Points: 1,841, Level: 1 Points: 1,841, Level: 1 Points: 1,841, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2005 Chrysler 300
Join Date: Jul 2010
Location: Ontario, Canada
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
oh yeah, I forgot to mention...
Seeing as the hot days are far and few between now, I have been just putting the jumper on when needed and removing it when I park the car. I don't want to leave the jumper on as I read somewhere that it could drain your battery as it will constantly send power to your compressor even with the ignition off.
amageed is offline  
post #8 of 26 (permalink) Old 09-11-2010, 01:25 PM
Major Contributing Member
Points: 113,961, Level: 1 Points: 113,961, Level: 1 Points: 113,961, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 29% Activity: 29% Activity: 29%
 
BobF's Avatar
 
Car: 2017 Chrysler 300S Ceramic Gray Clear Coat
Join Date: Sep 2005
Location: Southern California
Posts: 1,241
Thanks: 2
Thanked 11 Times in 8 Posts
I am just curious. Is there 12 V coming to one side of the relay coil and is the other side of the relay coil grounded? If not then replacing the relay will not help. The problem could be elsewhere as I see it. Regards, Bob.

2017 Chrysler 300S
BobF is offline  
post #9 of 26 (permalink) Old 09-13-2010, 09:23 AM
Senior Member
Points: 23,665, Level: 1 Points: 23,665, Level: 1 Points: 23,665, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
5CH_omar's Avatar
 
Car: 2005 Chrysler 300C
Join Date: Jun 2009
Location: Houson, Tx
Posts: 291
Thanks: 15
Thanked 2 Times in 2 Posts
So i had a friend of mine look at the car and i thought the compressor was turning on because i would see the rpm change when i turned the ac on even thought there was no cold air. He took a look and saw the compressor was in fact not turning on so he added some freon to see if the pump need more charge to turn on the compressor. Next thing i know the compressor kick in and then cold ac...ahhhhhh

He then did a vaccum test to see if there was a leak and if so how large was it, but he found nothing. So he recharged the system and its been working great. TOO HOT IN TEXAS to be dealing with this bs.

Does anyone know the charge the compressor is suppose to be?? I think he had it at 55 LBS
5CH_omar is offline  
post #10 of 26 (permalink) Old 05-13-2011, 09:55 AM
Junior Member
Points: 464, Level: 1 Points: 464, Level: 1 Points: 464, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300 Touring
Join Date: May 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Ok I have the same problem I am wanting to also check the Relay but I can not find anywere what relay is for what. I have a chart for the fuses but not for the relays. So what # is it.
frizman86 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
air compressor/pump Joe S General Discussion 0 09-09-2007 10:14 AM
Dual-Clutch Transmissions Rambit Other Chrysler/Dodge/Jeep/Fiat Vehicle Discussion 1 09-05-2007 01:04 PM
Smoked Compressor? MT DUBn Suspension/Handling Modifications 6 08-30-2007 10:21 PM
Compressor acesrt General Discussion 1 07-15-2007 03:45 PM
spring compressor? Rollin on Dueces Appearance General Discussion 4 04-04-2005 07:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome