Chrysler 300C Forum: 300C & SRT8 Forums - View Profile: Olly57

Olly57 Olly57 is offline

Junior Member

  Visitor Messages

Showing Visitor Messages 1 to 3 of 3
  1. Olly57
    08-01-2014 08:54 AM - permalink
    Olly57
    Well - there is hope that the day will end well -Inde' has reported back that he tested the alternator power again and it had dropped to 11.7v below the required 14v or normal power indication. However, having had the same unit replaced 21 months ago and still under warranty they had to change it FOC - well thats a first for my 300c SO all good again in the world for the next few hours anyway. Whilst I like my car I really can't abide the amount of making good that has to be carried out on a car like this. Alternator, brakes, swirl motor, fuel feed pipes, none broken just warn out. Haven't done a huge amount of mileage, and very well looked after car etc.
  2. Olly57
    08-01-2014 01:41 AM - permalink
    Olly57
    Problem increasing, now the battery light takes about 4 miles to go out, concerned as this has the same symptoms as the fuel pipes splitting and the deisel running into the alternator (knackered last time) Car taken back to Inde' last night and said don't give it back until issue found and resolved. Saw that another member was quoted around £700 for a swirl motor to be changed etc, this inde' charged a whole lot more, starting to get suspicious about their pricing etc. If I knew what I was looking for I would buy the parts myself and just then have to pay for the labour. The total cost of swirl motor plus labour was considerably more than the quote from the Chrysler dealership. Will update when I have the answer from the Inde' as to what the additional problem is in case this information is useful to others.
  3. Olly57
    07-30-2014 10:48 AM - permalink
    Olly57
    I have a 300c 2007 plate. Just had the swirl motor and bits replaced (god what a cost£££££££). A problem still exists: Turn the key on & let the usual lights go out (glow plugs etc) start the engine, all good, drive off and the red battery light comes back on for about 100 metres and then goes off. I have had the fuel lines and the alternator replaced about 18 months ago so hope to go it is not this AGAIN. Anyone had anything similar, what could it be, and what did it cost to put right?

  About Me

  • About Olly57
    Year
    2007
    Make
    Chrysler
    Model
    300c (3.0 Desiel)
  • Signature
    Olly 57

  Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: 08-06-2014 05:41 AM
  • Join Date: 10-28-2012
  • Referrals: 0

  Experience

Experience
  • Points: 707
  • Level: 1
  • Points: 707, Level: 1 Points: 707, Level: 1 Points: 707, Level: 1
  • Level up: 99%
  • Points needed: 0
  • Level up: 99% - 0 Points needed Level up: 99% Level up: 99% - 0 Points needed
  • Activity: 0%
  • Activity: 0% Activity: 0% Activity: 0%
Points for user
  • Points for User: 355
  • Per day: 323
  • Visitormessages: 3
  • Filled profile: 30
Points for threads
  • Points for threads: 333
  • Replies: 8
  • Views: 326
Points for posts
  • Points for Posts: 19
  • Posts: 19
  • Average Posts per Day: 0.03
Activities

  Mentions

No results to display...

  Thread Tags

No results to display...

  Quotes

No results to display...

  iTrader Rating

iTrader Profile Recent Ratings
iTrader Rating:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback
  Past
Month
Past
6 Months
Past
12 Months
Positive Positive 0 0 0
Neutral Neutral 0 0 0
Negative Negative 0 0 0
 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design