Engine Light on-RKE Battery??? HELP!! - Chrysler 300C Forum: 300C & SRT8 Forums
Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-27-2006, 03:26 PM Thread Starter
Junior Member
Points: 1,756, Level: 1 Points: 1,756, Level: 1 Points: 1,756, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Engine Light on-RKE Battery??? HELP!!

I recently had my car service at the dealer (oil change). I started driving it today and noticed as I pressed the gas, the car hesitated during acceleration. The engine light came on and RKE Battery displayed on the instrument panel. The dealer checked that a 23 point inspection was complete. Has anyone had this problem? If so, please advise!!!
sameolwill is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-28-2006, 06:07 AM
Senior Member
Points: 2,768, Level: 1 Points: 2,768, Level: 1 Points: 2,768, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2005
Posts: 124
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The rke is just a low battery in your Remote Keyless Entry. The hesitation needs to be checked by them. Not sure what could be causing that.
magnumfreak is offline  
post #3 of 7 (permalink) Old 05-28-2006, 09:29 PM
Senior Member
Points: 10,875, Level: 1 Points: 10,875, Level: 1 Points: 10,875, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2004
Location: Wainwright AB, Canada
Posts: 458
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had the same fault a year and a half ago just after i purchased mine and after taking it in I havent seen the fault since. I dont think its anything to be concerned about even though I freaked when mine started to come on.

steve 300c is offline  
post #4 of 7 (permalink) Old 06-07-2006, 06:21 PM
Member
Points: 1,568, Level: 1 Points: 1,568, Level: 1 Points: 1,568, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
sarcasim02's Avatar
 
Join Date: Feb 2006
Location: Ohio
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to sarcasim02
What does a 23 point inspection have to do with your hesitation. Did he tell you what was the cause? Could they duplicate the concern? The RKE (Remote Keyless Entry) would not cause the hesitation. Please have them check the vehicle again to see why the vehicle hesitated.

You can't fix stupid and thats the truth ruth!!
sarcasim02 is offline  
post #5 of 7 (permalink) Old 06-07-2006, 08:21 PM
Lifetime Premium Member
Points: 49,072, Level: 1 Points: 49,072, Level: 1 Points: 49,072, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 19% Activity: 19% Activity: 19%
 
Join Date: Feb 2005
Location: Coatesville, PA, U.S.A.
Posts: 3,616
Thanks: 2
Thanked 166 Times in 151 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
When my RKE BATTERY messge popped up I popped the keyfob open to get the battery number to go buy a replacement.
As it turned out, the battery holding clip in the fob had popped loose of a couple of solder joints! I re-soldered and put the original battery back into the fob. All is well. Others have had the same problem!

2005 300C BRILLIANT BLACK, DRL, Mesh Grill/Vents, Chrome Pillars & Fender Trim, MDS Indicator, Quad Brake Lights, Tinted Windows, De-Molded, K&N Aircharger, 180 T-Stat, Flashing Sidemarkers, Predator Cust. Perf. 93 CAI Tune
1997 MUSTANG COBRA 'VERT, TRIPLE BLACK, Vortech S/C'd., ECT Mod., 4.10 Rear, 18" Saleen Wheels
1950 FORD TUDOR FLATHEAD V8 - Sold 6/27/14 after 16 years of fun.
DESIREE is offline  
post #6 of 7 (permalink) Old 06-08-2006, 05:14 PM
Member
Points: 1,568, Level: 1 Points: 1,568, Level: 1 Points: 1,568, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
sarcasim02's Avatar
 
Join Date: Feb 2006
Location: Ohio
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to sarcasim02
We have been running in to that same problem here as well. For some reason the prongs that hold in the batteries have been breaking off. Im not sure what is the cause (Dropping the key, weak sodier or weak joints?) but if your fob is intergrated w/ the key then others are likely to run into the same problems. I have fowarded this same concern to my DM (Last year) and have yet to here from anyone at DCX......
sarcasim02 is offline  
post #7 of 7 (permalink) Old 07-15-2006, 12:08 AM
Elite Contributing Member
Points: 93,196, Level: 1 Points: 93,196, Level: 1 Points: 93,196, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
joey's Avatar
 
Join Date: Jun 2004
Location: fremont ca
Posts: 4,565
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by sarcasim02
We have been running in to that same problem here as well. For some reason the prongs that hold in the batteries have been breaking off. Im not sure what is the cause (Dropping the key, weak sodier or weak joints?) but if your fob is intergrated w/ the key then others are likely to run into the same problems. I have fowarded this same concern to my DM (Last year) and have yet to here from anyone at DCX......
About a week ago my remote door opener stopped working for a couple of hours. Then the next day the trunk wouldn't open, the doors would open. That also lasted a few hours.
For the past 5 days everything has been working fine again, but then in the past 2 days I have gotten the RKE Battery.

Do I need a new remote battery or new key? Do they sell the batteries at the dealer?
joey is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
RKE Low Battery (great forum) Rowbear General Discussion 0 10-02-2008 06:05 PM
RKE Battery low ftv Problems / Dealer Service 5 08-10-2008 01:23 PM
RKE Battery Low warning.. TTP 1st Gen SRT8-Specific General Discussion 4 05-19-2008 12:19 AM
? RKE Battery Low Lisamel General Discussion 15 04-28-2008 07:16 PM
RKE Battery Low moddog Problems / Dealer Service 10 04-24-2006 06:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design