No Heat!!! Check engine on the freeway. - Chrysler 300C Forum: 300C & SRT8 Forums
Interested in the Dodge Challenger? Be sure to check out the Dodge Challenger Forum for your Dodge Challenger information!
» Featured Product
» Buyers Guide

Wheel & Tire Center

Go Back   Chrysler 300C Forum: 300C & SRT8 Forums > Troubleshooting Forums > Problems / Dealer Service
Register Home Forum Active Topics (T) Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

300cForums.com is the premier Chrysler 300c Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-17-2007, 06:52 AM   #1 (permalink)
Senior Member
Points: 2,638, Level: 1 Points: 2,638, Level: 1 Points: 2,638, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300 Touring
Join Date: Feb 2007
Member Number: 10930
Posts: 136
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to hackedtodeath
No Heat!!! Check engine on the freeway.

2 days ago I wake up get in my car to go-to work and i turn the heat on the floor until it heats up. While about 10 mins after driving my engine temp was warm so i turned the heat on and BAM!!! cold air. It was hot for like 1 mins then went cold. The ac button is not on. I don't think its a fuse because then the hold hvac unit would not work. So any help would be grateful. I don't know if anyone else has the same problem but the check engine light comes on when I'm doing about 80 mph for about 5 mins straight. And stay on for a little bit. once the car cools down the light off. IT never comes on in during city driving, only highway

Those are my two problems anyone have the same ones?
__________________
Mod List

(x) Hid 6000k Headlights
(x) Hid 6000k Fog Lights( blew out driver side water leak)
(x) Debadged
(x) Demolded
( ) 22" Wheel Gotta have 6" lip
( ) Double mesh chrome grill
( ) Painted Tails
( ) 300c Chrome kit
( ) Chrome interior package

Let me know what I'm missing!
hackedtodeath is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-17-2007, 07:33 AM   #2 (permalink)
Lifetime Premium Member
Points: 41,869, Level: 1 Points: 41,869, Level: 1 Points: 41,869, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 53% Activity: 53% Activity: 53%
 
Car: 2005 Chrysler 300C
Join Date: Feb 2005
Member Number: 1483
Location: Coatesville, PA, U.S.A.
Posts: 3,445
Thanks: 2
Thanked 130 Times in 121 Posts
Quote:
Originally Posted by hackedtodeath View Post
2 days ago I wake up get in my car to go-to work and i turn the heat on the floor until it heats up. While about 10 mins after driving my engine temp was warm so i turned the heat on and BAM!!! cold air. It was hot for like 1 mins then went cold. The ac button is not on. I don't think its a fuse because then the hold hvac unit would not work. So any help would be grateful. I don't know if anyone else has the same problem but the check engine light comes on when I'm doing about 80 mph for about 5 mins straight. And stay on for a little bit. once the car cools down the light off. IT never comes on in during city driving, only highway

Those are my two problems anyone have the same ones?
I'd suspect a faulty thermostat. There was a rash of that awhile back. While I never noticed a problem, when I replaced the stock t-stat with a 180*F unit this is what I found: a torn seal:


Take your car into the stealership for service under warranty.
__________________
2005 300C BRILLIANT BLACK, DRL, Mesh Grill/Vents, Chrome Pillars & Fender Trim, MDS Indicator, Quad Brake Lights, Tinted Windows, De-Molded, K&N Aircharger, 180 T-Stat, Flashing Sidemarkers, Predator Cust. Perf. 93 CAI Tune
1997 MUSTANG COBRA 'VERT, TRIPLE BLACK, Vortech S/C'd., ECT Mod., 4.10 Rear, 18" Saleen Wheels
1950 FORD TUDOR FLATHEAD V8, FLAT BLACK, 54 Chevy Grill, Nosed/Decked, Frenched Headlights, Air Shocks, Three-On-The-Floor w/OD, Dual Glasspack Exhaust, Dual Two-Barrel Carbs
DESIREE is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-20-2007, 09:49 AM   #3 (permalink)
Senior Member
Points: 2,638, Level: 1 Points: 2,638, Level: 1 Points: 2,638, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300 Touring
Join Date: Feb 2007
Member Number: 10930
Posts: 136
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to hackedtodeath
thanks taking it in today they said that it could be the thermostat so you hit it right on the nose. Thanks a bunch
hackedtodeath is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-20-2007, 04:27 PM   #4 (permalink)
Senior Member
Points: 4,622, Level: 1 Points: 4,622, Level: 1 Points: 4,622, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 GMC Yukon Denali XL
Join Date: Jun 2007
Member Number: 12454
Location: Puyallup, WA
Posts: 465
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to IronMedic
yeah im having a similar problem. i get cold air blowing through all temp ranges except max. i dont know if that is a thermostat too. i need to find time to bring it in
__________________
2007 GMC Yukon Denali XL aka "The Tank"
IronMedic is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine On. Any Help? c'zer General Discussion 19 01-26-2010 01:06 PM
check engine light walto 1st Gen SRT8-Specific General Discussion 4 05-03-2009 10:36 AM
check engine/o2 ? 2005_300c General Discussion 2 06-16-2008 10:02 AM
Engine HEAT! NEED HELP. MTNHEMI General Discussion 12 09-10-2006 09:27 PM
Engine Temp and Heat lgret13 Off-Topic Discussion 5 12-21-2004 09:16 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:26 PM.



Inactive Reminders By Icora Web Design

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2