P0520 Code reset - Chrysler 300C Forum: 300C & SRT8 Forums
Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-23-2009, 08:44 AM Thread Starter
Senior Member
Points: 17,944, Level: 1 Points: 17,944, Level: 1 Points: 17,944, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
5CH_omar's Avatar
 
Join Date: Jun 2009
Location: Houson, Tx
Posts: 270
Thanks: 13
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
P0520 Code reset

I just got the engine malfuction indicator light the other day. I read a topic by Big K, which was great. He mentioned that you could reset the illuminated errors (warnings) on the dash but didnít mention how to do this. Can anyone tell me how to do this? I Still need to replace the oil pressure switch, but this givies me a little more time.
5CH_omar is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-23-2009, 08:55 AM
Senior Member
Points: 7,442, Level: 1 Points: 7,442, Level: 1 Points: 7,442, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Aug 2008
Posts: 296
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You can pop the hood and pull fuse 11 for a couple of minutes. Should reset it for you. I had one this weekend after adding some fuel additive and pulled fuse 11. Went away.
ojmcneill is offline  
post #3 of 6 (permalink) Old 11-23-2009, 09:28 AM Thread Starter
Senior Member
Points: 17,944, Level: 1 Points: 17,944, Level: 1 Points: 17,944, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
5CH_omar's Avatar
 
Join Date: Jun 2009
Location: Houson, Tx
Posts: 270
Thanks: 13
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ok ill try that when i get home. thanks
5CH_omar is offline  
post #4 of 6 (permalink) Old 11-23-2009, 02:15 PM
Senior Member
Points: 5,926, Level: 1 Points: 5,926, Level: 1 Points: 5,926, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Fastman425's Avatar
 
Join Date: Jan 2009
Location: Madtown, Wisco
Posts: 477
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
good luck....I'm currently dealing with p0520.....I've pulled that fuse like 5 times; it'll just keep coming back.
Fastman425 is offline  
post #5 of 6 (permalink) Old 11-23-2009, 04:06 PM Thread Starter
Senior Member
Points: 17,944, Level: 1 Points: 17,944, Level: 1 Points: 17,944, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
5CH_omar's Avatar
 
Join Date: Jun 2009
Location: Houson, Tx
Posts: 270
Thanks: 13
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I remember this code comming up before. I took it to the dealer and i think they replaced a part @ $1,000. Im guessing that was the entire circut boards itself. Yeah, i got money like that. LOL i just wanted to see what that would look like posting it up. all joking aside, i had maintence insurance, which covered this all i had to pay is 50 bucks. I dont think however that they changed the sensor. I think they just went for the big stuff since i had insurance. I wish i could call up and ask but my dealer in houston is no longer open since the economy went to George bush, ahem....I mean $&$*
5CH_omar is offline  
post #6 of 6 (permalink) Old 11-23-2009, 06:31 PM
Banned by AutoGuide
Points: 54,809, Level: 1 Points: 54,809, Level: 1 Points: 54,809, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2006
Posts: 5,754
Thanks: 0
Thanked 6 Times in 6 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mr. iNCREDIBLE is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
P0520 Code Engine Oil Pressure Sensor/Switch Circuit Malfunction Big K Problems / Dealer Service 57 02-13-2014 05:57 AM
Code P0520(Engine Oil Sensor) How long can I get away with this ojmcneill General Discussion 5 12-03-2009 08:43 PM
Added octane boost, now getting P0520 Code ojmcneill General Discussion 17 12-02-2009 12:45 PM
code p0128 reset on a 2008 C? Patrick M Problems / Dealer Service 5 08-11-2009 06:01 AM
P0520 and TSB#08-017-05 DESIREE Problems / Dealer Service 1 09-23-2005 03:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design