2008 Chrysler 300 Turn Signal issue - Chrysler 300C Forum: 300C & SRT8 Forums
Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-08-2010, 06:53 AM Thread Starter
Junior Member
Points: 401, Level: 1 Points: 401, Level: 1 Points: 401, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2008 Chrysler 300 Turn Signal issue

So yesterday when I was driving home from work I took a sharp left turn and my turn signal wouldn’t turn off automatically like normal. When I got home I stood idle in my driveway I turned the wheel to the left and right and I could hear a clicking on the inside and every once in awhile the left signal would turn on. Now today on my way to work I turn my turn signal on to turn right and I straighten the wheel out and the left signal turned on then when I took a left with the left signal on it turned off when I straightened the wheel but whenever I turned it just a little bit going along the curves in the road the left signal would turn on until I turned the wheel enough to make it click. Any ideas?
raryke is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-09-2010, 10:58 AM
Senior Member
Points: 1,134, Level: 1 Points: 1,134, Level: 1 Points: 1,134, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2009
Posts: 174
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sounds like either the multifunction swith or the turn signal cam is toast.
Nailfoot is offline  
post #3 of 7 (permalink) Old 10-11-2010, 03:22 PM Thread Starter
Junior Member
Points: 401, Level: 1 Points: 401, Level: 1 Points: 401, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
any idea on what the cost to fix it is?
raryke is offline  
post #4 of 7 (permalink) Old 10-11-2010, 07:12 PM
Lifetime Premium Member
Points: 97,419, Level: 1 Points: 97,419, Level: 1 Points: 97,419, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 21% Activity: 21% Activity: 21%
Super Flash Mario Bros. Champion, Yeti 8: Jungle Swing Champion
 
Fisch's Avatar
 
Join Date: May 2009
Location: Columbus, OH
Posts: 6,770
Thanks: 637
Thanked 544 Times in 429 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
So the signal is turning on when all you are doing is turning the wheel? Not touching the signal stalk at all? Hmmm.. never heard of that.

If I try to just flash my signal to change lanes and not push the stalk down all of the way, it sometimes keeps the signal on even though the stalk is back in the middle position. I have to full turn the signal on then back off to get it to stop. Not to mention the old "wipers going on with turn signal" issue that shows it face now and then. But never any signal problems without touching it...
Fisch is offline  
post #5 of 7 (permalink) Old 10-11-2010, 07:35 PM Thread Starter
Junior Member
Points: 401, Level: 1 Points: 401, Level: 1 Points: 401, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yup it just turns on while the wheel is turning. Also within the past couple days I actually have to hold the right blinker up when turning or it wont stay on I think the switch that turns the blinker off after you turn is busted
raryke is offline  
post #6 of 7 (permalink) Old 10-30-2010, 01:25 AM
Junior Member
Points: 38, Level: 1 Points: 38, Level: 1 Points: 38, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Wow, I just started having this exact same problem today and I have an 2008 300. I wonder if this is an recall..... did you get it fixed and if you did can you let me know what it was?
toris08300 is offline  
post #7 of 7 (permalink) Old 10-30-2010, 09:43 AM Thread Starter
Junior Member
Points: 401, Level: 1 Points: 401, Level: 1 Points: 401, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Nope I never got it fixed... It kind of fixed itself it still makes the clicking noise but it operates as normal however the left signal will still turn on every once and awhile after a right turn which gets kind of annoying.
raryke is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 mirror with built in turn signal pin an color code needed orandaberg Lighting Discussion 0 07-05-2009 01:48 AM
3157 LED Comarison (300C/300 Front Turn Signal) AACstyle.com Lighting Discussion 8 05-28-2008 02:16 PM
2008 turn signal miirors with puddle lights leodogg24 General Discussion 9 02-19-2008 05:42 PM
300 mirrors with LED turn signal lights - $100 Tork Monster Lighting Discussion 6 07-17-2006 10:03 AM
D'oh! 300/Magnum swap: turn signal and fog connectors (PICS!) nick_danger Appearance General Discussion 4 06-16-2006 07:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design