Anyone heard this Front Suspension Noise? - Chrysler 300C Forum: 300C & SRT8 Forums
Suspension/Handling Modifications This section is for discussion of suspension related topics.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 11-07-2008, 11:09 AM Thread Starter
Senior Member
Points: 5,135, Level: 1 Points: 5,135, Level: 1 Points: 5,135, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Hemissary's Avatar
 
Join Date: Feb 2007
Location: Calgary, Alberta
Posts: 293
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Anyone heard this Front Suspension Noise?

There are a number of threads discussing various noises, but the noise itself is not easily conveyed to others;

Find the video clip below. ST (KW) coilovers or the Hotchkis swaybar inner bushings are the likely suspects. The inner swaybar bushings were lubricated with synthetic grease ~2 weeks ago. I had the same noise last year about this time, I suspect given we are hovering around 0C (32F), the (lower) temperature is maing the noise louder. The noise is present to a lesser degree through the summer though.

Maybe others have experienced the same noise and can point me in the right direction:


HEMISSARY

Last edited by Hemissary; 11-08-2008 at 12:34 PM.
Hemissary is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 11-07-2008, 09:53 PM
Elite Contributing Member
Points: 93,196, Level: 1 Points: 93,196, Level: 1 Points: 93,196, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
joey's Avatar
 
Join Date: Jun 2004
Location: fremont ca
Posts: 4,565
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It is hard to tell from the video. If you want to rule out the sway bars, unbolt the end links. You don't need to remove the sway bars, just disconnect one end of the endlink.
joey is offline  
post #3 of 11 (permalink) Old 11-08-2008, 11:34 PM
Senior Member
Points: 3,131, Level: 1 Points: 3,131, Level: 1 Points: 3,131, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2007
Location: Westfield, MA
Posts: 186
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
+1

You can take the sway bar links, and bushings out of the equation by unbolting the end link from the shocks. (be sure to secure them so they don't interfere with anything)

If the noise is still there then it's not the sway bar, links, or bushings.

If the noise is still there check the lower shock bushings, radius rod bushings, and shock mounts.
Rob@WretchedMS is offline  
post #4 of 11 (permalink) Old 11-12-2008, 04:35 AM
Junior Member
Points: 656, Level: 1 Points: 656, Level: 1 Points: 656, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2008
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Its probably a suspension issue that is common with Chrysler cars..
Rob has it dead on...

seems that chrysler always has these issues on these cars... a friend that owns a magnum r/t had that similar noise and had to replace shock mounts and also ball joint
evo300c is offline  
post #5 of 11 (permalink) Old 11-15-2008, 12:55 PM
Junior Member
Points: 534, Level: 1 Points: 534, Level: 1 Points: 534, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ha al,l my noise was my left side outer tire rod, the noise started when i was on bumpie roads or turning to the right.....2006 300C
Bluedog is offline  
post #6 of 11 (permalink) Old 11-18-2008, 06:28 PM
Supporting Vendor
Points: 8,907, Level: 1 Points: 8,907, Level: 1 Points: 8,907, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Posts: 489
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I think it is rubber related. I would first suspect, as Rob mentioned, the sway bar bushes.

You also might try spraying some DW40 into the top strut mount. The mounts usually give a more tinnier sound. But at least check all the rubber in the front.
best of luck

mike
dms
info@PeddersUSA.com is offline  
post #7 of 11 (permalink) Old 08-12-2009, 11:50 AM
Member
Points: 3,061, Level: 1 Points: 3,061, Level: 1 Points: 3,061, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2009
Location: Columbus
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Did you ever solve this problem? I seem to have a similar noise...

Sorry to bring this thread back from the dead.
Rugster is offline  
post #8 of 11 (permalink) Old 08-13-2009, 02:39 PM Thread Starter
Senior Member
Points: 5,135, Level: 1 Points: 5,135, Level: 1 Points: 5,135, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Hemissary's Avatar
 
Join Date: Feb 2007
Location: Calgary, Alberta
Posts: 293
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
In fact I did; the KW inner bushings were dragging on the swaybar. A replacement set solved the problem for now. Folks need to realize that these parts require periodic replacement, especially when operating in extreme conditions (cold winters - hot summers). here's a better video showing the problem, I actually driving over a speed bump at slow speed:


Last edited by Hemissary; 08-13-2009 at 02:40 PM.
Hemissary is offline  
post #9 of 11 (permalink) Old 08-25-2009, 11:03 AM
Senior Contributing Member
Points: 12,818, Level: 1 Points: 12,818, Level: 1 Points: 12,818, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2007
Location: Edmonton, Alberta
Posts: 931
Thanks: 1
Thanked 20 Times in 18 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Moebius44 View Post
In fact I did; the KW inner bushings were dragging on the swaybar. A replacement set solved the problem for now. Folks need to realize that these parts require periodic replacement, especially when operating in extreme conditions (cold winters - hot summers). here's a better video showing the problem, I actually driving over a speed bump at slow speed:


the video is blocked for me at work. im having a weird front end noise with my SRT, with the KW suspension as well. its like a rubbing, binding type noise. and i only hear it going slow over bumps. is this what you were getting too??

2006 300C SRT-8 Black-VORTECH SUPERCHARGED, Magnaflow cats, Corsa Cat-back, DSS 1000hp Axles, 22" MHT Stiletto Forged rims, Nitto420's, Hotchkis Sway Bars, KW V2's, Big stereo, Compustar Alarm, VIP300C deep dish grill and eyelids, Tinted windows. SOLD!

2012 Chrysler 300 SRT-8, Black

2006 Dodge Viper SRT-10, GTS Blue- Cat Delete, Corsas, K&N CAI, SCT, MGW Shifter, MCS Coilovers

2011 Dodge Ram 2500 Laramie White- Deleted, H&S Tuner
Someguys300c is offline  
post #10 of 11 (permalink) Old 08-25-2009, 02:03 PM Thread Starter
Senior Member
Points: 5,135, Level: 1 Points: 5,135, Level: 1 Points: 5,135, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Hemissary's Avatar
 
Join Date: Feb 2007
Location: Calgary, Alberta
Posts: 293
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It sounds similar...
Hemissary is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
squeaky noise on front suspension peterdonovan CRD Wheels / Tyres / Suspension / Brake 0 05-16-2010 10:08 AM
Help Needed Front Suspension Noise sean1098s Suspension/Handling Modifications 0 08-16-2009 10:09 AM
Weird poppin clunking noise front driver side suspension! Chrysless25 Suspension/Handling Modifications 4 06-01-2008 08:53 PM
I've heard this little noise - any ideas? GoofyTimL General Discussion 1 01-13-2006 07:02 PM
suspension noise II kings 9:20 Problems / Dealer Service 3 12-16-2004 12:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design