Trunk will not open - no power to release mech - Chrysler 300C Forum: 300C & SRT8 Forums
Technical Service Bulletins / Recalls This forum is for the discussion of TSB's (Technical Service Bulletins) and Recalls which involve the Chrysler 300 models.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 02-08-2011, 01:49 PM Thread Starter
Member
Points: 7,910, Level: 1 Points: 7,910, Level: 1 Points: 7,910, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
-=SpeedFreak=-'s Avatar
 
Join Date: Apr 2005
Location: Southern New Hampshire
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Trunk will not open - no power to release mech

Hey there folks am hoping someone can enlighten me on this issue I am having. I hit 100k miles and now my girl is showing her age ;-)

I have a 2005 300C. I was driving at night the other day and something looked different.
Come to find out the lighting on the fan speed, temp dials, and def/heat selecter were not lighting up. Nor was the analog clock.

Then I noticed that the interior lamps would not come on when entering the car, nor when turned on manually. And then the trunk won't open either with either the remote nor the button on the dash. there is not even a hint of a click happening which tells me there is no power going to it.

I reviewed the manual for the fuses but do not see any fuse that is common amongst the above.

I brought it to the dealer but after an hour they could not definitively determine what the cause is.

Anyone have any educated guesses?

-=SpeeedFreak=-
2005 300C Midnight Blue
E&G Grille / Chrome Pillars
255x45x20's on MC2-FZ16 Chrome Rims
Zoomers Cat Back Exhaust (removed 90Kmi)
Pedders Full Suspension
SuperChips Tuner Currently running 91 Tune
------------------------------------
www.ihatedell.net
-=SpeedFreak=- is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 02-08-2011, 01:59 PM
Elite Contributing Member
Points: 43,588, Level: 1 Points: 43,588, Level: 1 Points: 43,588, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Bronek's Avatar
 
Join Date: Jul 2009
Location: Saskatoon, SK
Posts: 5,045
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Bronek
You got a fuse or a loose wire somewhere. I'm not familiar enough with the electronics, but the dealer not being able to diagnose it means you need to take your vehicle elsewhere.

Sabrina - Srebrny Księżna
2005 300 Limited AWD ~ FE210 AWD? Maybe...
Click below for current mods + future plans
I do not believe in fire-breathing dragons, multi-coloured unicorns, good-willed people, omni-present creators, or other mythical creatures.
Bronek is offline  
post #3 of 15 (permalink) Old 02-08-2011, 08:44 PM
Lifetime Premium Member
Points: 48,362, Level: 1 Points: 48,362, Level: 1 Points: 48,362, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 18% Activity: 18% Activity: 18%
 
Join Date: Feb 2005
Location: Coatesville, PA, U.S.A.
Posts: 3,606
Thanks: 2
Thanked 163 Times in 149 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
I did a search for you. Found this posted back in December:
"Success! Front Fuse #5 (25-amp) was blown. When replaced, my cabin lights, backlighting, and trunk opener magically work again! Hopefully it was a one-time fluke. I have extra 25-amp fuses now, just in case...
And for the record, I do have the HID w/ headlamp washers. Why these particular electrical functions are bundled together, I have no idea..."
Go get it!

2005 300C BRILLIANT BLACK, DRL, Mesh Grill/Vents, Chrome Pillars & Fender Trim, MDS Indicator, Quad Brake Lights, Tinted Windows, De-Molded, K&N Aircharger, 180 T-Stat, Flashing Sidemarkers, Predator Cust. Perf. 93 CAI Tune
1997 MUSTANG COBRA 'VERT, TRIPLE BLACK, Vortech S/C'd., ECT Mod., 4.10 Rear, 18" Saleen Wheels
1950 FORD TUDOR FLATHEAD V8 - Sold 6/27/14 after 16 years of fun.
DESIREE is offline  
post #4 of 15 (permalink) Old 02-09-2011, 12:25 PM Thread Starter
Member
Points: 7,910, Level: 1 Points: 7,910, Level: 1 Points: 7,910, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
-=SpeedFreak=-'s Avatar
 
Join Date: Apr 2005
Location: Southern New Hampshire
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ohhhh ohh I'm so excited. I will have to chek out this fuse.
If it is the fuse I am going to give the dealer HE double "L"
-=SpeedFreak=- is offline  
post #5 of 15 (permalink) Old 02-09-2011, 08:09 PM
Lifetime Premium Member
Points: 48,362, Level: 1 Points: 48,362, Level: 1 Points: 48,362, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 18% Activity: 18% Activity: 18%
 
Join Date: Feb 2005
Location: Coatesville, PA, U.S.A.
Posts: 3,606
Thanks: 2
Thanked 163 Times in 149 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
This issue pops up on the forum every so often.

For other issues try using the 'search' feature. If something is happening to you odds are it's happened to others and they've posted it, and in most cases, gotten an answer.

Let us all know what you find in the fuse box.

Then stick the stealership's nose in the box and slam the lid!

Last edited by DESIREE; 02-10-2011 at 07:17 AM.
DESIREE is offline  
post #6 of 15 (permalink) Old 02-10-2011, 11:25 AM
Major Contributing Member
Points: 65,576, Level: 1 Points: 65,576, Level: 1 Points: 65,576, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
blacknight's Avatar
 
Join Date: Sep 2010
Location: Bergen Cnty, NJ
Posts: 1,000
Thanks: 16
Thanked 29 Times in 27 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This maybe the culprit as I resolved teh same situation with a friends 04 Acura TL

Her memory seat, heated seat & windshield washer sprayers werent working,
Spoke to an Acura tech and he advised me to replace a specific fuse.
I replaced the fuse and the memory seat worked, the seat started to get warm and the wipers worked
But when I tried the use the washer sprayers....nothing happened and everything else above stopped working. I checked the fuse again and it blew.
Spoke with the tech and he said the pump for the sprayers is frozen along with the fluid in the resovoir.
I checked the resovoir and sure enough, it was frozen solid. granted it was about 2 degrees outside
I replaced teh fuse again and told her not to use the sprayers till it warms up.
A few days later it was in teh high 30's and we tried the sprayers and they worked fine.


So to the OP, I see you're in teh north east and we've had some blistering cold weather....That could be the problem

Last edited by blacknight; 02-10-2011 at 11:26 AM.
blacknight is offline  
post #7 of 15 (permalink) Old 02-10-2011, 02:22 PM Thread Starter
Member
Points: 7,910, Level: 1 Points: 7,910, Level: 1 Points: 7,910, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
-=SpeedFreak=-'s Avatar
 
Join Date: Apr 2005
Location: Southern New Hampshire
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
desiree;

That was the culprit. I replace the #5 fuse and everything work. Thats for the help.
PS I did do a search on this b4 I wrote the query and found 5 hits. None of which had the solution.
Also when I was typing in the query, the forum found "related threads" which were the same ones I found as well.

In any case Problem solved :-)
-=SpeedFreak=- is offline  
post #8 of 15 (permalink) Old 03-16-2012, 06:31 AM
Member
Points: 1,573, Level: 1 Points: 1,573, Level: 1 Points: 1,573, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
HemiLuv's Avatar
 
Join Date: Sep 2011
Location: Phoenix, AZ
Posts: 48
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by -=SpeedFreak=- View Post
ohhhh ohh I'm so excited. I will have to chek out this fuse.
If it is the fuse I am going to give the dealer HE double "L"
LOL, I feel ya on that
HemiLuv is offline  
post #9 of 15 (permalink) Old 03-16-2012, 09:25 AM
Lifetime Premium Member
Points: 48,362, Level: 1 Points: 48,362, Level: 1 Points: 48,362, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 18% Activity: 18% Activity: 18%
 
Join Date: Feb 2005
Location: Coatesville, PA, U.S.A.
Posts: 3,606
Thanks: 2
Thanked 163 Times in 149 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
[QUOTE=-=SpeedFreak=-;1010901]desiree;

That was the culprit. ]/QUOTE]

SCORE!
DESIREE is offline  
post #10 of 15 (permalink) Old 03-16-2012, 01:17 PM
Major Contributing Member
Points: 67,589, Level: 1 Points: 67,589, Level: 1 Points: 67,589, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 9% Activity: 9% Activity: 9%
 
BobF's Avatar
 
Join Date: Sep 2005
Location: Southern California
Posts: 1,142
Thanks: 0
Thanked 5 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Deleted


2008 300C SRT8
With all available options including:
Option Group I
Option Group II
Power Sunroof
13 Kicker SRT High-Perf. Speakers
Sirius Backseat TV
Rear Seat Video (VES)
Addons installed by me:
Weathertec front window deflectors
VES lid and seat belt pads embroidered by Jina's Simple Sew
SRT8 patches on front floor mats
Molder rubber trunk liner
Chrysler Cargo net

Last edited by BobF; 03-16-2012 at 01:24 PM. Reason: Deleted
BobF is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
trunk release problem simtso Problems / Dealer Service 5 06-20-2014 08:37 AM
Help!! Power seat release BigJ Problems / Dealer Service 4 01-23-2010 08:43 PM
Anyone ever actually LOOK at that little trunk release? OoTLink General Discussion 26 06-12-2006 11:01 PM
Trunk Release Hydraulic? y2kcurt General Discussion 3 04-06-2006 08:33 AM
Remote trunk release Jesus Chrysler Problems / Dealer Service 7 02-10-2006 01:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design