Exploding dishwasher - Chrysler 300C Forum: 300C & SRT8 Forums
UK & Europe Off Topic Discussions For topics not related to the Chrysler 300 - All forum rules apply.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-01-2013, 03:55 PM Thread Starter
Lifetime Premium Member
Points: 42,855, Level: 1 Points: 42,855, Level: 1 Points: 42,855, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
chrisp's Avatar
 
Join Date: Nov 2008
Location: Herefordshire UK
Posts: 2,041
Thanks: 81
Thanked 48 Times in 45 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exploding dishwasher

I'll aim this at Jack for his comments but all input welcome. I have a Beko dishwasher which we rarely use except at this time of year when we have loads of people round and loads of washing up. Anyways when it was running it made a loud and i mean loud electric shorting/banging sound once during the wash cycle followed by a load of smoke lol it never blew the fuse or trip though. On searching the web i found someone with the same problem and they said it was the suppresion filter. I took it apart for a look and sure enough the filter (see pictures) had blew apart and smelt burnt. Problem is after taking it apart i am sure it was connected up wrong (it was bought brand new and has never been apart till now) the neutrals were on the live terminals l/h terminals in picture definitely. Would this have caused it to blow. Any ideas
Attached Thumbnails
Click image for larger version

Name:	SAM_6613.JPG
Views:	102
Size:	88.0 KB
ID:	42576   Click image for larger version

Name:	SAM_6614.JPG
Views:	94
Size:	90.6 KB
ID:	42577  

MOPAR OR NOCAR 440 Coronet
2006 SRT8 Diablo Predator 93 Octane CAI performance tune
Mopar Cold Air Intake
EBC Yellows
Hurst Shifter
Badlanz Cutouts
Magnaflow Catback System
chrisp is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-01-2013, 06:49 PM
Lifetime Premium Member
Points: 48,231, Level: 1 Points: 48,231, Level: 1 Points: 48,231, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 19% Activity: 19% Activity: 19%
 
Join Date: Feb 2005
Location: Coatesville, PA, U.S.A.
Posts: 3,605
Thanks: 2
Thanked 163 Times in 149 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Looks to me like a plain old electrical failure of a solenoid coil due to electrical and mechanical stresses.
Just replace the part and forget about it.

2005 300C BRILLIANT BLACK, DRL, Mesh Grill/Vents, Chrome Pillars & Fender Trim, MDS Indicator, Quad Brake Lights, Tinted Windows, De-Molded, K&N Aircharger, 180 T-Stat, Flashing Sidemarkers, Predator Cust. Perf. 93 CAI Tune
1997 MUSTANG COBRA 'VERT, TRIPLE BLACK, Vortech S/C'd., ECT Mod., 4.10 Rear, 18" Saleen Wheels
1950 FORD TUDOR FLATHEAD V8 - Sold 6/27/14 after 16 years of fun.
DESIREE is offline  
post #3 of 3 (permalink) Old 01-02-2013, 08:27 AM
Senior Member
Points: 4,365, Level: 1 Points: 4,365, Level: 1 Points: 4,365, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2009
Location: Horley,Surrey
Posts: 112
Thanks: 8
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I don't think the live and neutrals on the wrong way would make any difference
UKCRD is offline  
The Following User Says Thank You to UKCRD For This Useful Post:
chrisp (01-03-2013)
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Exploding Belt Tensioner Stargate Australia / NZ Forum General Discussion 2 04-08-2010 06:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design