Bought a Predator - Page 3 - Chrysler 300C Forum: 300C & SRT8 Forums
UK & Europe Regional Forum This section is for topics relating to the EU versions of the Chrysler 300 and diesel powered models.

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 27 (permalink) Old 11-15-2012, 12:44 AM Thread Starter
Member
Points: 3,611, Level: 1 Points: 3,611, Level: 1 Points: 3,611, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Ian_T's Avatar
 
Car: 2007 Chrysler 300C 5.7 Hemi
Join Date: Jul 2012
Location: Middlesex, UK
Posts: 80
Thanks: 8
Thanked 8 Times in 8 Posts
I think I'd like to try that - where exactly are you?
Ian_T is offline  
Sponsored Links
Advertisement
 
post #22 of 27 (permalink) Old 11-15-2012, 12:50 AM
Supporting Vendor
Points: 39,887, Level: 1 Points: 39,887, Level: 1 Points: 39,887, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 20% Activity: 20% Activity: 20%
 
Simon@thecustom300cshop's Avatar
 
Car: 2010 BMW 520D M Sport Tourer
Join Date: Jun 2008
Location: Berkshire, UK
Posts: 6,702
Thanks: 158
Thanked 171 Times in 162 Posts
Quote:
Originally Posted by Ian_T View Post
I think I'd like to try that - where exactly are you?
I'm in Lambourn, near Hungerford.

Regards

Simon

www.custom300cshop.co.uk
Simon@thecustom300cshop is offline  
The Following User Says Thank You to Simon@thecustom300cshop For This Useful Post:
Ian_T (11-15-2012)
post #23 of 27 (permalink) Old 11-27-2012, 10:40 AM
Supporting Vendor
Points: 39,887, Level: 1 Points: 39,887, Level: 1 Points: 39,887, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 20% Activity: 20% Activity: 20%
 
Simon@thecustom300cshop's Avatar
 
Car: 2010 BMW 520D M Sport Tourer
Join Date: Jun 2008
Location: Berkshire, UK
Posts: 6,702
Thanks: 158
Thanked 171 Times in 162 Posts
I have got your Predator working Ian. At first it was having a communication failure when using my lead that I knew worked. I noticed the screen flickering very slightly when powered up, so I connected my 12v transformer and it loaded straight away. Your transformer must be a duffer.
Simon@thecustom300cshop is offline  
post #24 of 27 (permalink) Old 11-27-2012, 11:35 AM
Senior Contributing Member
Points: 24,926, Level: 1 Points: 24,926, Level: 1 Points: 24,926, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2006 chrysler 300C 5.7 Hemi
Join Date: Aug 2008
Location: Northern Ireland
Posts: 640
Thanks: 2
Thanked 19 Times in 19 Posts
It's good to see you have got it working. I think that the exchange of help and information on this forum is excellent, I have got a lot out of it over the last few years.
ivanford is offline  
post #25 of 27 (permalink) Old 11-28-2012, 12:07 AM Thread Starter
Member
Points: 3,611, Level: 1 Points: 3,611, Level: 1 Points: 3,611, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Ian_T's Avatar
 
Car: 2007 Chrysler 300C 5.7 Hemi
Join Date: Jul 2012
Location: Middlesex, UK
Posts: 80
Thanks: 8
Thanked 8 Times in 8 Posts
Quote:
Originally Posted by Simon@thecustom300cshop View Post
I have got your Predator working Ian. At first it was having a communication failure when using my lead that I knew worked. I noticed the screen flickering very slightly when powered up, so I connected my 12v transformer and it loaded straight away. Your transformer must be a duffer.
Thats fantastic - I can't thank you enough! I'll PM you a bit later, as I'm just off to hospital for the morning..

Ian_T is offline  
post #26 of 27 (permalink) Old 12-07-2012, 02:36 PM
Senior Contributing Member
Points: 24,926, Level: 1 Points: 24,926, Level: 1 Points: 24,926, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2006 chrysler 300C 5.7 Hemi
Join Date: Aug 2008
Location: Northern Ireland
Posts: 640
Thanks: 2
Thanked 19 Times in 19 Posts
Hi Ian
Have you got the Predator tune installed yet?
ivanford is offline  
post #27 of 27 (permalink) Old 12-08-2012, 06:09 AM Thread Starter
Member
Points: 3,611, Level: 1 Points: 3,611, Level: 1 Points: 3,611, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Ian_T's Avatar
 
Car: 2007 Chrysler 300C 5.7 Hemi
Join Date: Jul 2012
Location: Middlesex, UK
Posts: 80
Thanks: 8
Thanked 8 Times in 8 Posts
Yes, and it's definatey made a difference. I don't drive like a madman, but it's easy to tell the difference on acceleration. I'm getting better economy now as well I think - I switched to 99 fuel to match the tune and it seems smooter as well.

Funnily enough, Mrs T thought I had royally screwed the Predator and I now have a new inTune as well. I've just removed the Predator and re-done it with the inTune. I guess the performance/economy will be the same with the new one as well. Either way, it seems I now have two tuners, so the Predator is now up for sale (or very shortly will be)...
Ian_T is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Just bought a used diablosport predator, need help mjcotton7 Tuning/CMR/Dyno/DataLogging/Gauges 3 12-14-2011 11:11 AM
Just bought an '05 3.5l, will the predator tuner help much? zim18 Tuning/CMR/Dyno/DataLogging/Gauges 5 06-10-2010 02:33 PM
Just Bought Predator. FrankieG889D Tuning/CMR/Dyno/DataLogging/Gauges 6 03-17-2009 04:17 AM
Anyone that bought a 300 wish they had bought a Charger instead? 4life General Discussion 66 04-02-2008 10:28 PM
Predator callibration + $3000 Laptop = NO GO! Predator + SRT = 5.1sec 0-60 on 24's!!! YoungMedic23 Tuning/CMR/Dyno/DataLogging/Gauges 8 10-05-2007 11:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design