New Battery - Chrysler 300C Forum: 300C & SRT8 Forums
Interested in the Dodge Challenger? Be sure to check out the Dodge Challenger Forum for your Dodge Challenger information!
» Featured Product
» Buyers Guide

Wheel & Tire Center

Go Back   Chrysler 300C Forum: 300C & SRT8 Forums > Regional Forums > UK & Europe Regional Forum
Register Home Forum Active Topics (T) Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto Loans

UK & Europe Regional Forum This section is for topics relating to the EU versions of the Chrysler 300 and diesel powered models.

300cForums.com is the premier Chrysler 300c Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-15-2012, 05:12 PM   #1 (permalink)
Lifetime Premium Member
Points: 42,855, Level: 1 Points: 42,855, Level: 1 Points: 42,855, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
chrisp's Avatar
 
Car: 2006 Chrysler 300c SRT-8 {SZZ}
Join Date: Nov 2008
Member Number: 20152
Location: Herefordshire UK
Posts: 2,041
Thanks: 81
Thanked 48 Times in 45 Posts
New Battery

Put a new one on today it was still on the original one. The old one didn't fail to start it in fact it wound over faster cold than hot. Hot starts were the problem cured now lol. 73 delivered for a Bosch off the Bay chuffed with that.
__________________
MOPAR OR NOCAR 440 Coronet
2006 SRT8 Diablo Predator 93 Octane CAI performance tune
Mopar Cold Air Intake
EBC Yellows
Hurst Shifter
Badlanz Cutouts
Magnaflow Catback System
chrisp is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-15-2012, 05:53 PM   #2 (permalink)
Lifetime Premium Member
Points: 65,606, Level: 1 Points: 65,606, Level: 1 Points: 65,606, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 81% Activity: 81% Activity: 81%
 
badgx's Avatar
 
Car: 2006 Chrysler 5.7 Hemi STARTECH EDITION PRINS VSI LPG & KEIHIN INJECTORS
Join Date: Jun 2011
Member Number: 32952
Location: London, UK
Posts: 4,109
Thanks: 358
Thanked 429 Times in 389 Posts
Can't go wrong with Bosch
__________________
One step for man, one giant leap for mankind


Onboard Unipar SL700 & Redlflex F/B Laser Jammer @ 904nm light wavelenght & Road Angle Professional
badgx is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-16-2012, 02:30 PM   #3 (permalink)
Senior Member
Points: 7,588, Level: 1 Points: 7,588, Level: 1 Points: 7,588, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 9% Activity: 9% Activity: 9%
 
Pappajohn's Avatar
 
Car: 2007 chrysler 300c Touring (UK Station wagon)
Join Date: Oct 2012
Member Number: 41160
Location: Scarborough, north yorks.
Posts: 419
Thanks: 45
Thanked 27 Times in 24 Posts
wonder if a new battery will fix my flickering head/dash lights.....the new alternator certainly didn't
Pappajohn is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-16-2012, 04:08 PM   #4 (permalink)
Lifetime Premium Member
Points: 42,855, Level: 1 Points: 42,855, Level: 1 Points: 42,855, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
chrisp's Avatar
 
Car: 2006 Chrysler 300c SRT-8 {SZZ}
Join Date: Nov 2008
Member Number: 20152
Location: Herefordshire UK
Posts: 2,041
Thanks: 81
Thanked 48 Times in 45 Posts
What voltage you got showing in the hidden menu ?
chrisp is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-16-2012, 04:13 PM   #5 (permalink)
Senior Member
Points: 7,588, Level: 1 Points: 7,588, Level: 1 Points: 7,588, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 9% Activity: 9% Activity: 9%
 
Pappajohn's Avatar
 
Car: 2007 chrysler 300c Touring (UK Station wagon)
Join Date: Oct 2012
Member Number: 41160
Location: Scarborough, north yorks.
Posts: 419
Thanks: 45
Thanked 27 Times in 24 Posts
Quote:
Originally Posted by chrisp View Post
What voltage you got showing in the hidden menu ?
Is this question aimed at me ?
Pappajohn is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-16-2012, 04:28 PM   #6 (permalink)
Senior Member
Points: 7,588, Level: 1 Points: 7,588, Level: 1 Points: 7,588, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 9% Activity: 9% Activity: 9%
 
Pappajohn's Avatar
 
Car: 2007 chrysler 300c Touring (UK Station wagon)
Join Date: Oct 2012
Member Number: 41160
Location: Scarborough, north yorks.
Posts: 419
Thanks: 45
Thanked 27 Times in 24 Posts
Quote:
Originally Posted by Pappajohn View Post
Is this question aimed at me ?
Of course it was ...doh!!!

tonight, with ign sw to acc position only, the voltage was 11.8v...been doing short trips after dark for a while now.

start engine and while cranking (2>3 seconds) it dropped to 10.5v then straight to 14.4v dropping slowly to 11.6v with H/L's turned on.

while driving it varied anywhere between 11.2v and 14.8v.
voltage starts to drop at idle.

lights flicker under engine load but stay stable on overrun/idle and more noticeable on the dash and clock lights.
10 minutes or so driving and the lights became stable but the voltage showed a stable 12.8v.

alternator replaced last week.
battery checked for capacity last week and its an 800cca battery showing 675cca

Last edited by Pappajohn; 11-16-2012 at 04:31 PM.
Pappajohn is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-16-2012, 05:23 PM   #7 (permalink)
Lifetime Premium Member
Points: 42,855, Level: 1 Points: 42,855, Level: 1 Points: 42,855, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
chrisp's Avatar
 
Car: 2006 Chrysler 300c SRT-8 {SZZ}
Join Date: Nov 2008
Member Number: 20152
Location: Herefordshire UK
Posts: 2,041
Thanks: 81
Thanked 48 Times in 45 Posts
I would say you still have an alternator problem you should be getting more than 12.8 volts constantly when running more like 13.8 to 14.2
chrisp is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-16-2012, 05:27 PM   #8 (permalink)
Senior Contributing Member
Points: 24,926, Level: 1 Points: 24,926, Level: 1 Points: 24,926, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2006 chrysler 300C 5.7 Hemi
Join Date: Aug 2008
Member Number: 18868
Location: Northern Ireland
Posts: 640
Thanks: 2
Thanked 19 Times in 19 Posts
I would also say you should be getting around 14 volts normal running.
ivanford is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-16-2012, 05:30 PM   #9 (permalink)
Elite Contributing Member
Points: 16,992, Level: 1 Points: 16,992, Level: 1 Points: 16,992, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 28% Activity: 28% Activity: 28%
 
Car: 2008 Chrysler 300C SRT Design Diesel
Join Date: Aug 2010
Member Number: 28359
Location: Doncaster
Posts: 2,414
Thanks: 169
Thanked 307 Times in 293 Posts
Quote:
Originally Posted by Pappajohn View Post
Of course it was ...doh!!!

tonight, with ign sw to acc position only, the voltage was 11.8v...been doing short trips after dark for a while now.

start engine and while cranking (2>3 seconds) it dropped to 10.5v then straight to 14.4v dropping slowly to 11.6v with H/L's turned on.

while driving it varied anywhere between 11.2v and 14.8v.
voltage starts to drop at idle.

lights flicker under engine load but stay stable on overrun/idle and more noticeable on the dash and clock lights.
10 minutes or so driving and the lights became stable but the voltage showed a stable 12.8v.

alternator replaced last week.
battery checked for capacity last week and its an 800cca battery showing 675cca

Without doubt an alternator or connections problem methinks.

Jack
jackwalton is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 11-16-2012, 06:03 PM   #10 (permalink)
Senior Member
Points: 7,588, Level: 1 Points: 7,588, Level: 1 Points: 7,588, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 9% Activity: 9% Activity: 9%
 
Pappajohn's Avatar
 
Car: 2007 chrysler 300c Touring (UK Station wagon)
Join Date: Oct 2012
Member Number: 41160
Location: Scarborough, north yorks.
Posts: 419
Thanks: 45
Thanked 27 Times in 24 Posts
10 minutes or so driving and the lights became stable but the voltage showed a stable 12.8v.

Sorry, that should have read 13.8v
Pappajohn is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which battery should I buy ? ivanford UK & Europe Regional Forum 28 02-02-2012 06:59 AM
Is my battery about to die? Surreyuk UK & Europe Regional Forum 10 09-17-2011 02:25 AM
RKG Battery joelatigo Problems / Dealer Service 4 10-15-2008 10:27 AM
Battery Down Jimmy General Discussion 1 11-11-2007 10:36 PM
second battery 300cWannaBe Car Audio/Alarms/UConnect/Navigation 2 10-17-2006 08:04 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:53 AM.



Inactive Reminders By Icora Web Design

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2