Mid Range Acceleration - Chrysler 300C Forum: 300C & SRT8 Forums
Interested in the Dodge Challenger? Be sure to check out the Dodge Challenger Forum for your Dodge Challenger information!
» Featured Product
» Buyers Guide

Wheel & Tire Center

Go Back   Chrysler 300C Forum: 300C & SRT8 Forums > Regional Forums > UK & Europe Regional Forum
Register Home Forum Active Topics (T) Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto Loans

UK & Europe Regional Forum This section is for topics relating to the EU versions of the Chrysler 300 and diesel powered models.

300cForums.com is the premier Chrysler 300c Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-05-2012, 03:17 AM   #1 (permalink)
Lifetime Premium Member
Points: 787, Level: 1 Points: 787, Level: 1 Points: 787, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C CRD
Join Date: Nov 2012
Member Number: 41730
Location: Pine Mountain
Posts: 19
Thanks: 2
Thanked 1 Time in 1 Post
Mid Range Acceleration

I have a 2007 300C CRD that has done 157,000 kms and up until now the most serious thing has been a failed diff.....

Now the following happens:

Between 2,500 and 3,000 revs the car will not accelerate it lurches and runs very rough
foot off the accelerator and it runs (reasonably smoothly).
If I shift down to get in the rev range at a fixed speed and then accelerate it does the lurching even if I very gently accelerate.
If I accelerate from low speed as soon as it gets into the 2,500-3,000 rev range it lurches and no more power/acceleration. If I ease off it runs OK.

The are no codes showing with the triple ACC/ON.

Gear change is smooth enough but I cannot rely on the car to accelerate when its needed.

Any ideas before I resort to the stealership.............?
neilvha is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-05-2012, 03:24 AM   #2 (permalink)
Lifetime Premium Member
Points: 48,090, Level: 1 Points: 48,090, Level: 1 Points: 48,090, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 20% Activity: 20% Activity: 20%
 
UK CHRYSLER 300C's Avatar
 
Car: 2005 CHRYSLER 300C 5.7 HEMI (83W)
Join Date: May 2007
Member Number: 12398
Location: Stafford UK
Posts: 9,410
Thanks: 6
Thanked 188 Times in 162 Posts
CRuDs dont have the key dance,you need to get it read properly first and see what codes come up
__________________

single led 501's(not crappy flowery multi led,g4y type bulb,lol)
4300k hid main lights
4300k hid fog lights
Massive Brembo Gran Turismo Brake kit upgrade
Diablo Predator
RS UV-1, 20" alloys
NEVER SAY NEVER
Immobiliser screwed for the 2nd time in a year
UK CHRYSLER 300C is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 12-05-2012, 04:14 AM   #3 (permalink)
Supporting Vendor
Points: 35,668, Level: 1 Points: 35,668, Level: 1 Points: 35,668, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 3% Activity: 3% Activity: 3%
 
Simon@thecustom300cshop's Avatar
 
Car: 2010 BMW 520D M Sport Tourer
Join Date: Jun 2008
Member Number: 37145
Location: Berkshire, UK
Posts: 6,684
Thanks: 154
Thanked 167 Times in 159 Posts
As Ray already said, you need to get the codes read. It could be lots of different things. Swirl motor, blocked dpf, turbo, sensor failure. Worth checking to see if the wiring harness has rubbed through on the air con pipes beside the engine too.
__________________
Regards

Simon

www.custom300cshop.co.uk
Simon@thecustom300cshop is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 12-05-2012, 06:07 AM   #4 (permalink)
Lifetime Premium Member
Points: 787, Level: 1 Points: 787, Level: 1 Points: 787, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C CRD
Join Date: Nov 2012
Member Number: 41730
Location: Pine Mountain
Posts: 19
Thanks: 2
Thanked 1 Time in 1 Post
Thanks guys it wasn't until I checked a few more threads that I realised key dancing didn't work on the CRDs. I've had a good look at the wiring but I can't spot anything at the moment ....its dark...so I'll look in daylight.......I did find a mummified cane toad down the side of the engine but he's not giving anything away.
neilvha is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
The Following User Says Thank You to neilvha For This Useful Post:
dm575 (12-06-2012)
Old 12-05-2012, 11:36 AM   #5 (permalink)
Major Contributing Member
Points: 11,848, Level: 1 Points: 11,848, Level: 1 Points: 11,848, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
GrumpyBob's Avatar
 
Car: 2009 Chrysler 300C Touring SRT Design (HSZ)
Join Date: Dec 2009
Member Number: 24976
Location: Hartley, Kent, England
Posts: 1,172
Thanks: 12
Thanked 37 Times in 33 Posts
A quick freebie to try, remove then replace the fuel filler cap. If it's breather is blocked it can create a vacuum in the tank which leads to fuel starvation especially when you want more speed/fuel. I had it happen many years ago on a petrol engine car I owned. Worth a try!!
__________________


Chrysler/Brink Detachable Towbar
Billet Tech Catch Can
Alternator Shroud
BMC Performance Panel Filter
12 LED DRL's
Larger Intercooler
Viezu V-Switch
H&R TRAK+ 30mm Wheel Spacers


Software
Application: 2.404
Gracenotes: 2059
GrumpyBob is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 12-05-2012, 11:39 PM   #6 (permalink)
Lifetime Premium Member
Points: 787, Level: 1 Points: 787, Level: 1 Points: 787, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C CRD
Join Date: Nov 2012
Member Number: 41730
Location: Pine Mountain
Posts: 19
Thanks: 2
Thanked 1 Time in 1 Post
No problems with the breather...........however...........Having made the appointment with the dealer to get the codes read, the electronic throttle control warning light came on. Every time I switch off it clears until I get up to about 2,500-2,800 rpm and then come back on. It then goes to limp mode and wont let me accelerate.
neilvha is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 12-06-2012, 02:56 AM   #7 (permalink)
Lifetime Premium Member
Points: 787, Level: 1 Points: 787, Level: 1 Points: 787, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C CRD
Join Date: Nov 2012
Member Number: 41730
Location: Pine Mountain
Posts: 19
Thanks: 2
Thanked 1 Time in 1 Post
Sorted.....unplugged the swirl motor connector......fitted a 5k6 0.25W metal film resistor and hey presto ETC warning gone accelerates with its usual make a cup of tea delay....but once it gets going its beautiful again.......I'll stop thinking about that Amarok. Thinking about performance improvements again..............
neilvha is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 12-06-2012, 04:27 AM   #8 (permalink)
Supporting Vendor
Points: 35,668, Level: 1 Points: 35,668, Level: 1 Points: 35,668, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 3% Activity: 3% Activity: 3%
 
Simon@thecustom300cshop's Avatar
 
Car: 2010 BMW 520D M Sport Tourer
Join Date: Jun 2008
Member Number: 37145
Location: Berkshire, UK
Posts: 6,684
Thanks: 154
Thanked 167 Times in 159 Posts
Another case of the dreaded swirl flu then
Simon@thecustom300cshop is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Old 12-07-2012, 01:00 AM   #9 (permalink)
Lifetime Premium Member
Points: 787, Level: 1 Points: 787, Level: 1 Points: 787, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C CRD
Join Date: Nov 2012
Member Number: 41730
Location: Pine Mountain
Posts: 19
Thanks: 2
Thanked 1 Time in 1 Post
It's come back...

Had a great drive in to work this morning accelerated...good long motorway drive no problems.

Coming home this evening 3/4 the way through the trip and the ETC light comes on and no more power just limp mode.

I'll just have to remake that dealer appointment to get the code(s)http://www.300cforums.com/forums/ima...es/new/sad.gif
neilvha is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Diesel RPM range. Sonsarus Amaryllus UK & Europe Regional Forum 2 10-02-2012 07:05 AM
CRD mid range grunt. Armchair UK & Europe Regional Forum 14 01-16-2011 02:09 PM
low- to mid-range power saleen8927 1st Gen SRT8-Specific Performance & Engine/Intake/Exhaust Mods 21 03-27-2009 04:45 PM
EXPIRED: WTB Aftermarket CAI $200 - $250 range Dennis808 Parts Buy/Sell Forum 5 03-15-2007 12:15 AM
Temp range? bigrick21 General Discussion 3 09-14-2005 10:27 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 06:07 PM.



Inactive Reminders By Icora Web Design

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2