"Engine/Transmission" Malfunction Indicator Light????? - Chrysler 300C Forum: 300C & SRT8 Forums
UK & Europe Regional Forum This section is for topics relating to the EU versions of the Chrysler 300 and diesel powered models.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 31 (permalink) Old 04-26-2010, 04:07 AM Thread Starter
Senior Member
Points: 26,814, Level: 1 Points: 26,814, Level: 1 Points: 26,814, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
BigIan's Avatar
 
Join Date: Nov 2007
Location: Milton Keynes, England
Posts: 461
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exclamation "Engine/Transmission" Malfunction Indicator Light?????

This morning I had occasion to "floor it"

I was in second (I think) doing about 15 or 20mph and gave it a "bootfull" for about 3 or 4 seconds. That's when I got the "bong" and both the "Electronic Throttle Control Light" and the "Malfunction Indicator Light" come on.

The car went into "safe" mode (I think) wouldn't rev over 2000 ish rpm but changed gear OK getting up to 60 odd mph.

I got home and switched off. Switched back on the ETC has not come back on. The MIL goes out, then comes back on. I pulled fuses 11 & 14, and checked the connections to my CR2 chip, but it stays on when driving.

The car seems to drive OK, revving up to 4250rpm ish and changes gear when expected.

The handbook says:

"Certain conditions such as a loose or missing gas cap, poor fuel quality etc. may illuminate the light after engine start. The vehicle should be serviced if the light stays on through several of your typical driving cycles. In most situations the vehicle will drive normally and will not require towing"

I'm sure it's not "poor fuel" and the gas cap is in place, and I've only taken it for about a mile trip since.

Maybe I should disconnect my chip and start it without to see if that makes any difference.

Has anyone got any ideas on what it might be?


This was my 300C, there are many like it, but this one was mine.
Without my 300C, I am useless.
BigIan is offline  
Sponsored Links
Advertisement
 
post #2 of 31 (permalink) Old 04-26-2010, 04:25 AM
Supporting Vendor
Points: 37,912, Level: 1 Points: 37,912, Level: 1 Points: 37,912, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
Simon@thecustom300cshop's Avatar
 
Join Date: Jun 2008
Location: Berkshire, UK
Posts: 6,693
Thanks: 158
Thanked 169 Times in 160 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
You could try doing the key on-off routine to see if any codes come up.

Regards

Simon

www.custom300cshop.co.uk
Simon@thecustom300cshop is offline  
post #3 of 31 (permalink) Old 04-26-2010, 10:23 AM Thread Starter
Senior Member
Points: 26,814, Level: 1 Points: 26,814, Level: 1 Points: 26,814, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
BigIan's Avatar
 
Join Date: Nov 2007
Location: Milton Keynes, England
Posts: 461
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's OK............ panic over........... after 3 short journey's the MIL has gone out and stayed out so far

BTW what's the "key on/off routine" for next time.

Last edited by BigIan; 04-26-2010 at 10:31 AM.
BigIan is offline  
post #4 of 31 (permalink) Old 04-26-2010, 11:58 AM
Administrator
Points: 69,159, Level: 1 Points: 69,159, Level: 1 Points: 69,159, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
Kaiser Bill's Avatar
 
Join Date: Feb 2009
Location: Herefordshire, GB
Posts: 11,421
Thanks: 75
Thanked 436 Times in 379 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Garage
get inside the car, shut the door, quickly turn the key to ACC/ON ACC/ON ACC/ON and see what shows up in the EVIC

Watching You Avoiding Me!

Kaiser Bill is online now  
post #5 of 31 (permalink) Old 04-26-2010, 01:09 PM Thread Starter
Senior Member
Points: 26,814, Level: 1 Points: 26,814, Level: 1 Points: 26,814, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
BigIan's Avatar
 
Join Date: Nov 2007
Location: Milton Keynes, England
Posts: 461
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thanks for that
BigIan is offline  
post #6 of 31 (permalink) Old 06-21-2010, 02:46 PM
Junior Member
Points: 426, Level: 1 Points: 426, Level: 1 Points: 426, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My Malfunction Indicator Light came on a couple of months ago and then went off after a few cycles of driving. It came back on last week I pulled the fuse and it went away. Now if came back two days later. Should I replace the fuse or what to do? I don't really want to take it in to the dealer.
srt8driver is offline  
post #7 of 31 (permalink) Old 06-21-2010, 02:53 PM
Administrator
Points: 69,159, Level: 1 Points: 69,159, Level: 1 Points: 69,159, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 100% Activity: 100% Activity: 100%
 
Kaiser Bill's Avatar
 
Join Date: Feb 2009
Location: Herefordshire, GB
Posts: 11,421
Thanks: 75
Thanked 436 Times in 379 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Garage
Quote:
Originally Posted by srt8driver View Post
My Malfunction Indicator Light came on a couple of months ago and then went off after a few cycles of driving. It came back on last week I pulled the fuse and it went away. Now if came back two days later. Should I replace the fuse or what to do? I don't really want to take it in to the dealer.
1) Welcome!
2) please amend your details so everyone knows which part of the world youre in
3) try the key dance (see a couple of posts above) & tell us what fault codes appear (nb, note that 'on' in the key dance doesnt mean start the engine!)
Kaiser Bill is online now  
post #8 of 31 (permalink) Old 06-21-2010, 04:46 PM
Senior Member
Points: 10,702, Level: 1 Points: 10,702, Level: 1 Points: 10,702, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 60% Activity: 60% Activity: 60%
 
sniper300c's Avatar
 
Join Date: Jun 2009
Location: York UK
Posts: 492
Thanks: 24
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Garage
Quote:
Originally Posted by BigIan View Post
It's OK............ panic over........... after 3 short journey's the MIL has gone out and stayed out so far

BTW what's the "key on/off routine" for next time.

also check the small pipe that connects to the turbo (the 1 that drags the oil into the swirl chamber) if i've been messing about under the bonnet, i've knocked before and it does exactly what you've described.
just worth checking
sniper300c is offline  
post #9 of 31 (permalink) Old 06-22-2010, 01:33 AM
Supporting Vendor
Points: 37,912, Level: 1 Points: 37,912, Level: 1 Points: 37,912, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 5% Activity: 5% Activity: 5%
 
Simon@thecustom300cshop's Avatar
 
Join Date: Jun 2008
Location: Berkshire, UK
Posts: 6,693
Thanks: 158
Thanked 169 Times in 160 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by sniper300c View Post
also check the small pipe that connects to the turbo (the 1 that drags the oil into the swirl chamber) if i've been messing about under the bonnet, i've knocked before and it does exactly what you've described.
just worth checking
I don't think it will be that unless he's bought a CRD and no longer has the Hemi.
Simon@thecustom300cshop is offline  
post #10 of 31 (permalink) Old 06-22-2010, 02:20 AM
Lifetime Premium Member
Points: 51,045, Level: 1 Points: 51,045, Level: 1 Points: 51,045, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 68% Activity: 68% Activity: 68%
 
UK CHRYSLER 300C's Avatar
 
Join Date: May 2007
Location: Stafford UK
Posts: 9,540
Thanks: 7
Thanked 216 Times in 185 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Lambo,I think Sniper was talking to BigIan............(I did say think,lol)


single led 501's(not crappy flowery multi led,g4y type bulb,lol)
4300k hid main lights
4300k hid fog lights
Massive Brembo Gran Turismo Brake kit upgrade
Diablo Predator
RS UV-1, 20" alloys
NEVER SAY NEVER
Immobiliser screwed for the 2nd time in a year
UK CHRYSLER 300C is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Brakes" indicator light GreyMatter Brakes 5 06-02-2009 08:13 AM
Malfunction Indicator Light-Please Help RustyNail Lighting Discussion 2 09-15-2008 01:14 PM
Malfunction Indicator Light coolvanilla Problems / Dealer Service 12 03-12-2006 05:09 PM
Malfunction Indicator Light qictrk 1st Gen SRT8-Specific General Discussion 0 02-28-2006 10:08 PM
MDS "ON" Indicator Light magnuman Performance General Discussion 40 05-23-2005 05:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Inactive Reminders By Icora Web Design