Help! My car is sick! - Page 2 - Chrysler 300C Forum: 300C & SRT8 Forums
UK & Europe Regional Forum This section is for topics relating to the EU versions of the Chrysler 300 and diesel powered models.

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 38 (permalink) Old 01-07-2019, 10:02 AM
Lifetime Premium Member
Points: 85,741, Level: 1 Points: 85,741, Level: 1 Points: 85,741, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 99% Activity: 99% Activity: 99%
 
Car: 2005 Chrysler 300C
Join Date: Feb 2005
Location: Coatesville, PA, U.S.A.
Posts: 4,708
Thanks: 2
Thanked 242 Times in 224 Posts
Quote:
Originally Posted by feichter View Post
Just got the car back from my local garage.
He found 2 codes. U0101 and P0676 which he cleared. He drove the car and the codes haven't come back.
He said to bring the car back if the lights came back.

Any ideas anyone?

Sent from my Redmi 4 using Tapatalk
From the interweb:
This diagnostic trouble code (DTC) is a generic powertrain code. It is considered generic because it applies to all makes and models of vehicles (1996-newer), although specific repair steps may be slightly different depending on the model. This code relates to the device diesels use to heat the cylinder head for a few seconds when attempting to start a cold engine called a glow plug. A diesel relies entirely on the momentary high level of heat through compression to spontaneously ignite the fuel. The glow plug in the #6 cylinder has failed.

Read more at: https://www.obd-codes.com/p0676
BiliTheAxe likes this.

2005 300C BRILLIANT BLACK, DRL, Mesh Grill/Vents, Chrome Pillars & Fender Trim, MDS Indicator, Quad Brake Lights, Tinted Windows, De-Molded, K&N Aircharger, 180 T-Stat, Flashing Sidemarkers, Predator Cust. Perf. 93 CAI Tune
1997 MUSTANG COBRA 'VERT, TRIPLE BLACK, Vortech S/C'd., ECT Mod., 4.10 Rear, Lowered 1&1/2", 18" Saleen Wheels
1950 FORD TUDOR FLATHEAD V8 - Sold 6/27/14 after 16 years of fun.
DESIREE is offline  
The Following User Says Thank You to DESIREE For This Useful Post:
feichter (01-07-2019)
Sponsored Links
Advertisement
 
post #12 of 38 (permalink) Old 01-07-2019, 06:11 PM
Lifetime Premium Member
Points: 85,741, Level: 1 Points: 85,741, Level: 1 Points: 85,741, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 99% Activity: 99% Activity: 99%
 
Car: 2005 Chrysler 300C
Join Date: Feb 2005
Location: Coatesville, PA, U.S.A.
Posts: 4,708
Thanks: 2
Thanked 242 Times in 224 Posts
You are welcome there 'feichter'.
DESIREE is offline  
post #13 of 38 (permalink) Old 01-08-2019, 03:38 AM Thread Starter
Senior Member
Points: 16,064, Level: 1 Points: 16,064, Level: 1 Points: 16,064, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 7% Activity: 7% Activity: 7%
 
feichter's Avatar
 
Car: 2007 Chrysler 300C CRD
Join Date: Jan 2013
Location: Deal, Kent
Posts: 220
Thanks: 37
Thanked 10 Times in 9 Posts
Well, lights are back on!

The lightning bolt, the eps and the skid light.

Any help greatly appreciated.

Sent from my Redmi 4 using Tapatalk
feichter is offline  
 
post #14 of 38 (permalink) Old 01-08-2019, 05:46 AM
DGO
Senior Contributing Member
Points: 12,414, Level: 1 Points: 12,414, Level: 1 Points: 12,414, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 99% Activity: 99% Activity: 99%
 
Car: 2008 & 2013 Chrysler 300c CRD & 300 AWD
Join Date: Jun 2012
Location: Hertfordshire, UK
Posts: 977
Thanks: 1
Thanked 77 Times in 75 Posts
Same codes or different?
DGO is offline  
post #15 of 38 (permalink) Old 01-08-2019, 07:32 AM Thread Starter
Senior Member
Points: 16,064, Level: 1 Points: 16,064, Level: 1 Points: 16,064, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 7% Activity: 7% Activity: 7%
 
feichter's Avatar
 
Car: 2007 Chrysler 300C CRD
Join Date: Jan 2013
Location: Deal, Kent
Posts: 220
Thanks: 37
Thanked 10 Times in 9 Posts
Some limited success...

Thanks to all, in particular to Paul from the custom300cshop.
On his advice, I have disconnected the HID module next to the washer bottle, and after having left the battery disconnected for 20 minutes, the lightining bolt, eps light and skidd light are now off. However the engine manangement light is still on and I can't clear, or even see , the code with my USB elm. The car drives fine and is not in limp mode anymore.
So, I will wait until tomorrow, drive the car again, and if no light come on, I will download torquePro on my mobile and see if I can clear the code and turn the MIL light off with my other ELM (bluetooth).

Let's wait and see...
feichter is offline  
post #16 of 38 (permalink) Old 01-09-2019, 04:16 AM Thread Starter
Senior Member
Points: 16,064, Level: 1 Points: 16,064, Level: 1 Points: 16,064, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 7% Activity: 7% Activity: 7%
 
feichter's Avatar
 
Car: 2007 Chrysler 300C CRD
Join Date: Jan 2013
Location: Deal, Kent
Posts: 220
Thanks: 37
Thanked 10 Times in 9 Posts
Ok. Lights back on this morning and in limp mode.

So, have downloaded Torque Pro on my mobile and have been able to clear both codes! At least I will be able to drive it to the stealership!
feichter is offline  
post #17 of 38 (permalink) Old 01-09-2019, 06:56 AM
Senior Contributing Member
Points: 13,544, Level: 1 Points: 13,544, Level: 1 Points: 13,544, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2010 Chrysler 300C
Join Date: Apr 2009
Location: Tunbridge Wells, Kent
Posts: 651
Thanks: 6
Thanked 38 Times in 36 Posts
P0676 is the glowplug on cylinder 6. It doesn't cause the engine light to come on and, in fact, with only one glowplug dead it'll start and drive fine.

It's the rear cylinder on the passenger side (ie: closest to the passenger). New ones are £6 on ebay. I did two on my 300C yesterday - you need to do them with the engine hot, torque them to 12Nm.
talldave is offline  
The Following User Says Thank You to talldave For This Useful Post:
feichter (01-09-2019)
post #18 of 38 (permalink) Old 01-09-2019, 07:05 AM Thread Starter
Senior Member
Points: 16,064, Level: 1 Points: 16,064, Level: 1 Points: 16,064, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 7% Activity: 7% Activity: 7%
 
feichter's Avatar
 
Car: 2007 Chrysler 300C CRD
Join Date: Jan 2013
Location: Deal, Kent
Posts: 220
Thanks: 37
Thanked 10 Times in 9 Posts
Thanks for that talldave!
In fact, just had a look at that! However, I don't have the necessary tools and don't feel confident enough, so will take it to the local garage.
Do you know, or have you ever heard, of this causing my other lights (Lightning bolt, eps and skid light) to come on?
feichter is offline  
post #19 of 38 (permalink) Old 01-09-2019, 01:49 PM
Senior Contributing Member
Points: 13,544, Level: 1 Points: 13,544, Level: 1 Points: 13,544, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2010 Chrysler 300C
Join Date: Apr 2009
Location: Tunbridge Wells, Kent
Posts: 651
Thanks: 6
Thanked 38 Times in 36 Posts
Quote:
Originally Posted by feichter View Post
Thanks for that talldave!
In fact, just had a look at that! However, I don't have the necessary tools and don't feel confident enough, so will take it to the local garage.
Do you know, or have you ever heard, of this causing my other lights (Lightning bolt, eps and skid light) to come on?
I understand - a dealer once quoted me £100 to do two glowplugs, so that spurred on my investment in the right tools! With the right kit it's quite easy, although I was doing cylinders 1 & 3 yesterday and 1 is a pain as there's a rubber fuel pipe in the way. 6 looks easy - so if you're ever passing Tunbridge Wells, I'd be happy to help!

I've never known a glowplug error to cause any lights to come on. At worst, it might cause an extra bong at startup and a code added to the chime list in the "secret" menu. Unlike spark plugs, failed glowplugs don't stop the car working and I'm sure most CRD owners are driving round with one or more dead. I had to replace 3 on my first 300C and have done 4 on my current one. There's a myth that they're only powered on in very cold conditions, but that's not true according to the service manual - they stay on for between 2 and 3 minutes with a cold engine and 20 seconds for a hot engine. Starting is snappier with all 6 working.
talldave is offline  
The Following User Says Thank You to talldave For This Useful Post:
feichter (01-09-2019)
post #20 of 38 (permalink) Old 01-09-2019, 11:04 PM Thread Starter
Senior Member
Points: 16,064, Level: 1 Points: 16,064, Level: 1 Points: 16,064, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 7% Activity: 7% Activity: 7%
 
feichter's Avatar
 
Car: 2007 Chrysler 300C CRD
Join Date: Jan 2013
Location: Deal, Kent
Posts: 220
Thanks: 37
Thanked 10 Times in 9 Posts
Does anyone know a good stealership or, better, an independent garage in the Dover or east Kent region?

Sent from my Redmi 4 using Tapatalk
feichter is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Car still shaking Dakur 2nd Generation Chrysler 300 Discussion 18 06-13-2017 10:24 AM
newbie, great car! not so good dealer experience Adder72 2nd Gen SRT- General Discussion 8 11-02-2016 02:58 AM
Advice on selling car svisek General Discussion 13 09-19-2016 09:57 AM
So, I'm bringing my new-to-me car home and... Jim777 Off-Topic Discussion 11 11-21-2015 11:43 AM
Car wanders to the right Garrett Craig General Discussion on Issues / Trouble Shooting 6 08-26-2015 07:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome