Upper control arms - Chrysler 300C Forum: 300C & SRT8 Forums
UK & Europe Regional Forum This section is for topics relating to the EU versions of the Chrysler 300 and diesel powered models.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 02-23-2019, 01:38 PM Thread Starter
Member
Points: 2,080, Level: 1 Points: 2,080, Level: 1 Points: 2,080, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C
Join Date: Oct 2018
Location: Hampshire, UK
Posts: 57
Thanks: 33
Thanked 1 Time in 1 Post
Upper control arms

2007 CRD - 112k miles.

Hi All,

I have a metal type of squeaking noise coming from the nearside front suspension. Seems to be worse when fully loaded with passengers. Heard more at low speed (20 mph). Can also hear a lighter version of the noise when car is stationery and when turning the steering wheel slowly to the nearside. Sounds a bit like old metal bed springs.

After changing the anti roll bar bushes, am thinking it is likely to be the ball joint on the upper control arm.

I have read most of the posts on here about replacing the upper control arm (including the step by step guide), but am still a bit puzzled as to how to remove the rear nuts in the engine bay.

Does anyone have any experience/ideas on how best to get these off? I can get a socket on the nut but can't see how to get the wrench on it. Even if I remove some of the things beyond the nuts, the cross strut seems to be in the way.

Alternatively, a recommendation of a garage in the Hampshire area that may be able to do this for me.

Many thanks.
AB77 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-23-2019, 03:34 PM
DGO
Major Contributing Member
Points: 12,801, Level: 1 Points: 12,801, Level: 1 Points: 12,801, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 99% Activity: 99% Activity: 99%
 
Car: 2013 & 2014 Chrysler 300c CRD & 300 AWD
Join Date: Jun 2012
Location: Hertfordshire, UK
Posts: 1,030
Thanks: 1
Thanked 82 Times in 80 Posts
Having done mine a couple of years ago, the useful guide from theduxs isn't available anymore (their website has gone). It's a case of getting the right size spanner/ratchet spanner down the back and juggling between the bolt (under the wheel arch) and the hard to get at nut behind the strut tower. It is possible especially if you can get someone to help (but it's a bit tricky to do)
DGO is online now  
The Following User Says Thank You to DGO For This Useful Post:
AB77 (02-23-2019)
post #3 of 9 (permalink) Old 02-23-2019, 04:12 PM Thread Starter
Member
Points: 2,080, Level: 1 Points: 2,080, Level: 1 Points: 2,080, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C
Join Date: Oct 2018
Location: Hampshire, UK
Posts: 57
Thanks: 33
Thanked 1 Time in 1 Post
Thanks DGO......so can you remove by undoing (turning) the bolt from underneath the wheel arch, rather than undoing (turning) the nut at the back of the engine bay? ....obviously I would still need to get a spanner on the nut in the engine bay to stop it turning.
AB77 is offline  
 
post #4 of 9 (permalink) Old 02-23-2019, 04:48 PM
DGO
Major Contributing Member
Points: 12,801, Level: 1 Points: 12,801, Level: 1 Points: 12,801, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 99% Activity: 99% Activity: 99%
 
Car: 2013 & 2014 Chrysler 300c CRD & 300 AWD
Join Date: Jun 2012
Location: Hertfordshire, UK
Posts: 1,030
Thanks: 1
Thanked 82 Times in 80 Posts
No you have to turn the nut, I used a flat old fashioned spanner using one tooth at a time to start with. Took a while but you can do it. The bolt end in the wheel arch has a piece of metal to stop it turning. Only when they get loose enough (almost off) you can turn the bolt
DGO is online now  
The Following User Says Thank You to DGO For This Useful Post:
AB77 (02-24-2019)
post #5 of 9 (permalink) Old 02-24-2019, 03:10 AM Thread Starter
Member
Points: 2,080, Level: 1 Points: 2,080, Level: 1 Points: 2,080, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C
Join Date: Oct 2018
Location: Hampshire, UK
Posts: 57
Thanks: 33
Thanked 1 Time in 1 Post
Excellent, thanks.

A few more questions, if you don't mind, please.

1) Did you have to remove anything from the engine bay to get your spanner on the rear nuts?

2) Presumably you can't torque the rear nuts once refitting due to the limited access?

3) What were your symptoms before changing the upper control arms?

Thanks again.
AB77 is offline  
post #6 of 9 (permalink) Old 02-24-2019, 04:02 AM
DGO
Major Contributing Member
Points: 12,801, Level: 1 Points: 12,801, Level: 1 Points: 12,801, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 99% Activity: 99% Activity: 99%
 
Car: 2013 & 2014 Chrysler 300c CRD & 300 AWD
Join Date: Jun 2012
Location: Hertfordshire, UK
Posts: 1,030
Thanks: 1
Thanked 82 Times in 80 Posts
1. No I didn't have to remove anything to get to the rear nuts - but you're right it is a very tight gap. It helps of you have a decent range of spanners to choose from
2. No you can't get a normal torque wrench on the rear nuts. I don't know if one of the types that fits spanner ends would be able to fit.
Do remember to drop the car back onto it's wheels before final tightening to avoid putting an inbuilt twist into the rubber bushes
3. The ball joints were shot - I had already disconnected the hubs from the arms and the ball joint would just wiggle around loose
DGO is online now  
post #7 of 9 (permalink) Old 03-07-2019, 08:21 AM Thread Starter
Member
Points: 2,080, Level: 1 Points: 2,080, Level: 1 Points: 2,080, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C
Join Date: Oct 2018
Location: Hampshire, UK
Posts: 57
Thanks: 33
Thanked 1 Time in 1 Post
Just a quick update on this.

After deliberating for a while, decided to get the job done professionally and glad I did.

Had the work done at P & L Motors in Warminster (Wiltshire). Recommended to me by someone who buys and sells Chrysler 300s. Even though they are just over an hour away from me, well worth the trip.

Excellent service by P & L, they used a clever telescopic ratchet socket on a swivel joint which made getting to the rear nuts in the engine bay relatively simple, without the need to remove anything else. The ball joints were split with 7 or 8 very heavy hits with a hammer (much harder than I would have expected). Loosening of the shock absorber struts was also absolutely necessary in order to remove the 2 bolts.

P & L Motors have good knowledge of working on Chrysler 300s so would definitely recommend, even if you have a distance to travel, like me!
AB77 is offline  
post #8 of 9 (permalink) Old 03-07-2019, 08:44 AM
DGO
Major Contributing Member
Points: 12,801, Level: 1 Points: 12,801, Level: 1 Points: 12,801, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 99% Activity: 99% Activity: 99%
 
Car: 2013 & 2014 Chrysler 300c CRD & 300 AWD
Join Date: Jun 2012
Location: Hertfordshire, UK
Posts: 1,030
Thanks: 1
Thanked 82 Times in 80 Posts
Ah great news. How worn were the balljoints and bushes?

Is your squeaking cured?
DGO is online now  
post #9 of 9 (permalink) Old 03-07-2019, 10:22 AM Thread Starter
Member
Points: 2,080, Level: 1 Points: 2,080, Level: 1 Points: 2,080, Level: 1
Level up: 99% Level up: 99% Level up: 99%
Activity: 0% Activity: 0% Activity: 0%
 
Car: 2007 Chrysler 300C
Join Date: Oct 2018
Location: Hampshire, UK
Posts: 57
Thanks: 33
Thanked 1 Time in 1 Post
Fingers crossed, no creaks/squeaks so far having driven 60 miles home. It used to happen more when I drove with the extra weight of passengers so will try out over the next few days but am fairly confident it is fixed as I heard no noise at all.

P & L Motors thoroughly checked all the front suspension components while off the ground and even then it wasn't completely obvious that the upper control arm was the culprit. However, having removed the first arm, we could feel there was a very small amount of play in the ball joint when pushed in a certain direction.

The old upper control arms arms themselves did look fairly tired/slightly corroded so we were tempted to think they may have been the originals but at 112k miles this does perhaps seem unlikely.

Just need to fix an oil leak now! After some research on the forum and because of the location of the leaking oil, I think the oil cooler seal looks to be most likely but this seems to be a lot of work and very expensive, so I may just have to live with it. No noticeable loss of oil on the dipstick, but just a mess underneath the engine and some drops of oil on the drive.
AB77 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chrysler 300C Forum: 300C & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Query on replacing rear forward top control arms Clint221 CRD Wheels / Tyres / Suspension / Brake 3 01-17-2019 03:13 AM
2015 passenger upper control arm mrbill 2nd Generation Chrysler 300 Discussion 3 01-12-2018 08:03 PM
Help plz Upper control arm & ball joint Dreamcatcher300 UK & Europe Regional Forum 28 11-02-2016 04:02 PM
Adjustable control arms - any good ones? mopar to ya 1 1st Gen SRT8-Specific Wheels/Tires/Brakes/Suspension 2 09-10-2016 09:30 PM
Upper Control Arms Wayne Best UK & Europe Regional Forum 2 04-25-2016 06:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome