Chrysler 300C & SRT8 Forums banner

Reaction score
24

Profile posts Latest activity Discussions About

  • ChryslerCares ·
    Hi everyone,

    Please Private Message (PM) our page with any questions or concerns you may have. We usually need additional personal information to assist you which is why we ask this. To PM us just click on our username and choose "Send Private Message"!

    Thank you!

    Chrysler Social Care Team
    super-ss ·
    Hello Gents,

    I have a 300s 2017 and I faced some issues with my 8.4 screen "Uconnect" and I don't have a hard reset option as old version through the Engineering menu. Please I want your kind support to do the hard reset.

    I pulled the 37, 38 Fuses and disconnect the battery for 4 Hours and nothing changed.

    Your support is highly appreciated.

    Warm Regards,
    Sultan
    Giusemc ·
    HI there,

    Could you please check to see if my car can run E85, here is my VIN 2C3CDXHG6CH233364.

    THank you so much.
    Chrysler_2008 ·
    Hi from Ireland!

    I was wondering is there an official Chrysler Dealer in Dublin Ireland?

    Best regards

    Chrysler_2008
    Dublin
    Ireland
    BobF ·
    Hi Andrea. My VIN is 2C3CCABGXHH526670.The Service Adviser is Paul Batista. The Service Manager is Jerry Gordon. The Dealer is Glendale Chrysler Jeep etc. The phone number is (818) 242-4161. Good luck getting a hold of them as their phone system is not very good. As of now I have not heard back from Jerry who promised to call me as soon as a download was completed so he could update my car.

    I have contacted Chrysler upper management to make them aware of the situation and was told that a Uconnect Manager would look into the problem and my concerns and get back with me.

    Thanks and have a safe and happy Memorial Day.

    Best regards, Bob.

    (818) 240-0849
    Giusemc ·
    Hi there
    Could you​ please check my car VIN to see if my car support e85. I did replace after market hood and gas cap, so i can't see if there is e85 support. Here is my VIN :
    2C3CCADG5DH743678
    Thanks you.
    Best.
    mkillinger ·
    2012 Chrysler 300S 5.7 AWD
    AWD indicator in EVIC always shows AWD never changes to RWD, also another problem sounds like air compressor noise coming from engine compartment coupled with a rumble sensation in car (like awd is engaged).
    Small air compressor type noise noticeable at 40MPH under cruising conditions and becomes louder on decel when road noise lessens. Noise will stay active until speedometer reaches 20mph and then disappears, while it feels like something disengages at same time noise stops.
    At the same time tachometer jumps approx. 200rpm and goes back down.
    Last time while two dealerships had car I was without car (had loaner from CarMax) for five weeks with no fix.
    Bough vehicle at CarMax but still has powertrain warranty until February but two dealerships (sent to by CarMax) could not find source of noise but replaced two lifters in engine. Oddly enough I have a very bad lifter noise when air temp is below 10degress F. Takes a long time to pump up the lifters.
    Giusemc ·
    Hi there,

    I have same issue with my roughly down shift from 2nd->1st. Would you please write me a letter or any kind of document which I can show it to dealer to get it fix? Base on what I have read, do you think if the dealer changes the valve body, it can fix the problem? Please help me out because I really love the car and do not want to trade it in, but the issue really bother me. My car is 2013 chrysler 300C John Varvatos luxury but with this issue, it makes me feel like I am driving a low class car...

    Best Regards,
    Chanh Nguyen
    Bklynmann117 ·
    I have bought my used 2006 Chrysler 300c 5.7 in 2010 with 92000 miles. This was a fleet car and well maintained. I have had the car for 6 years always kept the maintenance up on the vehicle with 143000 miles. Without warning the car would not start so I had it towed to my mechanic in which he told me that one of my cylinders failed and that the cost to replace my engine will be 7k. I don't understand what happen to the engine but I cant afford that kind of money to get this fixed. I have did some research and found out that this was a manufacturing defect on the 5.7 hemi engines. I would like for Chrysler to take responsibility to replace this engine or for some type of compensation. I really love my Chrysler 300c and planned to keep this car for a very long time. Here is then VIN number 2C3KA63H86H432421 Please let me know if you can help. Thanks
    GABRIEL O. ·
    Why my 300c sounds at engine knock at idle every time. It sounds more loud at engine normal operation temperature. I change sparg plugs, clean injectors on lab, i test 2 kinds of gasoline oct. change the engine oil, And reprogramed the computer with my dealer. But no change the situation . Please help me !!!!
    mrmonster78 ·
    Drove home from work the other day, stopped at the store. a normal everyday routine before heading in(Mind you i'm financing and have only had the car for a little over three months-as is no warranty). come back out and go to start my car and nothing nothing but clicking n grinding. not good, at all i'm thinking alternator or starter but slight grinding had no clue. i sit there and call the tow truck, when they get there they ask if it starts i said it wasn't, turned the key and it came on so it wasn't alternator or starter. but it was making a loud grinding noise so i turned it off. took it to Chrysler and they said i need a new engine which will cost 7k. does anyone know of a cheaper cost option maybe a rebuild or swap that i can entertain. taking all options, just frustrated. I'm in New Jersey now public transportation bound while still paying for a car i cant drive, would there be any assistance i can be provided to help during this crazy event.
    casaandrews ·
    I am the latest victim of 2006 300C Engine Fail w/no warning. Bought it brand new and serviced regularly at dealership. When warranty ran out--still serviced regularly & purchased lifetime oil change pkg. I have found this is common problem with the 2006 300C. Is Chrysler acknowledging this and offering replacement. This is $7,000+ and past the warranty. I am hesitant and afraid to go used route. I loved this car never had any issues as others have reported. I will not consider another Chrysler as a replacement. An engine failure should NOT be happening on a 2006 vehicle that has well been taken care of. It appears from the posting of others with the same problem, that The Chrysler Company is not standing behind its product and allowing its customers to eat the ginormous costs of it's faulty machinery/parts. I would appreciate if there is someone I could get in contact with that could offer any type of recourse to make this right. Thank you.
    Rmany ·
    Hello,I sent a reply to older thread concerning a 2007 300c. I own a 2005 300C with the 5.7L Hemi.My brake lights just stopped working. Can you tell me where the"stop lamp inhibit relay" is located. I opened my fuse panel in trunk first time and found no fuse at all in Cavity 15(brake light 5.7L) and good 10 amp in Cavity19.I put new 20 amp yellow in Cavity 15-brake lights still dont work. I am wondering if someone tampered with my car.Shouldnt there be a 20 amp in Cav 15? I also read that the stop lamp inhibit relay can cause brake lights not to come on.I cant find where this is.Its not mentioned in owners manual. I would appreciate greatly any help you can provide! Thank you in advance!
    teebone300 ·
    Hi, another member put me onto you to see if you could help with a query over the factory build spec of my new purchased 300S, relating to whether this currently unregistered or delivered Australian MY13 vehicle (factory build date 18th April 2013) does actually have the 19 speaker Harmon Kardon Sound system fitted, as per my Contract of Purchase from the a main dealer here in Aus.

    I don't yet have the vehicle, it is 200kms away and I didn't check this when I drove all the way to inspect it yesterday. However, all the Chrysler Brochures and options lists I have subsequently looked at to show a friend, doesn't show this system as an option for the 300S.

    Hopefully, there was a specific build with this system for Australia and the spec isn't showing correctly in the Aus Brochures - Vin number is: 2C3CCAYGXDH683939, Engine DH683939.

    Hope you can ease my concerns - Many thanks
    markz300S ·
    I have a high pitched sound like a whistle or ringing in my interior blower fan. I thought it was interference with the radio that I was hearing, but the sound occurs with the ventilation fan on speeds 1-4 mainly. After 5 I do not hear it. The sound occurs with radio on or off, with A/C on or off. Can you help with diagnosis? The shrill sound is really unnerving at times. It is not audible outside the car, so it does appear to be an interior issue. I have already replaced my blower fan last fall just outside of my warranty (3 YEARS/36K MILES). Is there a warranty on repairs and replacement parts if this is indeed another blower motor/fan issue? Thank you so much!
    Tae300 ·
    I need help! I took my car to Auto Zone because my check engine light came on randomly after replacing my ignition coils on my 2005 Chrysler 300 Touring 3.5L. The codes came back as P0562 "System Under Voltage", P0700 "Transaxle Control Malfunction", P0457 "EVAP System Loose", & A Vacuum Leak. They tested my battery & alternator & said that those were fine so I don't understand the P0562 code. My car feels like I am driving over rumble stripes around 40-50mph, could the code P0700 be causing that? Where would the transaxle control be located? The P0457 code read that is was the gas cap was loose how ever I've tightened it. What else could I check. How could I diagnose the vacuum leak? If it makes it easier you can reply to my email: [email protected] , thank you in advance if you could help.
  • Loading…
  • Loading…
  • Loading…
Top