Chrysler 300C & SRT8 Forums banner

help

  1. I made a mistake...

    General Discussion
    hello y'all, finally been able to get some free time to work on my baby. Jumped right on in, started pulling her apart, got all the way to driver's head pull and I'm ready to pull the cam.....I missed a step somewhere....great big high five and an Attaboy to you if you can guess what........ok...
  2. Tapping sound upon deceleration

    1st Gen SRT8-Specific Wheels/Tires/Brakes/Suspensi
    Good afternoon everyone, I'm having yet another issue with the 06 SRT8. This is a problem that my girlfriend pointed out when driving the car yesterday. When slowing down, there is a tapping sound coming from the back that is relative to the speed of the car. It almost sounds like there is a...
  3. 2006 300c SRT8 Torque Converter Problem

    1st Gen SRT8-Specific General Discussion
    Good day all, You may have seen some of my other posts on this form about my 06 SRT8 and the journey I've gone through fixing this thing up. One of the issues that has been around since the beginning is an odd fluctuation in the RPM when under light load (driving up hill at low RPM). The...
  4. C2116 ABS Low Voltage

    1st Gen SRT8-Specific General Discussion
    Unfortunately I have had to start 2 threads today for 2 different issues with my 2006 6.1... This one is for a code that I have been getting since day one. C2116. ABS Low voltage. What is strange is the ESP, BAS, Traction CTRL, ABS lights don't always come on. It is on about 70% of the time when...
  5. SRT8 Running Odd with no codes

    1st Gen SRT8-Specific General Discussion
    Good morning all, I have a bit of a strange situation with my 2006 Chrysler 300c SRT8 with the 6.1. I recently changed the intake manifold gaskets and plenum (I used no RTV on either). I changed them because of oil seepage from the intake area and a major leak on both sides of the intake. After...
  6. 2006 SRT8 Groan Sound

    1st Gen SRT8-Specific General Discussion
    Good afternoon everyone, This is my first post here so I apologize for any ignorance about the forums here but I'm in desperate need of help with this car. 2 years ago we got scammed when purchasing a 2006 300C SRT8, in short the odometer had been rolled back, and it had a whole slew of other...
  7. IAT reads -40degF constant

    General Discussion on Issues / Trouble Shooting
    I have a 2010 300C and I recently installed an Airraid CAI and in the process I broke the IAT that was already installed. I ran to the parts store and grabbed a replacement (Mopar PN 56028364AA) (I also tried Mopar PN 4606487AB, it doesn't fit). I plugged it in and didn't have any codes or...
Top