Chrysler 300C & SRT8 Forums banner
pcm
1-8 of 8 Results
  1. General Discussion
    Hello, I just picked up a 2006 Chrysler 300C with the 5.7L Hemi for a steal, knowing that it had an unidentified "misfire" problem. Now that I have it home, the car seems to be able to run, and is mechanically excellent. The first time you start up after a full night "cold soak", the car will...
  2. General Discussion
    my 300's engine has been shutting off while driving and at idle. when it happens the codes get erased. diagnostic tools show nothing and the mechanic doesn't know what's happening but thinks it could be a crank sensor. maybe pcm? any ideas? this is my first post I hope its in the right place.
  3. General Discussion
    Had some codes pop up for high/low voltage to wheel sensor, egr sensor, and oil pressure sensor. ESP BAS and ABS lights were on along with the check engine. Car seemed to run fairly decent but was a little sluggish sometimes on acceleration. Well last weekend I was driving all of a sudden the...
  4. General Discussion on Issues / Trouble Shooting
    Hey guys, first time posting here I’ve been on here reading frequently since I got my car back in August. Cut to the point, there seems to be an issue relating to the transmission. I first noticed it when my car stopped being able to coast. I release the gas at speed, and it immediately starts...
  5. General Discussion
    2005 Chrysler 300c 5.7l. Need some expert advice. I just installed a remanufactured PCM, it's been updated with my VIN. From what I've read here and in other forums, and according to the company that sold me the unit, as well as the locksmith, the car shouldn't run without having the SKIM...
  6. General Discussion
    I apologize as I am new to this site and am really unsure of what I am doing, so bare with me if I happen to post a thread under the wrong forum or something. The one thing I do know is that I'm having some issues with my 2006 Chrysler 300 and I'm hoping someone on here has had the same or...
  7. General Discussion on Issues / Trouble Shooting
    Hello Everyone, I'm so frustrated and at my WITS end with my 2005 Chrysler 300 2.7 Mean Vanilla. My wife drives this car mainly, it has over 260k miles on it and this summer she was driving when suddenly she heard a loud pop and saw smoke. She pulled over and all the coolant had leaked out of...
  8. General Discussion on Issues / Trouble Shooting
    I need some help basically trying to add a shifter knob from a 2015 Chrysler 300 to my 2013 Chrysler 300 v6 with the 8 speed transmission. when I connect it the power comes on but can't do anything with it. any help would be greatly appreciated. when I connect the original shifter and splice...
1-8 of 8 Results
Top