Chrysler 300C & SRT8 Forums banner

rough idle

  1. General Discussion on Issues / Trouble Shooting
    Hi everyone.
  2. General Discussion on Issues / Trouble Shooting
    Hello Everyone, I'm so frustrated and at my WITS end with my 2005 Chrysler 300 2.7 Mean Vanilla. My wife drives this car mainly, it has over 260k miles on it and this summer she was driving when suddenly she heard a loud pop and saw smoke. She pulled over and all the coolant had leaked out of...
  3. General Discussion on Issues / Trouble Shooting
    Thanks for taking the time to read this and help out. Recently, two weeks ago, I installed a oil catch can. After extensive research, I thought it would be a great idea to install a catch can, in hopes that it will help maintain proper performance in the long run. Roughly a week after...
  4. CRD Electrics / Electronics / Lighting
    Hi guys, I have a 2008 CRD SRT Design and recently I've been having some problems with the voltage dropping on idle when the inside heater blower is on and the radiator fan kicks in. With the blower off, car idles fine and voltage remains at 14.6-14.8V. When I turn the blower on the voltage...
  5. General Discussion
    Hey guys, I was driving my car today and everything was fine and normal. I was picking up someone and when I got there, I had turned off my car for about 30 seconds. When I started the car back up, it wouldn't start. So I tried it again and it came on, but had a really rough idle and wanted to...
  6. General Discussion
    My 300C (2005) when it starts, it kind of bucks like the default timing is too advanced. At a steady speed, like 35 mph, it wants to vibrate, then will run smooth if I keep accelerating slightly and occasionally, when at idle, it dies, won't restart without pressing the accelerator, then it...
  7. General Discussion on Issues / Trouble Shooting
    2005 Chrysler 300 3.5 V6 Engine shudders/Vibrates intermittently and varying intensities This is long but I wanted to include as much detail as I could. The engine shudders/vibrates when accelerating and driving sometime at 40 mph but most often when 60mph and above, it stops if I let off the...
  8. General Discussion on Issues / Trouble Shooting
    Hello all My friend has an 05 C300 5,7L Hemi, it has 125k miles. the car sometimes doesn't idle properly and i've never heard or seen these symptoms on a car before because all of these appear by the same time and once a 4 times roughly !! the battery light flashing and ESP light appears...
Top