Chrysler 300C & SRT8 Forums banner

sensor

  1. 2006 300 Sig Series Oil Pressure at Idle Issue

    General Discussion
    Hey gang, I recently posted I was having issues with my oil pressure light coming on when I was braking. I thought it may be a sensor issue that when the forward momentum was braked hard enough pushed the wires out of place enough to trip the oil pressure light. Since then, I've discovered...
  2. Mystery object on roof headlining of wagon

    General Discussion
    Hello I feel like a bit of a twit asking this (as I'm sure it is probably something obvious) I discovered this sensor or light on the roof interior of my 2006 (Australian model) wagon and I have no idea what it is I've re-read the owners manual and there is no mention of it that I can find...
  3. 300c Wheel Pressure sensor

    UK & Europe Regional Forum
    Hi all, I have just purchased a new set of wheels for my 300c. Does anyone know an easy way of removing the old pressure sensors from my old wheels so that I can fit them to my new wheels. I understand that they are stuck on! Thanks, Neil.
  4. Surging at speed

    General Discussion
    I have a 2005 300c that has developed a surge when it is at a constant speed. I had a code “P3497” pop up, I changed the oil and it went out. About a month ago I had the transmission flushed at the local dealer so the fluids are fresh. I do pull a trailer with this car but the load is under a...
  5. Why am I Over Heating with the A/C?

    General Discussion
    Model: 2006 Chrysler 300 (100% stock) Touring AWD 3.5L 174,000kms How it Started: Last night I drove home with the A/C on, for about 25 minutes. I picked up the kids and headed to the bank, at which point the engine temp warning popped on for a moment. The temp gauge corresponded by...
  6. Brake Pedal Position Sensor

    General Discussion
    Hi Fellas, I have called 2 dealerships in Michigan area asking for a Brake Pedal Position Sensor for my 2005 Chrysler 300C rear wheel drive. They cannot find and I am a little frustrated. I can find on my own on Autozone. What my problem is with my car is this - the ABS light is on as well...
  7. Accelerator Postion Sensor

    General Discussion on Issues / Trouble Shooting
    Hey all. thanks for all the help on many other things. I am receiving an error code for the low voltage on the APS. I wanted to change this out but am unsure as to how you do the following: 1. how to check if I have a fixed or AT Accelerator Position Sensor pedal Assembly? 2. How to change...
  8. Air Bag Connector Wire?

    General Discussion on Issues / Trouble Shooting
    Hello, I have a 2005 300C and just yesterday I purchased a new seat motor for my drivers' side. There was 1 wire left unconnected but i wasn't sure what it was for. The new seat moves front/back and up/down. Now my airbag light is on and i cannot shut it off. I know now that the left over wire...
  9. instrument cluster engine temp gauge

    Engine Cooling
    Temp gaugue went out a while back. never had a overheating problem so didn't worry about it. Engine light went on a couple days ago because the thermostat threw a code. Immediately replaced the thermostat, Engine Cooling Tempature (ECT) Sensor, and flushed cooling system . All is good except...
  10. car dies/stalls outs

    General Discussion on Issues / Trouble Shooting
    Hey guys I'm running into a bit of trouble with my 300. Hopefully I can get some direction here. I drive a 2006 Chrysler 300 Touring and when I start the car usually in the mornings when it hasn't been driven for a long period of time she'll idle for a few seconds then completely die. It takes...
Top