Chrysler 300C & SRT8 Forums banner
subwoofer
1-8 of 8 Results
  1. Car Audio/Alarms/UConnect/Navigation
    Hi guys, I have a 2012 300c that i bought at 24 000 K. I found out after i bought it that the original owner requested NOT to have a subwoofer in there for some reason. I bought the stock sub that goes in there, but after connecting it i get nothing. The back deck is already prewired for the...
  2. Car Audio/Alarms/UConnect/Navigation
    I'm trying to wire up amp and subs using a LOC since I have 2006 Signature Series with navi and 6 cd changer. I was trying to find the wires to the two 6x9s to splice in LOC and the right 6x9 was already spliced or wrapped around with the sub wires. I thought it was just the left 6x9 wrapped...
  3. Parts Buy/Sell Forum
    F/S Kicker 77KICK20AB dual 10" subwoofer I've got a Kicker 400watt dual 10" subwoofer, in great condition, for sale. I'm the original owner... It's adult owned( I'm in my 40s) and never abused. It's installed in a 2007 300c with the REC radio right now... It fits 2005-2009 chrysler 300C...
  4. Car Audio/Alarms/UConnect/Navigation
    Hey guys, I have a 2013 Limited (Second Generation). At this moment I am running 2 Kicker CompR 15" subs off of a Kicker KX2400.1 with a Kicker KX400.4 running the stock speakers (Will be upgrading to JL C3600 components all round) and H/L conversion is being done with an Audiocontrol LC6i. I am...
  5. Car Audio/Alarms/UConnect/Navigation
    Hello everyone, I am new to these forums and I was wondering if one of you could help me out. I have a 2012 Chrysler 300 and I got two 10" kickers in a ported box installed yesterday and I noticed that my trunk will pop open while I am driving if I put the volume too high :lame:. It pretty...
  6. Car Audio/Alarms/UConnect/Navigation
    I just picked up a 2011 Chrysler 300C with the upgraded Alpine system. Even though the system includes an 8" sub, I'm disappointed with the bass output. I don't need a ton of bass, but I'd like a little more thump out of it. I'm trying to avoid putting a sub in an enclosure in the trunk. I don't...
  7. Car Audio/Alarms/UConnect/Navigation
    I have a 05 300c w/o the navigation. I am installing subs into the trunk. My amp is hooked up right and receiving power although my subs are not getting any power. I have been trying to hook a high to low power converter throught the back two speakers. I dunno if this is the problem or what. One...
  8. Car Audio/Alarms/UConnect/Navigation
    I have an 05 300c Hemi. I am putting my subs into the the trunk. The remote wire for my amp neesd to be plugged into a power source that does not involve me putting in a toggle switch. I am keeping the factory radio. I have tried a few different fuses in the rear fuse box but they all seem to...
1-8 of 8 Results
Top