Chrysler 300C & SRT8 Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I recently purchased a DiabloSport Trinity and installed the 91oct CAI tune. I just tested my 0-60 through the cars timer and got 3.92 seconds. Is there any way it could be wrong? Because I'm having a really hard time believing that a 2+ ton family sedan can go that fast.

The cars only mods are:
-Mopar Intake
-DiabloTune
-Mopar Coilovers
 

·
Premium Member
Joined
·
5,718 Posts
Sounds like a lot of wheel spin and caused a false reading.
 

·
Administrator
Joined
·
13,064 Posts
I agree. Some folks have reported spot on results with independent timing being done, others state that the stock 0 - 60 timer is way off. I'd get in some dragstrip time and see what it really does!
 

·
Premium Member
Joined
·
404 Posts
Yeah... Don't trust EVIC. I lost traction on the 1-2 shift and got a 3.5sec
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
You know, that might be what happened. There was a little chirp when it shifted, but it was still mindblowing how much faster the car got with the tune. I just couldnt believe 3.92 . Thanks for the info guys.
 

·
Registered
Joined
·
643 Posts
EVIC doesnt lie.
It can't.
It's a computer....
LOL

But definitely some track time will confirm you correct 0-60 times tho.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 · (Edited)
Haha I gave it to one of my buddies with an e92 m3 for a couple hours yesterday and he was tripping out at how fast it was lol



Definately going to hit the strip though!
 

·
Registered
Joined
·
75 Posts
I lost traction once and got a 1.8
Lol
Looked good on the dash. Nobody believed lol
But pissed me off cause it was my new record and no matter how fast i got it. I could never show noone cause always displayed the 1.8 cause it was the fastes recorded time lol
battery reset fixed it
 
1 - 8 of 8 Posts
Top