Chrysler 300C & SRT8 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have several things going on 1st is the reservoir bubbling 2nd heat not working in car 3rd the temperature gauge stays on cold and the high speed fans come on and won't go off is this a thermostat issue maybe being stuck open
 

·
Registered
Joined
·
1,083 Posts
Your thermostat may very well be stuck open, but all those symptoms don't really fit together.

I don't know the history of your car, but incompatible coolant mixing is a common problem with LX/LD cars. Chrysler switched from HOAT to OAT coolant in 2013, which has led to many cases where owners and/or mechanics have topped off HOAT coolants with OAT. Another problem is that LX cars like yours came with an orange-colored coolant from the factory, and most orange-colored coolants available in stores are a type called DEX-COOL, formulated for GM cars. So some folks think, "Hey, orange is orange", and add DEX-COOL to their Chryslers. Besides the fact that DEX-COOL is an OAT and not compatible with their cars, it also contains a plasticizer, EHA-2, which can destroy seals in cars not designed for it. So DEX-COOL is essentially Kryptonite to your 300.

So depending upon how well you know your car's history, and how carefully it has been serviced, you could be dealing with a partially clogged cooling system due to sludging caused by mismatched coolant. It could also be partially clogged by rust.

What I would suggest would be a complete drain and flush with distilled water. I like to remove the thermostat, flush until the drained water runs clear, and then install a new thermostat and a 50/50 mix of fresh HOAT coolant concentrate and distilled water. Check your owner's manual to be 100% sure of the correct coolant type.

It's not a bad idea to replace the radiator cap at the same time. Also be sure to inspect the coolant reservoir for cracks.
 

·
Registered
Joined
·
12 Posts
I have several things going on 1st is the reservoir bubbling 2nd heat not working in car 3rd the temperature gauge stays on cold and the high speed fans come on and won't go off is this a thermostat issue maybe being stuck open
i would change the thermostat and reservoir cap. You can also have an air bubble in your cooling system. If you recently replace anti- freeze and didn’t bleed your system it will cause these problems . To bleed you need tho loosen the bleeder valve on the water pump and fill your system until fluid comes of the bleeder bolt. The only other thing that can cause those problems is a leaking head gasket.
 

·
Registered
Joined
·
173 Posts
i would change the thermostat and reservoir cap. You can also have an air bubble in your cooling system. If you recently replace anti- freeze and didn’t bleed your system it will cause these problems . To bleed you need tho loosen the bleeder valve on the water pump and fill your system until fluid comes of the bleeder bolt. The only other thing that can cause those problems is a leaking head gasket.
It may be too late for that engine if there was an air bubble...
 
1 - 5 of 5 Posts
Top