Chrysler 300C & SRT8 Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Picked up on 9/9/04 - Won't Start on 9/17/04

I don't know what is wrong with my 300c... It just wouldn't start, wouldn't even click, the instrument panel lights would just flicker... Called DC and they sent a two truck to tow it to the dealer. I'm driving a 2005 Dodge Magnum until they figure out what is wrong with my car. Has anyone had a problem like this???
 

·
Registered
Joined
·
588 Posts
There have been a few similar events reported; usually it was the battery or a power outlet left on somehow. The car does have a 9 minute delay which will cut off any circuit left on after leaving the car, but there is one loophole.

There is a power outlet in the console box which is NOT protected by the car's electrical ON/OFF timer. Plugging in a cell phone or computer will drain the battery very quickly if left without the engine running.

Then there is the other obvious thing in that something is messed up electrically in the car. Getting it to the dealer is the correct thing to do.

How about posting afterwards just what was wrong, please? It will help us all.
 

·
Registered
Joined
·
99 Posts
mileshoover said:
There have been a few similar events reported; usually it was the battery or a power outlet left on somehow. The car does have a 9 minute delay which will cut off any circuit left on after leaving the car, but there is one loophole.

There is a power outlet in the console box which is NOT protected by the car's electrical ON/OFF timer. Plugging in a cell phone or computer will drain the battery very quickly if left without the engine running.

l.
Leaving a cell phone on to charge in the console box will not drain the car battery because as the cell battery takes on its charge its internal resistance increases and limits current flow. My wife left our phone plugged in there for three days recently ( the car was parked all that time) and the battery was just fine when we next went to start the car. I think more a bad cell in the car battery could be the culprit
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
Well, I will let everyone know what it was when I get it back. Also, I told them to go ahead and tint my windows while they have it (10% all the way around) 5% is toooo dark. I've already installed my E&G Grill, took me about an hour and didn't have to drill it out (saved the old grill). Also, i've installed the B-Posts too, the car looks awesome, only thing I think I will need after this is maybe some 20" wheels to feel up the wells a bit more since I don't want to lower it. I would like to find some factory 20"s like they have on the 2006 Prototype 300c.
 

·
Registered
Joined
·
122 Posts
cshflow said:
I would like to find some factory 20"s like they have on the 2006 Prototype 300c.
Wait year and youll be able to get them on ebay as folks put 22s on that new car.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #9
Talked to the dealer yesterday and they just said that something is draining the battery and they can't find it, they are still looking for the problem. I'm about to change my mind and ask for my $10k back!
 

·
Registered
Joined
·
74 Posts
Electrical problems are very difficult to trace. I hope they find the problem quickly so that you can drive the car and remember why you wanted it in the first place.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #11
Thanks... It barely has 300 miles on it now. I've waited since 6/15 so i'm back in the anxious mode. :)
 

·
Registered
Joined
·
48 Posts
Discussion Starter #12
Well, it's going on 3 weeks now and Friday, the dealer told me that they couldn't find anything and that they are flying someone in from Michigan to look it over. They said that they are suspecting the main computer is bad which they may have to change??? I'm still getting frustrated and about to change my mind on the 300c totally.
 

·
Administrator
Joined
·
7,117 Posts
cshflow said:
Well, it's going on 3 weeks now and Friday, the dealer told me that they couldn't find anything and that they are flying someone in from Michigan to look it over. They said that they are suspecting the main computer is bad which they may have to change??? I'm still getting frustrated and about to change my mind on the 300c totally.
If that's the case I'd be telling them to stop wasting my time and their money and replace the main computer NOW or replace the vehicle!
 

·
Registered
Joined
·
48 Posts
Discussion Starter #14
Well, I picked up my 300c on 9/9 and on 9/17 it wouldn't start and the dealership has flown in field representatives from Michigan and they still can't find what's draining the battery as of today. Based on the law, in 30days if they can't fix the problem with a new car in 30 days they have to refund me my ($10K) down or either provide me with a new car... I don't know what to do, I guess i'll have to just wait it out. Has anyone else had this type of problem? See the thread "Picked up on 9/9 won't start on 9/17" for more details.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #15
Good NEWS... They fixed my 300c. I don't pick it up until in the morning, but they told me the problem was a defective Steering Wheel Control Module.
 

·
Registered
Joined
·
1,231 Posts
Yikes!
Nothing like successfully surviving Intensive Care at the hospital, eh? :p
Kinda like when you are hanging up a picture on the wall and you hit your finger with a hammer - feels great when you stop.
Drive on! :D
 

·
Registered
Joined
·
48 Posts
Discussion Starter #18
Well, I just picked it up and everything seems fine for now... They will be tinting my windows next week for me for FREE of course. :)
 

·
Registered
Joined
·
337 Posts
I hate when I hear of others having problems because I really hope that this car lives up to its initial success and I know what a joy it is to drive when it's running smooth. I have over 2000 miles without any serious problems and I hope this continues.
 

·
Administrator
Joined
·
7,117 Posts
cshflow said:
Good NEWS... They fixed my 300c. I don't pick it up until in the morning, but they told me the problem was a defective Steering Wheel Control Module.
Well, no new posts from you today must mean you're out drivin' and survivin' and all the well-wishes worked. Let us know if that is the case... we're all pulling for you!
 
1 - 20 of 27 Posts
Top