Chrysler 300C & SRT8 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all,

over the last 48 hours my heated seats stopped working. the lights on the switches would blink at random and no heat. I replaced the relay in Cavity 5 in the trunk. Same exact type of relay. Yesterday I was driving when I smelled burnt plastic. I had a fire under the passenger seat where the heated seat module is located. Now the car wont start. Power windows and radio wont work and I have a "NO BUS" message. Any ideas on what i can expect from the dealer? No insurance or warranty. This is coming out of my pocket. I have no after market modifications to the car.
 

·
Administrator
Joined
·
13,064 Posts
Sounds like the heating element or harness failed, causing a short. You may not have a warranty claim but it might be a good idea to see if there are any other complaints or similar issues files with the NHTSB.

First things first, they will replace the seat, harness and heated seat element. Then they will have to diagnose the "No Bus" message which tells me there is a relay or failed fuse as part of either the Body Control Module or Front Control Module circuit to the PCM.

The seat work is fairly straight forward and I suspect that will probably be somewhere on the order of 4 - 6 hours of labor per the service book. The diagnostics, on the other hand, may not be as straight forward and may or may not point to another failed component upstream as mentioned above.

Good luck!
 
1 - 2 of 2 Posts
Top