Chrysler 300C & SRT8 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have an 05 300c 5.7L that out of the blue developed an oil pressure and knocking issue . I've had rods go in the past (street racing as a kid) with other cars and don't believe that that is the problem .
Cold start up the engine knocks a couple times and but quits . After that it runs good with no issues . After warm up it begins to get a consistent knock that sounds like it's coming from the bottom of the motor and my oil pressure drops from around 50 down to between 15 and 20 pounds at idle . I tried adding a quart of Lucas oil treatment with no results
Any suggestions ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
I have an 05 300c 5.7L that out of the blue developed an oil pressure and knocking issue . I've had rods go in the past (street racing as a kid) with other cars and don't believe that that is the problem .
Cold start up the engine knocks a couple times and but quits . After that it runs good with no issues . After warm up it begins to get a consistent knock that sounds like it's coming from the bottom of the motor and my oil pressure drops from around 50 down to between 15 and 20 pounds at idle . I tried adding a quart of Lucas oil treatment with no results
Any suggestions ?
[/Q
I have an 05 300c 5.7L that out of the blue developed an oil pressure and knocking issue . I've had rods go in the past (street racing as a kid) with other cars and don't believe that that is the problem .
Cold start up the engine knocks a couple times and but quits . After that it runs good with no issues . After warm up it begins to get a consistent knock that sounds like it's coming from the bottom of the motor and my oil pressure drops from around 50 down to between 15 and 20 pounds at idle . I tried adding a quart of Lucas oil treatment with no results
Any suggestions ?
I don't know maybe I posted in the wrong area but I really expected I would have had a little info or help from somebody
I have an 05 300c 5.7L that out of the blue developed an oil pressure and knocking issue . I've had rods go in the past (street racing as a kid) with other cars and don't believe that that is the problem .
Cold start up the engine knocks a couple times and but quits . After that it runs good with no issues . After warm up it begins to get a consistent knock that sounds like it's coming from the bottom of the motor and my oil pressure drops from around 50 down to between 15 and 20 pounds at idle . I tried adding a quart of Lucas oil treatment with no results
Any suggestions ?
I'm disappointed . I haven't been here in quite some time and thought by now as in the past someone could have shed some light on this problem for me . I am disabled on a fixed income and can't afford a garage . I really need some info before I start tearing into this myself. I'm in big trouble . Plz plz someone help .
 

·
Registered
Joined
·
25 Posts
Personally I would say lower end or cam/lifter related.
Nothing anyone here can say will magically fix your problem. It's going to have to come apart to see what the problem is.
Drain the oil and look for metal.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
That's kind of what I figured . I was just thinking someone else might have had the same issue . It's disappointing . The cars been well taken care of and driven well . Thanks for taking the time to reply though
 

·
Registered
Joined
·
25 Posts
My had a slight tick. One day turned into a spun bearing. I can't believe it drove for 6 months while I had it before it let go. Looking at the heads could tell it dropped the valve seats in the past. Assuming someone dropped in some junkyard pistons and used bearings.
Guy I got it from claimed it was ticking when he got it, and the owner before him said it had ticked for a long time.
Too many possibilities to guess. Lol

Sent from my SM-N960U using Tapatalk
 
1 - 5 of 5 Posts
Top