Chrysler 300C & SRT8 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all.
Just bought myself a preowned 2006 CRD that has been chipped to 308 bhp. Engine runs perfect and it really goes when you put the pedal down. Very satisfied with everything about the car except...
- Tyre preassure warning light is allways on, and tyre preassure reading on the dash is 0.0 for all four wheels.
- From time to time the dashboard lights up like a christmas tree with all warning lights on for a few seconds before disappearing again. Car behavious normally everytime this happens. What could this Be?
- Strange clonking sound from the rear right corner from time to time. Only happens when hitting bumps in the road. But the clonking is not permanent, sometimes its gone for days only to return again. I have removed the spare tyre, jack etc. And checked that the battery is firmly fastened. Any Ideas?

Thanks a lot for all help and advice.

Per from Norway
 

·
Administrator
Joined
·
19,734 Posts
TPMS warning and no pressure readings means the left front transceiver has gone bad or the TPMS module has gone bad. It could be the connector to the TPMS module too.

All the lights coming on and off could be a main harness connection issue at the front control module (FCM) or the powertrain control module (PCM). Check both to make sure they are clean, not corroded, and there are no bent pins.

Sorry, the "clonk" could be anything. Check the exhaust hangers, exhaust pipe clearance, wheelwell splashguards, etc...
 

·
Registered
Joined
·
3,083 Posts
Hi all.
Just bought myself a preowned 2006 CRD that has been chipped to 308 bhp. Engine runs perfect and it really goes when you put the pedal down. Very satisfied with everything about the car except...
- Tyre preassure warning light is allways on, and tyre preassure reading on the dash is 0.0 for all four wheels.
- From time to time the dashboard lights up like a christmas tree with all warning lights on for a few seconds before disappearing again. Car behavious normally everytime this happens. What could this Be?
- Strange clonking sound from the rear right corner from time to time. Only happens when hitting bumps in the road. But the clonking is not permanent, sometimes its gone for days only to return again. I have removed the spare tyre, jack etc. And checked that the battery is firmly fastened. Any Ideas?

Thanks a lot for all help and advice.

Per from Norway
Hi Per,

Possibly all 4 Tyre Pressure Sensors have flat batteries if they haven't been changed since 2006. The batteries are supplied as part of the sensors. Could be a module or wiring fault but difficult to guess. If you could drive for a few miles behind another 300C your module may pick up the signals from the other cars sensors to prove if your module is OK, but its not conclusive.

Dashboard Lights are a bit worrying I would think. Could be a possible bad chassis connection somewhere (Possibly behind the dash).

Clunk could possibly be the exhaust thumping against something underneath, but only a guess.
Rear shocker bushings have been found worn before and sometimes bolts have been found loose. (Check top and bottom)

Good luck in sorting it out and keep us informed please..

Jack
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Thanks a lot for all Help!

i had the same problem with my tpms so i put normal valves in when it needed tyres its a annoyance
I will put in new tyre preassure sensors and see if that solves the issue. It can't be that expensive. All the warning lights that comes on for a few seconds from time to time must be caused by bad grounding somewhere I think as it tends to happen when hitting bumps in the road. The car has aftermarket lowered suspension, that might be the problem with the clonking sound I hear. The exhaust seems to be in order but I will have that checked too. The car goes back to the dealer for checking next week. I will keep you updated.

Thanks a lot for all the input!

Per
 

·
Registered
Joined
·
546 Posts
the sensors were quite expensive there are loads on ebay but none that work with a uk 300c because of the mhz rating
 

·
Registered
Joined
·
3,083 Posts
I will put in new tyre preassure sensors and see if that solves the issue. It can't be that expensive. All the warning lights that comes on for a few seconds from time to time must be caused by bad grounding somewhere I think as it tends to happen when hitting bumps in the road. The car has aftermarket lowered suspension, that might be the problem with the clonking sound I hear. The exhaust seems to be in order but I will have that checked too. The car goes back to the dealer for checking next week. I will keep you updated.

Thanks a lot for all the input!

Per
Its down to personal choice but there is no way I would renew the tyre pressure sensors if mine failed. Many problems are caused by this system and the TPMS transponders can also fail and prevent your car from starting.

I would personally do away with the system if I had problems.
I would unplug the lot and see what happens first in an attempt to fix it. (3 transponders and one module)


Jack
 
1 - 8 of 8 Posts
Top