Chrysler 300C & SRT8 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hi,

My car is at the dealer right now and I just had the news that it has a broken valve spring on cylinder #7!! That sucks!!

I started the car yesterday morning (it was a cold morning) and the car was shaking at idle. Went to work and everything seemed fine when car was hotter... Than, when coming back on that night, the check engine light came on. So I did the key dance to find what code it was throwing: P0307: cyl #7 misfire...

So I decided to leave the car to the dealer, thinking it was maybe the spark plug or coil... Finally, it is a broken valve spring and I need to replace all springs and valve on that head.
Lucky that I didn't have more damage I guess...

I looked a bit on the forum and saw some other spring failures. But has anyone experienced that failure recently?

My srt8 has 80 000 miles and has only minor mods, never had any engine problems yet.

Thanks and have a nice day!
 

·
Currently Away From 300C Forum
Joined
·
19,574 Posts
They had this problem with the early engines. Even Car & Driver had the problem with their Road Test article on the new SRT8. But theirs happened within a 1,000 miles of new I think.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
Thanks guys!

Finally I saw the spring and only a tiny part was broken but still in place. The compression on this
cylinder was zero because the valve could not seal tight anymore. All the other cylinders were at 175 psi.

I am lucky that the valve did not fall into the cylinder...

Anyway, I hope this won't happen to you!

Have a nice winter (just put my winter tires... I hate that!)
 
1 - 5 of 5 Posts
Top