Chrysler 300C & SRT8 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey Guys,

Ongoing issue since November 2020 with multiple things replaced and no answer. Hoping you guys can help.

When driving my 2006 5.7L hemi 300c it stalls/engine stops mid drive. Mostly when driving low speed or sitting idle - engine light comes on temporarily with loss of power.

So far I have replaced EGR sensor, crank angle sensor and camshaft sensor with issues still occurring. We have owned the vehicle for 9 years and it is well looked after.

Would appreciate any help,
Cheers
 

·
Registered
Joined
·
1,080 Posts
Hey Guys,

Ongoing issue since November 2020 with multiple things replaced and no answer. Hoping you guys can help.

When driving my 2006 5.7L hemi 300c it stalls/engine stops mid drive. Mostly when driving low speed or sitting idle - engine light comes on temporarily with loss of power.

So far I have replaced EGR sensor, crank angle sensor and camshaft sensor with issues still occurring. We have owned the vehicle for 9 years and it is well looked after.

Would appreciate any help,
Cheers
Do you have access to an advanced scantool to check for trouble codes?
 

·
Registered
Joined
·
8 Posts
Hey Guys,

Ongoing issue since November 2020 with multiple things replaced and no answer. Hoping you guys can help.

When driving my 2006 5.7L hemi 300c it stalls/engine stops mid drive. Mostly when driving low speed or sitting idle - engine light comes on temporarily with loss of power.

So far I have replaced EGR sensor, crank angle sensor and camshaft sensor with issues still occurring. We have owned the vehicle for 9 years and it is well looked after.

Would appreciate any help,
Cheers
One known issue is a loose fuel tank cap causing these things to stall out, maybe check there
 
1 - 3 of 3 Posts
Top