Chrysler 300C & SRT8 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello everybody, I'm new here and very excited to join this great community. I'm making this post about my 2006 300C SRT8's shifting problem. When I use the auto stick, sometimes, on average about once every 10 times, it just doesn't shift. I'll push it to the right, and it's like it just doesn't register. It doesn't matter if I just started my baby or if she's been running for a little bit, there's no real sign if it's going to shift or not. I'm wondering if a relay is going bad, or what's happened. I got it last July, it's only got 27k on her, but she sat for 5 years after having 21k on her.
Any help or advice would be very greatly appreciated, thank you.
 

·
Administrator
Joined
·
19,734 Posts
Sounds like the control box and contacts may need service.

You also have upshift and downshift solenoids within the transmission that take the signal from the control box and apply hydraulic pressure when activated to change gears.

Normally transmission fault codes occur if the solenoids are bad. My thought is that your shift control box and/or contacts are failing. I'm not sure if that is a service part or if you need to replace the shifter mechanism box under the center console.
 

·
Premium Member
Joined
·
7,943 Posts
I actually had that problem with my 07 model SRT for quite some time. I could never find a pattern to it.
Eventually it bugged me enough that I made the call to book it in and see if they could find the problem.
In that week before it was due to go in it stopped happening so I never did take it in.
The symptom never came back again. Whether yours will do the same is hard to know.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Sweet, thanks for the response guys!! When I drove her today, it didn't happen at all. So who knows. If it happens again, I'll take her in and try to post back to tell ya what it was.
 
1 - 4 of 4 Posts
Top