Chrysler 300C & SRT8 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi,
I searched the forum but could not find my exact issue. So if this is duplicate my apologies.

I have a 2011 300C with 142,000 miles. The transmission is having difficulty shifting into 3rd gear. I initially noticed the issue when going up hills. Around 39 mph the it would get "stuck" and make a noise and vibrate. I have to gas it somewhat to get the car to shift into the next gear.

The issue is getting worse and now occurring on flat, non-hilly roads in the same gear.

I had the same exact problem in 2016 at 78,000 miles. I'm embarrassed to say that I can not recall what the exact solution was. Primarily because it took numerous trips and over 2 months to diagnose. The dealer couldn't figure it out so they kept trying to blame me and said it was driving style...lol... I was able to locate a service bulletin that described the exact issue. I gave it to them and turns out this fixed the problem.

I called the dealer that performed the warranty work and they have no real details on the 4 times I brought it in over 2 months. Seriously.....so frustrating. I think it was maybe an oil pan reseal and valve body???

Does this sound familiar to anyone?

Thank you for your assistance.
 

·
Registered
Joined
·
340 Posts
If this was in 2016 at an FCA dealer, just go here. If you don't have an account, create one, log in, add the VIN and the service record should be right there.
 
1 - 2 of 2 Posts
Top