Chrysler 300C & SRT8 Forums banner
1 - 20 of 39 Posts

·
Registered
Joined
·
241 Posts
Discussion Starter · #1 ·
Question to those with Sport mode only: Is there an update available for your 2012 300 SRT8, if not what is your prod date? If so did the software update gain you both modes?

Question to those with Track and Sport mode: How do you enable track mode? Through Uconnect?


My problem is that on my vehicle under the uconnect screen is says track/sport mode. Once I press the button it only illuminates Sport mode. For some reason it will not let me access Track mode and I'm unsure why. Possible issue? Warranty fix? Just trying to get to the bottom of it.
 

·
Registered
Joined
·
842 Posts
Yep, you push it once you go into sport mode. Believe it or not I think the car feels way to floaty normal mode. I leave mine in sport mode all the time. I think this is how it should feel, nice and tight . Now on the track mode I just push the button again and the checkered flag appears on the EVIC next to the what I would call a shock absorber which is the sport mode symbol. Weird why you can't get to track mode?
 

·
Premium Member
Joined
·
3,791 Posts
I recall hearing some time ago there were versions without track mode. I don't think you can update it, that's just how it is, it's not a fault. I have a 2012 with Sport and track mode and I enable track mode by just pressing the same button again. The button has both Sport and Track written on it one above the other and it changes to highlight which mode it is in. I think my build date is around July '12.
 

·
Registered
Joined
·
372 Posts
If you received a software flash or a new UConnect unit, you may have the Sport / Track button, but only Sport mode functionality. You can check the sticker on your drivers doorjamb for your build date - I'm not sure when the flip-over mid-year for '12 was, but I have a Dec '11 build and no Track mode.
 

·
Registered
Joined
·
386 Posts
Hmmmm........wasn't aware that some '12's had it and some not. I guess it's like the early '13's not having launch mode (mine was one, had it flashed in). I wonder why they can't flash that in? I love the ride of my car in normal mode, but I LOVE track mode. Sport mode firms up the suspension, but track mode does that more and changes the shift pattern (sport mode does not).

I wonder if Johan @ Diablo could program a track mode for you guys??? It would require changes to both the engine and trans computers, but they can do that.........
 

·
Registered
Joined
·
31 Posts
Some 2012s like mine do have sport, and track mode. The launch control I was told by Chrysler is not something that you can program in on 2012s.
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #7 · (Edited)
I recall hearing some time ago there were versions without track mode. I don't think you can update it, that's just how it is, it's not a fault. I have a 2012 with Sport and track mode and I enable track mode by just pressing the same button again. The button has both Sport and Track written on it one above the other and it changes to highlight which mode it is in. I think my build date is around July '12.
I have read that the early 2012 only have sport mode and later 2012 had sport and track. Can you confirm your prod date in your door jam, please? I'm pretty sure those whom do not have track mode do not have that on there Uconnect page. My date is JUN12 and I'm pretty sure mine should have had track mode functionality.

If you received a software flash or a new UConnect unit, you may have the Sport / Track button, but only Sport mode functionality. You can check the sticker on your drivers doorjamb for your build date - I'm not sure when the flip-over mid-year for '12 was, but I have a Dec '11 build and no Track mode.
Interesting. From my understanding those with no track mode only have sport mode visible on the page. However mine has both sport/track mode and I have a JUN12 date. Only issue with mine is when I press the bottom the track mode does not illuminate. What does your page on the Uconnect say? Can you take a picture and post so others are aware?
 

·
Premium Member
Joined
·
3,791 Posts
I stand corrected, my build date is June '12. I have Sport and Track mode. I heard it the other way around to you, I heard the early one did have it and they took it away with the later builds to only have Sport mode.

Anyway, I'm an export version so that may also be a variable.
 

·
Registered
Joined
·
372 Posts
I only have a "Sport" button on the 'Controls" UConnect page between my seat heat / cool options. The SRT Engineers confirmed in a chat Q/A session that the roughly first half of production 2012s to a certain point do not have Track, and it is not a software flash - there is an actual physical difference and retrofit is not possible.
 

·
Premium Member
Joined
·
3,791 Posts
Well that's a bummer for you Spartaa, because track mode is great. lol. I guess you don't want to hear that. :(
 

·
Premium Member
Joined
·
221 Posts
Mine has a build date of Jun 12 also and has sport and track mode. The button on the Uconnect toggles between normal, sport, and track.
 

·
Premium Member
Joined
·
829 Posts
I only have a "Sport" button on the 'Controls" UConnect page between my seat heat / cool options.
Well that's a bummer for you Spartaa, because track mode is great. lol. I guess you don't want to hear that. :(
Actually, for the early build models that only have the Sport mode, it is the same as Track mode. It activates both the firmer suspension and modified shifting. The later builds added the extra option for firmer suspension only and chose to call that Sport mode while calling the original behavior Track mode.

Personally, I want a mode that allows the modified shifting without stiffening up the suspension (since mine is already lowered and stiffer under normal conditions).
 

·
Registered
Joined
·
372 Posts
Actually, for the early build models that only have the Sport mode, it is the same as Track mode. It activates both the firmer suspension and modified shifting.
Indeed it does. :drive:
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #15 · (Edited)
Mine has a build date of Jun 12 also and has sport and track mode. The button on the Uconnect toggles between normal, sport, and track.
Ok so I got my vehicle back today after a coupl of days. So I was wrong. My car does the opposite of what I said it did.

Sport/Track are displayed and once I press the option it activates Track mode only and does not let me select Sport. However the "sport" illuminates on the dash in green but the evic displays "Track mode has been activated..."

Wtf?
 

Attachments

·
Registered
Joined
·
31 Posts
Ok so I got my vehicle back today after a coupl of days. So I was wrong. My car does the opposite of what I said it did.

Sport/Track are displayed and once I press the option it activates Track mode only and does not let me select Sport. However the "sport" illuminates on the dash in green but the evic displays "Track mode has been activated..."

Wtf?
Keep in mind that track mode only shows on the screen, and that the EVIC will display sport mode not track mode.
 

·
Premium Member
Joined
·
3,791 Posts
So if you press the button again you don't get 'Sport' mode? I can press my button 3 times. Once for Sport, once for Track and once to have them both 'off'.

By the sound of what yours does, I think I'd prefer yours. Does it stay in that mode if you turn the car off and back on again?
 

·
Premium Member
Joined
·
829 Posts
Ok so I got my vehicle back today after a coupl of days. So I was wrong. My car does the opposite of what I said it did.

Sport/Track are displayed and once I press the option it activates Track mode only and does not let me select Sport. However the "sport" illuminates on the dash in green but the evic displays "Track mode has been activated..."

Wtf?
Mine does the exact same thing. When I first got my car, it did say "Sport mode activated" in the EVIC (cluster), but after doing a flash update to the EVIC software, it then changed to saying "Track Mode Activated". This is now consistent with the 13+ ones where their track mode is also suspension+transmission.
 

·
Premium Member
Joined
·
829 Posts
By the sound of what yours does, I think I'd prefer yours. Does it stay in that mode if you turn the car off and back on again?
Unfortunately, no.
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #20 · (Edited)
So if you press the button again you don't get 'Sport' mode? I can press my button 3 times. Once for Sport, once for Track and once to have them both 'off'.

By the sound of what yours does, I think I'd prefer yours. Does it stay in that mode if you turn the car off and back on again?
Nope I can press it 5x and it will always be track mode only. No sport. Just track.

Mine does the exact same thing. When I first got my car, it did say "Sport mode activated" in the EVIC (cluster), but after doing a flash update to the EVIC software, it then changed to saying "Track Mode Activated". This is now consistent with the 13+ ones where their track mode is also suspension+transmission.
Well it sounds like to me I've had a update then. But I'm sure the 13+ aren't like this. They can toggle between sport and track. We are just stuck in track which to me isn't right.
 
1 - 20 of 39 Posts
Top