Chrysler 300C & SRT8 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I know my car is out of warranty. I did purchase the most recent map update and I did update the firmware to 7.11. My Unit keeps freezing and restarting. I am an IT technician. I was able to find videos about diagnostic menus. Since it is out of warranty, do you know if there is a way to copy the diagnostic log files to a USB to review them or send them to Uconnect? The USB is connected to the computer but the diagnostics doesn't recognize it. I've tried both a formatted USB and a Garmin update USB.

176542


176543


176544


176545


176546


176548


176549


176550


176551


176552
 

·
Registered
Joined
·
92 Posts
I wouldn't waste time trying to get diag info to send to uconnect (unless they tell you how to do it)

If you did officially "buy" the update, then I would complain to uconnect that their update messed up your radio - that your radio was working fine before their update.

So, regardless if it is out of warranty, they still need to fix the problem because you paid for the map update and it screwed up your radio.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I wouldn't waste time trying to get diag info to send to uconnect (unless they tell you how to do it)

If you did officially "buy" the update, then I would complain to uconnect that their update messed up your radio - that your radio was working fine before their update.

So, regardless if it is out of warranty, they still need to fix the problem because you paid for the map update and it screwed up your radio.
I understand that if I bought the map update I should contact Uconnect. I did and they said it was an issue with the hardware. When I first took it to the dealership, they said it was out of warranty and any repairs or scans would cost money.

I found this menu in the diagnostics and I am trying to copy the files so I can examine what the problem is but the USB disk isn't being recognized.
 

·
Registered
Joined
·
92 Posts
Tell uconnect that it is definitely a software issue because the only thing that changed from when it was working to when it was not working, was their software update - the hardware is the same hardware that was working before the update!

And even if you are able to read the diag info, there really isn't anything that I can think of that you will be able to do to fix the issue because it sounds like the update got corrupted for some reason and the only fix is to re-flashed it with the original factory software.
 

·
Registered
Joined
·
74 Posts
The map updates are supplied by nav-tech, not Uconnect so I would beef it out with them. Last update I purchased changed my format from a Chrysler screen to a Dodge screen. They sent me the wrong update. I’m a Chrysler technician and have sent files over to Chrysler several times and they never helped.
If you purchased it from a dealer and it crashed your head unit, mopar should replace it. You just need to prove it was working before.
 
1 - 5 of 5 Posts
Top