Chrysler 300C & SRT8 Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just bought this car a month ago! It is gorgeous, loaded and fun to drive, however, when the radio malfunctions, it's just another ole boring car.
The Uconnect system will start bouncing from one radio preset to another, it will randomly save a radio station to a preset, if I go to the media screen, it will repeatedly change from repeat to random(or whatever that selection is), among countless other issues. I just wish I could attach a video of this system going haywire, it would be so much easier to understand. It is such a shame for such a beautiful car to have this huge of a problem.
If anyone has a suggestion, a fix or a solution, please let me know. I will be forever grateful!
 

·
Chrysler Customer Service Agent
Joined
·
1,171 Posts
Hi Aud,

We're sorry to hear that this infotainment issue is souring the experience of your Chrysler vehicle. Please send our team a private message with your VIN, mileage, and servicing Chrysler dealer. We would be happy to investigate if there are any available software updates for your Uconnect system.

Darlene
Chrysler Social Care Specialist
 

·
Registered
2014 CRD
Joined
·
1,609 Posts
There's a restore in the settings in the Uconnect screen. Might also be worth a battery disconnect for an hour or so. If you do that please be careful you don't lock the car or shut the trunk without a way to get back in again
 

·
Registered
Joined
·
1 Posts
Hi Aud,

We're sorry to hear that this infotainment issue is souring the experience of your Chrysler vehicle. Please send our team a private message with your VIN, mileage, and servicing Chrysler dealer. We would be happy to investigate if there are any available software updates for your Uconnect system.

Darlene
Chrysler Social Care Specialist
I’m having similar issues. Except my infotainment system freezes and the backup camera doesn’t come on in Reverse anymore (just started a few hours ago). I only have 21,000 miles on this car!!! I would love a number or email for someone that can help.
 

·
Chrysler Customer Service Agent
Joined
·
1,171 Posts
I’m having similar issues. Except my infotainment system freezes and the backup camera doesn’t come on in Reverse anymore (just started a few hours ago). I only have 21,000 miles on this car!!! I would love a number or email for someone that can help.
Hi D Allen,

I'm sorry to hear that you have a similar concern with your infotainment system. If you send me a private message with your VIN, I will check for applicable updates and escalate a case to a Uconnect Specialist for further troubleshooting.

Darlene
Chrysler Social Care Specialist
 

·
Registered
Joined
·
2 Posts
Hi Aud,

We're sorry to hear that this infotainment issue is souring the experience of your Chrysler vehicle. Please send our team a private message with your VIN, mileage, and servicing Chrysler dealer. We would be happy to investigate if there are any available software updates for your Uconnect system.

Darlene
Chrysler Social Care Specialist
I’ve been having issues with my Uconnect not working and the screen freezing. Volume being stuck with no way to turn it off. USB ports lit up but not connecting to my phone. Radio randomly restarting. I took my car to the dealership while under warranty and they claimed to have fixed the issue but 2-3 months afterwards, experienced the same issues. What should I do. I am currently unable to connect my USB and use the awesome Carplay.
 

·
Registered
Joined
·
668 Posts
Bring it in to dealership again. Was probably bad radio.


Sent from my iPad using Tapatalk
 

·
Chrysler Customer Service Agent
Joined
·
1,171 Posts
I’ve been having issues with my Uconnect not working and the screen freezing. Volume being stuck with no way to turn it off. USB ports lit up but not connecting to my phone. Radio randomly restarting. I took my car to the dealership while under warranty and they claimed to have fixed the issue but 2-3 months afterwards, experienced the same issues. What should I do. I am currently unable to connect my USB and use the awesome Carplay.
Since it has been 2-3 months, we do recommend following up with your dealer. However, we can have a case escalated for additional support while you're in service. Once you have an appointment, send our team a private message with your VIN, mileage, and dealer.

Darlene
Chrysler Cares
 

·
Registered
Joined
·
5 Posts
I have a 2017 Chrysler 300 C Platinum 5.7 and I have had it 3 weeks now, only 22,000 miles and it is doing the SAME EXACT THING! It freezing, deleting all my stations, restarting while driving and just going black. What do I need to do? Robert
 

·
Registered
Joined
·
2 Posts
Since it has been 2-3 months, we do recommend following up with your dealer. However, we can have a case escalated for additional support while you're in service. Once you have an appointment, send our team a private message with your VIN, mileage, and dealer.

Darlene
Chrysler Cares
I will make an appointment with them tomorrow and will message you all the details. Thank you for helping out with this. I LOVE my car. Just need this issue resolved.
 

·
Chrysler Customer Service Agent
Joined
·
1,171 Posts
I have a 2017 Chrysler 300 C Platinum 5.7 and I have had it 3 weeks now, only 22,000 miles and it is doing the SAME EXACT THING! It freezing, deleting all my stations, restarting while driving and just going black. What do I need to do? Robert
Hello Cox7215,
We are certainly sorry to hear about your recent concerns. If you could please reach out to us privately we would be happy to escalate your concerns to a Specialist to further assist you. We look forward to hearing from you.
Laura
ChryslerCares
 

·
Registered
Joined
·
1 Posts
Hi Aud,

We're sorry to hear that this infotainment issue is souring the experience of your Chrysler vehicle. Please send our team a private message with your VIN, mileage, and servicing Chrysler dealer. We would be happy to investigate if there are any available software updates for your Uconnect system.

Darlene
Chrysler Social Care Specialist
It's a warranty issue, they say it's a bubble behind the screen!🙂
 

·
Registered
Joined
·
104 Posts
My 2017 300s I bought late last year has no remote Unconnect capabilities and GPS thinks I'm 450 miles N of my location and has no idea what direction I'm driving. The SOS call out button doesn't work either. The cellular signal strength indicator for the unit its self shows no signal.
I bought from Illinois but the local dealerships in Tulsa say the unit has to replaced but it's not covered at 33K miles and want $1,200 plus labor to replace it.

I've reset it and driven in circles in a parking lot and was going to have the dealer update it but they said it would not fix the issues and they wouldn't spend the $140 on the update.
In
 

·
Registered
Joined
·
1 Posts
My 2017 300s I bought late last year has no remote Unconnect capabilities and GPS thinks I'm 450 miles N of my location and has no idea what direction I'm driving. The SOS call out button doesn't work either. The cellular signal strength indicator for the unit its self shows no signal.
I bought from Illinois but the local dealerships in Tulsa say the unit has to replaced but it's not covered at 33K miles and want $1,200 plus labor to replace it.

I've reset it and driven in circles in a parking lot and was going to have the dealer update it but they said it would not fix the issues and they wouldn't spend the $140 on the update.
In
The remote Uconnect and the SOS system only work with a paid subscription. You should be able to use the "Assist" button to connect to them to activate your account. It's a separate subscription from the Sirius music account. But in my opinion it's not worth it. It takes several minutes to just unlock the car - IF it works at all, maybe 3 out of 10 tries in my experience.
 
1 - 17 of 17 Posts
Top