Chrysler 300C & SRT8 Forums banner
21 - 30 of 30 Posts

·
Registered
Joined
·
2 Posts
YouTube link Hello Beautiful people my 2018, 300 is also having the same issue
In the past month it wasn’t as bad, but since the last software update about 2-3 weeks ago, it’s been impossible to use the system with or without Uconnect
Please advise.
 

·
Registered
Joined
·
2 Posts
I am having my the same issue with my 2018, 300, it wasn’t this bad until around 2-3 weeks ago when I installed the latest update for the unconnect system.
It’s impossible to use the system, the touch screen goes haywire, whether it’s on then radio or CarPlay
I wish I could post a video.
But here is a YouTube link of it.


Please advise.
 

·
Registered
Joined
·
1 Posts
I am having same issue with 2017 300. I purchased the car 2 yrs ago and this past year the radio randomly will not turn up or down or off at times. the air will not work, button will not turn off . the backup camera stays on even though its in drive. it has 23000 miles on it. it is not under warranty any longer due to its a 2017 . i have not taken to a dealer for the issue yet. but i have noticed in the right corner what looks to be a bubble that will not go away. After looking into this issue , it seems to be very common for 2017 chrysler , jeeps and chargers.
 

·
Chrysler Customer Service Agent
Joined
·
938 Posts
Hello,

We came across this thread and are extremely sorry to hear about the concerns you two are experiencing. If either of you are currently working with your dealer to get these concerns addressed and would like additional assistance, please don't hesitate to let our team know via private message! We'd be happy to look into it for you.

Courtney
Chrysler Cares
 

·
Registered
Joined
·
3 Posts
Hello,

We came across this thread and are extremely sorry to hear about the concerns you two are experiencing. If either of you are currently working with your dealer to get these concerns addressed and would like additional assistance, please don't hesitate to let our team know via private message! We'd be happy to look into it for you.

Courtney
Chrysler Cares

I am having major issues with my Uconnect system that is causing driving hazards. The Uconnect screen will freeze randomly causing me to lose my backup camera and signal the parking sensors into slamming on my brakes for me when no one is even around the vehicle. I constantly lose connectivity for both Bluetooth and Carplay. At times I have no choice but to use GPS on my cellphone while driving. The sound will not work, can’t change stations, or move between apps on the screen. AC controls become inoperable due to not being able to change screens. I reboot the Uconnect but it lasts for a short period of time before it goes haywire again. I have checked on the Uconnect site for updates, but it states there isn't any. This is almost on a daily basis now with a car that has less than 10,000 miles on it.
 

·
Registered
Joined
·
3 Posts
Sounds like my exact problem. Dealer switched out the radio for a second time and still no improvement.
Do you still have a warranty with Chrysler? Mine has run out and I'm afraid to take it to the dealer just to have them tell me it will cost $1500 plus labor to replace....
 

·
Registered
Joined
·
4 Posts
I have extended warranty but don’t think this was covered by that as it has been a well documented issue since I bought the vehicle in 2017.
 

·
Chrysler Customer Service Agent
Joined
·
938 Posts
I am having major issues with my Uconnect system that is causing driving hazards. The Uconnect screen will freeze randomly causing me to lose my backup camera and signal the parking sensors into slamming on my brakes for me when no one is even around the vehicle. I constantly lose connectivity for both Bluetooth and Carplay. At times I have no choice but to use GPS on my cellphone while driving. The sound will not work, can’t change stations, or move between apps on the screen. AC controls become inoperable due to not being able to change screens. I reboot the Uconnect but it lasts for a short period of time before it goes haywire again. I have checked on the Uconnect site for updates, but it states there isn't any. This is almost on a daily basis now with a car that has less than 10,000 miles on it.
Sounds like my exact problem. Dealer switched out the radio for a second time and still no improvement.
We're saddened to hear that you two are experiencing concerns and have not had much luck with getting this resolved. While we'll continue working with @Tay Landry on his concerns, we'd like to look into your concerns as well, @ObnoxusOne ! Please follow up with our team privately so we can collect your VIN and software information.

Thanks in advance,

Courtney
Chrysler Cares
 
21 - 30 of 30 Posts
Top